Front panel audio out + mic not working (Realtek 1220 on MSI mb)


  1. Posts : 1
    Windows 10
       #1

    Front panel audio out + mic not working (Realtek 1220 on MSI mb)


    Hi all,

    Hoping for some solid help here with with my new Ryzen build... Reddit didn't have the answer (so far) and MSI Forums neither, but I realised that Tenforums have this excellent Sounds and Audio section Fingers crossed, because right now I'm totally stuck - and reading here it seems that Realtek in general can be tricky...

    Problem - from the front panel jacks, I get no audio out nor does the mic work. Audio out from the rear panel works, as does the mic. I have a speaker setup which I need to connect to the rear panel.

    My build is brand new, consisting of MSI MEG X570 ACE (so Realtek 1220 audio), Ryzen 3700X, MSI 2080 Super Gaming X Trio, G.Skill 3200C14 2x16Gb, Samsung EVO 970+ and all that is housed in a Fractal Define R6. I installed Windows 10 Pro fresh. I've upgraded to latest (non-beta) BIOS from the MSI site.

    So what I've done (roughly in order):
    - Right after first Windows boot, installed all the latest MSI drivers incl the Realtek audio one. No audio on front panel jacks.
    - Uninstalled all Realtek drivers/software, downloaded a (slightly) newer Realtek driver from Station Driver and installed. No audio from front jacks.
    - Uninstalled, cleansed the system acc to Realtek Audio Console REQUIRES a Realtek HD (UAD) Driver!!
    - Reinstalled the MSI drivers - and of ocurse no audio from front jacks.
    - Obviously checked the cabling. It's "HD Audio", connected to the right MB contact, and the connector sits firmly in place (I've pulled it off and pushed it back on again a couple of times).
    - Tried unplugging the headphones & mic and plugging them in only after WIndows has started (suggestion found on the net somewhere)



    The weird thing is that I can see that the jacks are detected, ie when I insert the headphones it properly detects the headphones and same with the mic... Just no audio output. To me that means that the jacks themselves are working, as is the MB? I've been looking for an "audio level" to adjust somewhere, but the Realtek device is just one single device (plus the Digital Output one) with just one level.

    A quick google revelas that this is apparently very common, but there seems to be a bazillion different more or less helpful hints, suggestions et.c. The reasonable ones are the ones I've tried... without success. My previous build with an ASUS Z170 Deluxe mb also had Realtek and front panel jacks, never had a single issue with those over the four years I've had the build.

    Anyone....??
      My Computer


  2. Posts : 1,277
    Windows 10
       #2

    Please provide the appropriate diagrams of pins of the board and wires of the case and version of driver you have installed and a print screen of "Recording" tab in "Sounds" window after ticking both "Show Disabled Devices" and "Show Disconnected Devices" .
      My Computer


  3. Posts : 12,459
    Win10 Version 21H2 Pro and Home, Win11 Pro
       #3

    I've seen a few times where merely shutting down, pulling the power cord out, waiting a minute for residual power to drain from the motherboard, unplugging that front panel cable from the motherboard, plugging it back it, plugging in the power cord then starting the computer put things right.
      My Computers


  4. Posts : 2,505
    Win 11 Pro
       #4

    Since its a new build, the case front panel jacks or cabling could be the problem, if its connected properly to the motherboard (and preferred connector is HD Audio rather than older AC97 connector in some case wiring). I had a new Corsair case with a defective front panel on one build.
      My Computers


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 05:51.
Find Us




Windows 10 Forums