I thought I'd just put in an update about the May 2019 1903 update.

I ran the installation on both my laptop and my desktop. Everything went well for both computers except when I tried to watch a YouTube video on my desktop, I noticed my audio was gone. The computer had not recognized my USB 3.0 external audio interface the Zoom UAC-2 3.0 USB. When this has happened in the past, I've unplugged the USB cable, waited a few seconds and plugged it back in and it worked. This time it didn't.

So I plugged it into one of my other 3.0 USB ports. Nothing. I tried ALL of my USB 3.0 and 2.0 ports. Nothing. I tried rebooting the machine several times. Nothing. Then I plugged it into my USB 3.0 Hub (something you are NOT supposed to do with an external audio device) and it worked! While the computer was recognizing the Zoom, I unplugged the USB 3.0 cable and plugged it back into the original USB 3.0 port on the motherboard and it still worked.

I don't know what voodoo this is but is there a better way to get an update to re-initialize devices on USB ports?