Sound Blaster X-Fi Titanium HD not working properly in Windows 10 Insi

Page 3 of 4 FirstFirst 1234 LastLast
  1. Pulcinella's Avatar
    Posts : 180
    Windows 10 Home x64 2004
       #21

    Urbwolf said:
    Did reinstalling drivers work for you?
    Nothing helped. I tried all the tricks on the books, out there online, nothing works.
    I keep getting:
    Attachment 234686

    PS:
    This is what I have and was working before upgrade.
    PCIe SB X-Fi Titanium, Driver version 2.40.15

    - - - Updated - - -

    [QUOTE=boombastik;1628729]-https://www.touslesdrivers.com/index.php?v_page=23&v_code=61161
    Drivers Creative Sound Blaster X-Fi Titanium HD 3.00.2022B WHQL beta[/QUOTE
    @boombastik.
    Thanks for the link. Good place to keep up to date for late developments. Unfortunately my version has not been fixed yet.

    - - - Updated - - -
    @Urbwolf
    Don't ask me how I did it but downloaded :
    Drivers Creative Sound Blaster X-Fi Titanium 2.40.0018 WHQL
    Installed and by my pleasure and surprise it works now.

    Here the link:

    Drivers 2.40.0018 WHQL pour les cartes sons Creative Sound Blaster X-Fi Titanium et Windows 10
      My Computer

  2. boombastik's Avatar
    Posts : 323
    Windows 10 X64 latest
       #22

    1)

    • Sound Blaster X-Fi Titanium (SB0880)
    • Sound Blaster X-Fi Titanium OEM (SB0881)
    • Sound Blaster X-Fi Titanium OEM (SB0883)
    • Sound Blaster X-Fi Titanium OEM (SB0887)
    • Sound Blaster X-Fi Titanium OEM (SB0889)
    • Sound Blaster X-Fi Titanium Fatal1ty Champion Series (SB0886)
    • Sound Blaster X-Fi Titanium Fatal1ty Professional Series (SB0886)
    • Sound Blaster X-Fi Titanium Professional Audio (SB0888)

    Driver 2.40.0018 WHQL

    2)X-fi titanium HD (SB1270)
    driver 3.00.2022B

    3)
    X-Fi XtremeGamer Fatal1ty Professional Series pci

    X-Fi Platinum Fatal1ty Champion Series pci

    X-Fi XtremeMusic pci

    X-Fi XtremeGamer pci

    X-Fi Platinum pci

    X-Fi Fatal1ty pci

    X-Fi Elite Pro pci

    X-Fi Elite pci

    Drivers: Box







    Last edited by boombastik; 25 May 2019 at 01:58.
      My Computer

  3. boombastik's Avatar
    Posts : 323
    Windows 10 X64 latest
       #23

    drivers for x-fi pci:
    -https://creative.box.com/s/fxzp6tmp6nzxrzao7faknmt7b0oc6a4t
    Last edited by essenbe; 05 Jun 2019 at 20:59.
      My Computer


  4. Posts : 1
    Windows 10 Pro
       #24

    I'll waiting driver X-Fi XtremeGamer.
      My Computer

  5. boombastik's Avatar
    Posts : 323
    Windows 10 X64 latest
       #25

    drivers for x-fi pci includes x-fi pci gamer sb0730.I already post them above your post .
      My Computer


  6. Posts : 1,128
    Windows 7 Home Premium x64
       #26

    saotsubasa said:
    I'll waiting driver X-Fi XtremeGamer.
    updated driver for XtremeGamer already available from the link boombastik mentioned earlier
      My Computers



  7. Posts : 7
    Windows 10
       #27

    BIG thanks to @boombastik for the driver link, just installed v1903 and was about to rollback to 1809 when I saw your link so will give it a go :)
      My Computer


  8. Posts : 1,128
    Windows 7 Home Premium x64
       #28

    X-FI Titanium HD driver 3.00.2022 officially released on Creative support site June 7 (supports 1809, 1903 & later):
    Creative Worldwide Support

    -for X-FI Titanium HD sound card only
      My Computers

  9.    #29

    Hello,

    Thanks to drivers from @boombastik my X-Fi XtremeGamer was successfully instaled, but Dolby Digital and DTS encoders stoped working :/ License is activated, there is a tab with encoders in Control Panel, but after i try to select one after a few seconds it automaticaly returns to "off" :/ I have my card pluged in to AV Receiver via Spdif/Toslink and i need those encoders to have a sound. Can samebody help me with that?
      My Computer


  10. Posts : 2
    Windows 10 1903 x64
       #30

    Hi boombastik,
    Thanks for the drivers for X-Fi XtremeMusic, unfortunately they are not working quite right - channels are not assigned to the right places, so they need to be reassigned, but after reassigning there is an issue with the rear right channel (it's not a speaker issue for sure).
    Attached Thumbnails Attached Thumbnails Sound Blaster X-Fi Titanium HD not working properly in Windows 10 Insi-annotation-2019-06-08-212129.jpg  
      My Computer


 

Related Threads
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 07:37.
Find Us




Windows 10 Forums