Sound Blaster X-Fi Titanium HD not working properly in Windows 10 Insi

Page 2 of 4 FirstFirst 1234 LastLast
  1.    #11

    boombastik said: View Post
    1)danielK drivers are whql but with one installer have all new drivers control panels etc together.
    2)titanium hd works without drivers also with simple hd drivers form microsoft in device manager have the name hight defention audio.
    3)reinstall the daniel k drivers.
    Hey, I am sorry for reviving such an old thread, but I own the mentioned soundcard and am wondering how to use it without the drivers from Creative? I can't get it to work with the default HD drivers from Microsoft. The soundcard is recognized but no sound is coming through.

    Drivers from Creative are sadly not compatible with recent Windows 10 versions.
      My ComputerSystem Spec


  2. Posts : 590
    Windows 7 Home Premium x64
       #12

    maybe try contacting Creative themselves and see if they have plans to release new drivers for the X-FI Titanium HD in 2019, though it could be a longshot.
      My ComputersSystem Spec


  3. Posts : 590
    Windows 7 Home Premium x64
       #13

    a follow up - it seems Creative may be in the process in making newer drivers for X-FI Titanium HD as I just came across this recent thread from Reddit; no timetable as to when Creative will actually post new drivers for this specific Creative sound card:

    X-Fi Titanium HD drivers for 1903 : when ? : SoundBlasterOfficial
      My ComputersSystem Spec

  4.    #14

    -https://www.touslesdrivers.com/index.php?v_page=23&v_code=61161
    Drivers Creative Sound Blaster X-Fi Titanium HD 3.00.2022B WHQL beta
      My ComputerSystem Spec

  5.    #15

    Creative has updated drivers for legacy devices. I am using Xfi titanium fatality pro and there new drivers with the beta audio console work fine.
      My ComputerSystem Spec


  6. Posts : 590
    Windows 7 Home Premium x64
       #16

    Urbwolf said: View Post
    Creative has updated drivers for legacy devices. I am using Xfi titanium fatality pro and there new drivers with the beta audio console work fine.
    X-FI Titanium & Titanium HD, yes. (these do have updated drivers)
    X-FI XtremeGamer, XtremeMusic, XtremeAudio, NO
      My ComputersSystem Spec


  7.    #17

    erpster4 said: View Post
    X-FI Titanium & Titanium HD, yes. (these do have updated drivers)
    X-FI XtremeGamer, XtremeMusic, XtremeAudio, NO
    Audigy 2 and Audigy 4 YES Working see:
    https://answers.microsoft.com/en-us/...eb8cb8b?page=2
      My ComputerSystem Spec

  8.    #18

    Because audigy rx is an audigy 4 with a plx bridge pci to pcie. Also it works with audigy 2 because all the differences from audigy 4 is in hardware and transparent to software.
      My ComputerSystem Spec

  9.    #19

    Lost Creative Sound Blaster X-FI Titanium after upgrade to 1903.
    Following up on @erpster4post#16 link for hopefully soon coming good news.
      My ComputerSystem Spec

  10.    #20

    Pulcinella said: View Post
    Lost Creative Sound Blaster X-FI Titanium after upgrade to 1903.
    Did reinstalling drivers work for you?
      My ComputerSystem Spec


 
Page 2 of 4 FirstFirst 1234 LastLast

Related Threads
Hello there, As in the title: I have lost sound after latest Windows 10 update, which happened yesterday (23rd June 2017) - I am using Creative Sound Blaster Z sound card. I have tried reinstalling the drivers, then reinstalling the device, then...
My Creative Sound Blaster PCI Express X-Fi Titanium worked just fine with Win 10 (64-bit) prior to the so-called "Anniversary Update" Any solutions would be appreciated.
Hi, My Sound Blaster Audigy 4 Pro. I wanted to ask if there is Driver or something better and that works for the sound card Creative Sound Blaster Audigy 4 Pro. Here are the Driver for the Creative Sound Blaster Audigy 4 upgraded to Windows 10,...
Hi, I just bought this sound card and installed drivers for Windows 10. (and a crapton of bloatware with UI of Win XP media player...) Everything works well except one thing: when I change the sound (or mute) I don't see Windows 10 volume bar. I...
Hello -- After I upgraded to Windows 10 from 7 Pro, there was no sound. Obviously, Creative Labs has yet to release compatible drivers for many of their sound cards. Nevertheless, I found out that I'd make it work by changing its modes back and...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 23:41.
Find Us