Disconnected device sound keeps happening every few seconds

Page 1 of 2 12 LastLast

  1. Posts : 36
    Windows 10
       #1

    Disconnected device sound keeps happening every few seconds


    This is literally driving me to insanity.

    I'm just using the pc normally and i keep hearing the sound that you hear when you disconnect a usb device.

    It happens every few seconds. I opened up device manager, nothing abnormal there, but when ever i hear the disconnected device sound, the device manager refreshes the list.

    I noticed also the task bar of open windows flash when it happens. I dunno why this is happening, it is driving me insane. Please help i need solutions to this problem, i don't know where to being to solve this problem.
      My Computer


  2. Posts : 482
    Windows 10 Home
       #2
      My Computer


  3. Posts : 36
    Windows 10
    Thread Starter
       #3

    This is what i got:

    Disconnected device sound keeps happening every few seconds-capture.jpg

    So thats the culprit but i don't know what that is ?
      My Computer

  4. EyeInTheSky's Avatar
    Posts : 737
    Windows 10 Home x64 - Version 21H1 (OS Build 19043.1288)
       #4

    In the lower right taskbar, right click on the speaker icon and select "Sounds":


    Disconnected device sound keeps happening every few seconds-taskbar.png


    That will pull up this:


    Disconnected device sound keeps happening every few seconds-windows-sounds.png


    Scroll to "Device Disconnect"


    Then "Windows Hardware Remove" will be shown under the word "Sounds:"


    Disconnected device sound keeps happening every few seconds-settings.png


    Just click the scroll down arrow and select "none" for the Hardware Remove sound.


    This is a work-around until you figure out what is causing it.


    Look in your "Reliability Monitor" also for problems that point to your circumstances.
      My Computer


  5. Posts : 36
    Windows 10
    Thread Starter
       #5

    Doesnt that just hide the annoyance but not solve the fault ?
      My Computer

  6. EyeInTheSky's Avatar
    Posts : 737
    Windows 10 Home x64 - Version 21H1 (OS Build 19043.1288)
       #6

    SirChick said:
    Doesnt that just hide the annoyance but not solve the fault ?
    I did say it was a work-around until you figure out what is causing it.
      My Computer



  7. Posts : 36
    Windows 10
    Thread Starter
       #7

    Or sorry didn't see that :) Thanks !
      My Computer


  8. Posts : 482
    Windows 10 Home
       #8

    Press the Windows and "R" keys simultaneously, type "devmgmt.msc" into the "Run" box and click "OK". When Device Manager starts, click "View", "Show hidden devices" and see if there are any unknown devices or a device with a yellow exclamation point. If so, right-click it and disable it.

    Ben
      My Computer


  9. Posts : 36
    Windows 10
    Thread Starter
       #9

    This is all i found which seemed a bit off, but theres no exlamation point on the icons:



    But even then that device is disabled. Pretty sure it will automatically appear again if i remove and reboot too.
      My Computer


  10. Posts : 482
    Windows 10 Home
       #10

    Right-click the device and see if it has a power management option. If so, change it. Also, disabled devices usually have a red "X" on them.

    Ben
      My Computer


 
Page 1 of 2 12 LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 05:49.
Find Us




Windows 10 Forums