USB Connect/Disconnect Sound


  1. Posts : 3
    Windows 10
       #1

    USB Connect/Disconnect Sound


    Hello All,
    I just built a new system last week and everything is working correctly with the recent drivers and all.
    I'm having a problem with the USB Connect/Disconnect sound, it's not coming up when I connect or disconnect a USB flash Drive or HDD. Everything else is working correctly including sound in all apps and games.
    Worth to mention that in the first couple of days after the build, the connect/disconnect sound was working as it should.
    I've had this issue with my previous system as well.
    My Windows 10 version is 1709 (16299.371) I guess some update messed with the USB sound.
    Any way to resolve this?
    Thank you kindly.
      My Computer

  2. Masterchiefxx17's Avatar
    Posts : 516
    Windows 10 Professional 64bit
       #2

    Hi and Welcome to TenForums!

    It could be a problem with the chipset drivers. I would recommend installing the latest chipset drivers from your motherboard manufacturer's website.
      My Computer


  3. Posts : 3
    Windows 10
    Thread Starter
       #3

    Thank you for your reply. I already made sure I have the latest drivers, including the Intel Chipset. The current version I have is 10.1.1.45 which is the latest on MSI website. (My mobo is MSI Z370 Gaming Pro Carbon)


    Masterchiefxx17 said:
    Hi and Welcome to TenForums!

    It could be a problem with the chipset drivers. I would recommend installing the latest chipset drivers from your motherboard manufacturer's website.
      My Computer

  4. spunk's Avatar
    Posts : 3,418
    Windows 11 Pro 64 Bit 21H2
       #4

    Go to Control Panel/Sounds/Sounds tab. scroll down to Device Connect and Device Disconnect. If there isn't a sound associated with it, (ie) a speaker icon next to it, then choose the Browse button and choose whatever sound you want. Default is Windows Hardware Insert, and Remove respectively.
      My Computer


  5. Posts : 3
    Windows 10
    Thread Starter
       #5

    Thank you for your reply. I already checked this and everything is as it should be. the sound is set and it plays fine on test. However I don't hear it when I connect and disconnect my USB drives.


    spunk said:
    Go to Control Panel/Sounds/Sounds tab. scroll down to Device Connect and Device Disconnect. If there isn't a sound associated with it, (ie) a speaker icon next to it, then choose the Browse button and choose whatever sound you want. Default is Windows Hardware Insert, and Remove respectively.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 16:32.
Find Us




Windows 10 Forums