Windows 10: Cannot remove apps using Appx after Fall Creator Update Solved

  1.    04 Dec 2017 #1

    Cannot remove apps using Appx after Fall Creator Update


    I do not know if others have come across this problem, but it seems that remove-appxpackage no longer works to remove the UWP downloaded by the system.

    The command runs thru with its usual error message about being unable to remove some, but these aren't in that list.
    Also get-appxpackage -allusers | remove-appxpackage no longer seems to work. Or at least it doesnt remove the apps from all users any longer.
      My ComputerSystem Spec

  2.    10 Dec 2017 #2

    I tried your code and it removed some apps, but it didn't remove other things like "Bubble Witch 3 Saga", "Disney Magic Kingdoms", etc. Is that what you mean?

    I have found that "Remove-AppXPackage" works best when used before installing Windows. Either in sysprep Audit Mode, or editing the offline wim directly. This is the command I use to remove apps from a mounted image:
    Code:
    Get-AppXProvisionedPackage -Path "C:\Mount" | Where-Object {$_.PackageName -NotLike "*Microsoft.WindowsStore*"} | Where-Object {$_.PackageName -NotLike "*Microsoft.WindowsCalculator*"} | Where-Object {$_.PackageName -NotLike "*Microsoft.MicrosoftStickyNotes*"} | Remove-AppXProvisionedPackage

    This also has to be used in conjunction with the "Turn off Microsoft consumer experiences" computer policy. For servicing an offline wim, it can be translated as a reg value like this:
    Code:
    REG ADD "HKLM\%MountedSoftwareHive%\Policies\Microsoft\Windows\CloudContent" /v "DisableWindowsConsumerFeatures" /t REG_DWORD /d "1" /f

    If that part isn't there, "Candy Crush" or whatever is still going to install itself within a few minutes of connecting to the internet. I am normally doing this with an Enterprise image in a domain environment that includes lots of other modifications. I tried it today with an x64 Pro ISO downloaded from the Media Creation Tool. Besides having to convert "install.esd" to "install.wim", it appears to work the same. When I first signed into my test machine, the Start menu looks like below. After over an hour there are still no new apps installing themselves.

    Click image for larger version. 

Name:	VirginInstall.png 
Views:	1 
Size:	62.3 KB 
ID:	167629
      My ComputerSystem Spec

  3.    12 Dec 2017 #3

    OK. I dont know what I was doing wrong, but the command started working again.

    Thanks for that info. I will definitely do that on the next image.
      My ComputerSystem Spec


 

Related Threads
Fall Creator's Update and Sound in Windows Updates and Activation
I finally got the 1709 Fall Creator's Update on my Dell Optiplex 330. At first, I thought it was flawless, but then realized that my "Line In" sound wasn't working, which I use on a regular basis, even though no errors were being shown in Device...
fall creator update in Installation and Upgrade
Is there a general chart which might give info on when i would get fcu. I went from 7 to 10 just a couple weeks before free 10 stopped.
Solved How do I get the Fall Creator's Update..... in Installation and Upgrade
.......and is it included with the most recent version of Windows 10 that I get with the Media Creation Tool?
USB3 bug in Fall Creator's Update in Drivers and Hardware
I have the problem described in http://www.drivethelife.com/windows-10/fix-usb-3-0-not-working-recognized-windows-10-creators-update.html on both a desktop and laptop. I tried all the fixes it describes and none of them work. Is anyone aware of a...
I have been seeing a few posts about the Fall Creator update and the various problems or no problems. Mine was that I had updated to W10Pro so I could use whatever drivers I wanted to. But with the first Creator update I couldn't install any NVidia...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 06:29.
Find Us