We have been using the Mail & Calendar app for our users on LINX1010 devices, the email address's are setup through exchange and work fine when I send the devices out.

However I am getting a number of users calling me to say there is a problem with the app and that they're emails won't sync or that the app is stuck syncing, the mail app won't open or you are unable to enter any account settings for the email account.

These devices have Vodafone roaming SIM's & go on WI-FI when they are in our depots however they still seem to get the issues with syncing no matter what connection they have... I can connect to the devices remotely and take a look but whenever you hit sync the dots at the top of the screen just constantly flow without stopping. I don't think it's an issue with the internet connection as I can connect to the device, websites load and other apps have no other issues... just the mail app!!

I have also seen the mail app not open at all, I try and reset the app through the settings, restart the device and then see if this resolves the issue, most of the time it does but other times the app still fails to open. (I have removed the Windows Store from the devices via Powershell so don't know if this affects it?)

Another issue I have had was that a user hadn't received emails for 5 days, I tried to get into his account settings on the app however as soon as you click the account name it wouldn't do anything, click again, again, again.... It just flickers and nothing happens! I tried to add the account via Accounts in settings, entered all of the details and then I just got the constant flow of blue dots at the top of the screen for 10 minutes before giving up.

I keep getting a lot of problems with the app and having trawled through Google I haven't been able to find a fix for any of the issues yet. Has anyone else had these problems and have any idea how to solve them?