1.    4 Weeks Ago #1

    Win 10 1709 Settings app starts then crashes.


    I've just upgraded my Dell Latitude E6420 laptop from Win 10 Pro 1607 to 1709.

    The only problem I've found is that I can't run the Settings app.

    It starts, shows the blue 'flash' screen, then disappears. Watching Task Manager processes during this the Windows Problem Reporting process runs for a few moments. Using the Windows Event Viewer there are error logs each time I try this. The log entry is:

    Faulting application name: SystemSettings.exe, version: 10.0.16299.15, time stamp: 0x7640753d
    Faulting module name: SettingsEnvironment.Desktop.dll_unloaded, version: 10.0.16299.15, time stamp: 0x10c58cc4
    Exception code: 0xc0000005
    Fault offset: 0x00000000000290b3
    Faulting process ID: 0x1d5c
    Faulting application start time: 0x01d34aa0e9bfd967
    Faulting application path: C:\Windows\ImmersiveControlPanel\SystemSettings.exe
    Faulting module path: SettingsEnvironment.Desktop.dll
    Report ID: ad1a99ce-e839-4117-94e9-73d445125956
    Faulting package full name: windows.immersivecontrolpanel_10.0.1.1000_neutral_neutral_cw5n1h2txyewy
    Faulting package-relative application ID: microsoft.windows.immersivecontrolpanel

    I've run sfc /scannow and it gave a clean bill of health.

    I can't find any reference to this problem in a Win 1709 context. Any thoughts?
      My ComputerSystem Spec
  2.    4 Weeks Ago #2
    Join Date : Jan 2015
    Posts : 382
    Windows 10 Home x64

    First thought was restore but that's in the application that won't respond. I guess since you've done the scannow you could try this,
    Use DISM to Repair Windows 10 Image Performance Maintenance Tutorials

    Sounds like something is corrupt, and might be fixed with the DISM repair. It won't hurt anything to try it.

    Hopefully there's some other suggestions forthcoming from some of the more knowledgeable members.
      My ComputersSystem Spec
  3.    4 Weeks Ago #3

    This is weird! After rebooting the laptop in various ways and trying various things over the weekend I left it.

    This morning I had an idea and brought it up in Safe Mode - some months ago I'd added Safe Mode option to the Start Up options screen. And guess what! Settings worked.

    So I tried it in various ways, then closed down and restarted in normal mode. And Settings works.

    I've tried various Settings features and they appear to be OK.

    So goodness knows why it didn't work earlier. I can only think that Safe Mode somehow 'fixed' it. Though I can't see how.
      My ComputerSystem Spec
  4.    4 Weeks Ago #4
    Join Date : Oct 2017
    Posts : 2
    Windows 10 (64-bit)

    tpriest,
    Is it Pro version of Windows 10 that you use?
      My ComputerSystem Spec
  5.    4 Weeks Ago #5

    Yes, it's Win 10 Pro
      My ComputerSystem Spec
  6.    4 Weeks Ago #6
    Join Date : Jan 2015
    Posts : 382
    Windows 10 Home x64

    Well sounds like good news all the way around, seems the issues you've posted about have resolved themselves, "came clear" so to speak.

    It'd be nice to know exactly what the root cause was, and what action fixed it, but sometimes you have to take what you get. In this case it worked out.
      My ComputersSystem Spec
  7.    4 Weeks Ago #7
    Join Date : Jul 2015
    Posts : 1,598
    Windows 10 Pro (64 bit)

    Maybe safe mode cleared some kind of corrupt cache out here. But it is funny how something can just decide to work. I had the same issue with the lock screen and ‘get help’ app they never worked, always crashing. Our of nowhere one day they start working again. No changes, I did nothing. Relief but also frustrating that windows 10 is such a fragile and unpredictable animal !
      My ComputerSystem Spec
  8.    4 Weeks Ago #8
    Join Date : Oct 2017
    Posts : 2
    Windows 10 (64-bit)

    tpriest,
    This may be caused by making some change in restriction policies, e.g. deleting path rule.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
My settings screen starts to show, then disappears.
Hello, I'm new to the forum. I just wondered if this issue I am having with my settings screen is a common problem, and if there is a fix for it? I just upgraded my system yesterday, from Windows 7 to Windows 10, and I wanted to go into the settings...
Performance & Maintenance
Solved Edge starts then crashes
Win 10 Pro x64 Version 1607 Build 14393.187 Edge starts and then crashes. It brings up the Edge banner screen for about 1 second then shuts down. I can find 3 event logs that are associated with this but I can't get to the next step and work out...
Browsers and Email
Settings / Accounts Page Crashes and Does Not Load
Hi there Got a niggly problem with my W10 Pro install. It's not a show stopper but any advice would be appreciated. As the title says, if you go into Settings, Accounts, it does not load. I've got no idea where to start. It's irritating more...
User Accounts and Family Safety
When Excel 2007 starts Windows Installer also starts
Hi, after upgrading from Win7 Ultimate with Office 2007 to Won10 pro, every time I star Excel or Word or PowerPoint the Windows Installer screen appears and then asks for Microsoft Visual Studio Team System 2008 Development Edition.ENU disk. ...
Software and Apps
Bug: Settings app crashes
Whenever I go to the "Settings" app, then click on "Update & security" and then, if I immediately click on "Windows Defender", after a few seconds the app crashes.
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 11:57.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums