Page 1 of 3 123 LastLast
  1.    18 Sep 2017 #1
    Join Date : Aug 2017
    Posts : 35
    Windows 10 Pro 1511...to...1703 (10.0.15063)

    Windows 10 Photos App failed after editing with Paint.


    I captured printscreens yesterday and pasted to paint, then added some remarks etc and saved it from paint as .JPG files. This went all well, no problems opening them afterwards.

    1-Today I opened one of these files, I want to do some more editing on it and close it (.JPG still)
    2-I then re_open the file using PAINT to edit it, I then made some changes.
    3-I then saved the changed PAINT-PIC as .JPG again with extra file name to differentiate between this and original
    file, ok its done.

    4-When I now tried to open any .JPG file with Win 10 Photo App, just a temp black screen and app crashed.

    My temp selution:
    Before I tried a restore, I done this:
    1-I open the .JPG file with "Open With", then chose the Apple viewer, and associate all .JPG files with it.
    2-Now I can see the photos again, but what I dont liked was I cant use the arrows to page to next photos.

    Surprise:
    3-I the open .JPG photo again with "Open With" and assoccioate all .JPG's with Win 10 Photo-App.
    4-To my surprise it now works again.

    Entry in Eventviewer(Multile).

    Faulting application name.Microsoft.Photos.exe
    Faulty module name unknown etc......

    For information & anybody nows more about this failure what looks like an file association mishap from a photo changed with paint to .JPG saved, opened & changed with paint(Only as BMP for this photo), then saved again as .JPG.
      My ComputersSystem Spec
  2.    18 Sep 2017 #2
    Join Date : Aug 2017
    Posts : 35
    Windows 10 Pro 1511...to...1703 (10.0.15063)
    Thread Starter

    Ok, it just decided to fail again, after it worked a few times. I deleted the suspect .JPG file I edited, but no change.

    I do not want to do a System restore yet.

    How do I get the WIN 10 Photo reinstalled or fixed-?

    Note: I see in Eventviewer the 1st APP failure was svchost>exe regarding AppsReadiness, vertion 10.0.15063.0

    Troubleshoot:
    Windows store cache may be damaged
    Last edited by Chris77; 18 Sep 2017 at 11:00.
      My ComputersSystem Spec
  3.    18 Sep 2017 #3
    Join Date : Aug 2017
    Posts : 35
    Windows 10 Pro 1511...to...1703 (10.0.15063)
    Thread Starter

    My selution


    Ok, i decided to dump the windoes "photos" app. I cannot find his app, and also do not know how to uninstall it.

    Instead I installed a Windows photoviewer called=Restore Windows Photo Viewer, associoated all .JPG / tiff etc files to it, and it works exactly as I wanted it to be.
      My ComputersSystem Spec
  4.    19 Sep 2017 #4
    Join Date : Jun 2015
    UK
    Posts : 2,082
    Windows 10 Home x64 (Laptop), Windows 10 Pro x64 (Desktop)

    If you install Classic Shell, it will give you a right click option to uninstall the Photos app which you can then reinstall from the Store. You can also try resetting the Photos app from Settings / Apps & Features then choose Advanced options.
      My ComputersSystem Spec
  5.    19 Sep 2017 #5
    Join Date : Aug 2017
    Posts : 35
    Windows 10 Pro 1511...to...1703 (10.0.15063)
    Thread Starter

    Eventviewer:

    Looking back, the Apps started to give problems as from 2017-09-14. It started failing with Apps readiness.
    File=ntdll.dll

    This was after Security updates, KB4038806, KB4038788, were installed.

    I went to settings, Apps, reset each one from Advanced option, it made no difference.


    KB4038788:
    Improvements and fixes

    This update includes quality improvements. No new operating system features are being introduced in this update. Key changes include:

    • Addressed issue where the color profiles do not revert to the user-specified settings after playing a full-screen game.
    • Updated HDR feature to be turned off by default in the OS.
    • Addressed issue where you can't open the Start menu when you add a third-party IME.
    • Addressed issue with scanners that rely on inbox driver support.
    • Addressed issue in a Mobile Device Manager Enterprise feature to allow headsets to work correctly.
    • Addressed issue where some machines fail to load wireless WAN devices when they resume from Sleep.
    • Addressed issue where Windows Error Reporting doesn't clean up temporary files when there is a redirection on a folder.
    • Addressed issue where revoking a certificate associated with a disabled user account in the CA management console fails. The error is "The user name or password is incorrect. 0x8007052e (WIN32: 1326 ERROR_LOGON_FAILURE)”.
    • Addressed issue where LSASS is leaking large amounts of memory.
    • Addressed issue where enabling encryption using syskey.exe renders the system unbootable.
    • Updated the BitLocker.psm1 PowerShell script to not log passwords when logging is enabled.
    • Addressed issue where saving a credential with an empty password to Credential Manager causes the system to crash when attempting to use that credential.
    • Updates to Internet Explorer 11’s navigation bar with search box.
    • Addressed issue in Internet Explorer where undo is broken if character conversion is canceled using IME.
    • Addressed issue with the EMIE where Microsoft Edge and Internet Explorer repeatedly switched between each other.
    • Addressed issue where a device may stop responding for several minutes and then stop working with error 0x9F (SYSTEM_POWER_STATE_FAILURE) when a USB network adapter is attached.
    • Addressed issue where some apps cannot be opened because the IPHlpSvc service stops responding during the Windows boot procedure.
    • Addressed issue where spoolsv.exe stops working.
    • Addressed issue where the Get-AuthenticodeSignature cmdlet does not list TimeStamperCertificate even though the file is time stamped.
    • Addressed issue where, after upgrading to Windows 10, users may experience long delays when running applications hosted on Windows Server 2008 SP2.
    • Addressed RemoteApp display issues that occur when you minimize and restore a RemoteApp to full-screen mode.
    • Addressed issue that sometimes causes Windows File Explorer to stop responding and causes the system to stop working.
    • Addressed issue that causes the Export-StartLayout cmdlet to fail when exporting the layout of tiles at startup.
    • Addressed issue where the option to join Azure AAD is sometimes unavailable during the out-of-box experience.
    • Addressed issue where clicking the buttons on Windows Action Center notifications results in no action being taken.
    • Re-release of MS16-087- Security update for Windows print spooler components.
    • Security updates to Microsoft Graphics Component, Windows kernel-mode drivers, Windows shell, Microsoft Uniscribe, Microsoft Edge, Device Guard, Windows TPM, Internet Explorer, Microsoft Scripting Engine, Windows Hyper-V, Windows kernel, and Windows Virtualization.

    If you installed earlier updates, only the new fixes contained in this package will be downloaded and installed on your device.




      My ComputersSystem Spec
  6.    19 Sep 2017 #6
    Join Date : Aug 2017
    Posts : 35
    Windows 10 Pro 1511...to...1703 (10.0.15063)
    Thread Starter

    Quote Originally Posted by Steve C View Post
    If you install Classic Shell, it will give you a right click option to uninstall the Photos app which you can then reinstall from the Store. You can also try resetting the Photos app from Settings / Apps & Features then choose Advanced options.
    Thanks, but I could not found that specific app in the store.
    Also, I have a problem with all apps, at the moment I do not use one of them. My problem started after KB Update.
      My ComputersSystem Spec
  7.    19 Sep 2017 #7
    Join Date : Jun 2015
    UK
    Posts : 2,082
    Windows 10 Home x64 (Laptop), Windows 10 Pro x64 (Desktop)

    Classic shell is a program you install from here http://www.classicshell.net/

    You could uninstall KB4038788 to check the problem disappears. Also try the Store Apps Troubleshooter.
      My ComputersSystem Spec
  8.    19 Sep 2017 #8
    Join Date : Aug 2017
    Posts : 35
    Windows 10 Pro 1511...to...1703 (10.0.15063)
    Thread Starter

    List of Apps failing


    Everything else works fine..

    The Apps that fails: I only used the Photo of the lot.

    1-Alarms & Clock

    2-Calculator.. I fiddled with some of the app related settings and got this one to work, it still works.

    3-Grove Music

    4-Maps

    5-Microsoft Silitaire

    6-Mixed Reality Portal

    7-Movies & TV

    8-One Note

    9-Phone

    10-Phone Companion

    11-Photos......I fiddled with some settings related to Apps and got it working twice, but now it fails again.

    12-Voice Recorder.

    I dont need these, so as long as the rest of the PC works fine, I dont think I am going to do anything major.
    Maybe in 6 months time Microsoft gets to the cause and fix it with an update.
      My ComputersSystem Spec
  9.    20 Sep 2017 #9
    Join Date : Jan 2015
    UK, Midlands
    Posts : 10,971
    Win 10 Pro (1703)

    Reinstall and Re-register Apps in Windows 10 Windows 10 Performance Maintenance Tutorials

    I doubt MS will investigate your particular issue; doesn't seem one others report.

    If the tutorial doesn't help, try creating a new user account and see if they work.
    If they do, it's likely not a basic Windows corruption
    If they don't, it probably is.

    If so, you can try an in-place repair install of Windows which keeps all programs and data and most settings.
      My ComputerSystem Spec
  10.    20 Sep 2017 #10
    Join Date : Aug 2017
    Posts : 35
    Windows 10 Pro 1511...to...1703 (10.0.15063)
    Thread Starter

    Eventviewer:Found something


    Thanks for the link, but for one or other reason it does not work recognising the command for the Photo-app reset, so nothing happens. It seems that every now and then if I try the Photo-App does open, usually twice, then it fails again.
    The Eventviewer normally go to says Remote Procedure Call failed regarding the Photo-App.
    ###################################################################################
    I found something in Eventviewer:
    Go to.....
    >Applications and Services Logs
    >Microsoft
    >Windows
    >Applications Experience
    >>Program Telemetry.......
    Now I saw entries about compatbility fixes applied......
    >>I then try to open the Photo-App....It failed.
    Refresh log
    .....The log basicly said Windows applied a compatibility fix to Microsoft.Photos.exe.

    Now what could this mean ? I would like to see if I can get to the bottom of this without re-installing the OS.
    I just try to this for interest sake, I got a Photo-Viewer now that works perfectly, nothing in the log about this one.
      My ComputersSystem Spec

 
Page 1 of 3 123 LastLast


Similar Threads
Thread Forum
Solved (Windows 10 Photos) we're having trouble opening this file for editing
I'm having trouble editing on Windows Photos due to problems opening the file for editing from my memory card. 101533 Please, could you tell me what the problem is? Thanks From River.
General Support
Photos Won't Default To My Photo Editing Program
I'm using a Sony a3000 camera, although I don't think that's the problem. When I download photos on my old computer, which is still running Windows7, my photos go straight to my default program, PaintshopPro. On my laptop, which has Windows...
Software and Apps
Custom Background Colors, Theme Editing, msstyles editing advice?
Hi folks, So I have been playing with making my own custom themes, as many here have done (and shared here). However, I wanted to do a little more, and in the process I solved some of my own confusions but brought up new ones. So I wanted to...
Customization
Windows 10 Photos app - Edits some photos but not others
This is driving me crazy. I have PhotoShop which runs fine under win10 bty BUT I really like the little Photos app for quick editing however. It doesn't work all the time. The app itself never fails to launch but with about half of the pictures...
Software and Apps
Slow loading of programs like Paint / Can't edit files on Photos
Why do programs like Paint and Photoshop take FOREVER to load? It's not like my computer slows down as they are loading either. My computer is running well without any issues, but this is still a problem. I was part of the Insider Program and I am...
Software and Apps
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 23:16.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums