1.    24 Jul 2017 #1
    Join Date : Jun 2016
    Posts : 2
    Windows 10

    Issues running application as Administrator in terms of file access.


    Hi all,
    I have an Excel spreadsheet that makes an OLE call to a running application. Since moving to Windows 10, I can't seem to get that OLE call to work unless I run Excel in Administrator mode. The issue with that is, when I try to load worksheets in Excel in Administrator mode, it can't find the worksheets. Its as if the user no longer has any rights to his/her files or shares.

    I think this has to do with how Windows 10 functions when you "Run as Administrator".

    What I'd like to do is either find a way to run the OLE call without putting Excel into "Run as Administrator", or find a way for Excel (running as Admin) to be able to locate and access user files.

    Thanks in advance.
      My ComputerSystem Spec
  2.    24 Jul 2017 #2
    Join Date : Jul 2016
    Crewe Cheshire
    Posts : 1,451
    windows 10

    Welcome to the forum. Is the file in another users profile if so you won't have rights to it
      My ComputerSystem Spec
  3.    24 Jul 2017 #3
    Join Date : Jun 2016
    Posts : 2
    Windows 10
    Thread Starter

    Quote Originally Posted by Samuria View Post
    Welcome to the forum. Is the file in another users profile if so you won't have rights to it
    Actually, I'm logged onto the PC as a user with local admin. And the files I'm attempting to access are in that user's \home directory.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Running always an application with administrative privileges
Hi I have Windows 10 v1703 and I would need that an application is always run with administrative privileges even when it is run by a user who has a Users's account. So, how should I do this? Thanks Bye
Software and Apps
Administrator Password Required for non-Admin application
Somehow, an ordinary, everyday application I use on my computer has gotten it into its head that I need to enter my Administrator password every time I call it up. So the prompt to enter my Admin password pops up and I have to enter it. It only...
Software and Apps
My Application which is in Start up folder is not running
My application which is in Startup folder is not started after restarting the computer. I find some solutions on internet like 1. Hkey_Local_Machine\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\ System\ Set EnableLUA to 0 (See at right...
Software and Apps
Unassociated file associations only running programs as administrator
My issue revolves around encountering read/wright permissions with programs Java-based programs. I currently have installed jdk-8u65-windows-x64 on Windows 10 64-bit. Java is installed on C drive within program files. by Java-based programs reside...
Software and Apps
Solved Issues with quick access and file explorer
Today after starting my computer, I realized that quick access items disappeared and I am unable to pin anything. In addition, all pinned items in the menu that appears when you right click on the file explorer disappeared as well. I am...
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 02:04.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums