1.    08 May 2017 #1
    Join Date : Apr 2017
    Posts : 13
    Windows 10

    Unable to install .NET Framework 3.5


    Hello.

    I'll just get right to it. When i try to launch a program, i get prompted that it requires .NET Framework 3.5, which includes 2.0 and 3.0, however, when i click install, i get an error saying;

    "Windows couldn't find required files to complete the requested changes. Make sure you're connected to the Internet and try again."

    Error code: 0x800F081F


    I've tried to enable .NET Framework 3.5 in the "Turn Windows Features on/off" in the control panel, however i got the same error.
    I also ran this command in the command prompt;

    DISM /Online /Enable-Feature /FeatureName:NetFx3 /All /LimitAccess /Source:e:\sources\sxs" in Administrative Command Prompt

    And i also tried downloading it from the Microsoft website, again, same error.

    Tried installing update 3005628, according to Microsoft this is the resolution, but it didn't work for me.

    I've heard this is because of 3 security updates from Windows, however when i checked, i do not have those updates installed at all. And also, this problem appeared after i reset Windows to factory. Before that, i was still running Windows 10, and everything was fine.
      My ComputerSystem Spec
  2.    08 May 2017 #2

    Search for "framework 3.5 offline installer"

    MS has not concentrated on 3.5 (and rightly so.. ) in latest Windows releases - developers should update their apps...

    3.5 is too much maintenance for MS... the fact that 4.7 is as backwardly compatible is commendable given the deprecated features...The problem is, that results in bloat for users, when developers do not move with the improvements in runtime.

    Not a rant just a concern.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Windows 10 - Unable to Install .Net Framework 3.5
Hello,I know this thread has been posted several times online, but none of the solutions I've researched have been working for me. I have been trying to install Microsoft .Net Framework 3.5 for a week to no avail. Some of the methods I've used...
Software and Apps
How do i install Windows 10 .NET Framework 3.5?
How do i install windows 10 .NET Framework 3.5 without a Windows 10 ISO file nor disk and usb containing it? I have literally tried everything, and every single time it gets me this error message when its about to install "0x800F081F"
Drivers and Hardware
Unable to install .NET Framework 3.5 on Windows 10
I am unable to install the .NET Framework 3.5 on my Windows 10 box. I tried enabling it through Programs and Features, I tried enabling and installing through DISM, I tried SFC /scannow. Everything is failing. Mostly I get error code 0x800736B3...
Software and Apps
Unable to install framework 3.5, error 0x800736B3
Hi! I just do clean install windows 10 and unable to install net framework 3.5 it give an error 0x800736B3 "The referenced assembly is not installed on your system" , I did try to enable group policy setting that I read from microsoft helper but...
Software and Apps
Unable to install visual studio, required .net framework.
I'm trying to install visual studio community 2015, however it has an error '.net framework required for setup'. Tried installing .net framework 4.5 but it is stated that 'Microsoft .NET Framework 4.5 is already a part of this operating system. ...
Software and Apps
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 17:30.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums