Windows 10: Installing Net Framework 3.5 hangs when searching for required files

  1.    25 Apr 2017 #1

    Installing Net Framework 3.5 hangs when searching for required files


    I am trying to install Net Framework 3.5 on my windows 10 laptop but when it gets to the searching for required files the progress bar keeps cycling and never gets past that screen. It seems like it connot find or cannot download the Net Framework files needed to install the application. How do I fix this as I need Net Framework 3.5 for Print Artist Platinum version 24.
      My ComputerSystem Spec

  2.    25 Apr 2017 #2

    Hi zipster and welcome to Tenforums.
    Have you tried just enabling it through Control Panel>Turn Windows Features On or Off?

    Click image for larger version. 

Name:	image.png 
Views:	12 
Size:	11.8 KB 
ID:	131976

    Search for that in the Cortana search box. I thought it was already enabled in W10 anyway?
      My ComputerSystem Spec

  3.   My ComputerSystem Spec


  4. Posts : 2,865
    Windows 10.4 Home 1709 x64
       25 Apr 2017 #4

    Offline install of .NET Framework 3.5 in Windows 10 using DISM - Winaero

    Code:
    FOR %%i IN (D E F G H I J K L M N O P Q R S T U V W X Y Z) DO IF EXIST %%i:\bootmgr SET CDROM=%%i:
    Dism /online /enable-feature /featurename:NetFX3 /All /Source:%cdrom%\sources\sxs /LimitAccess
      My ComputerSystem Spec


  5. Posts : 8,721
    windows 10 professional version 1607 build 14393.969 64 bit
       25 Apr 2017 #5

    WIndows 10 version 1703 has Microsoft .Net Framework 4.6 or higher. It is supposed to be backward compatible. So you are likely to see the message in the image below:

    I was unable to install an Intel program related to Microsoft .Net Framework that Intel chat did not know how to troubleshoot. In the process I found a solution on the internet that worked.

    Open administrative command prompt or administrative powershell (menu method or keyboard win + x, a, alt + y) and enter this command to see if it fixes your Net Framework problem (the capital R is important and the command may need to be entered a second time): LODCTR /R or lodctr /R


    Click image for larger version. 

Name:	Microsoft net framework 4.61 or later is already installed on this computer 4 24 2017.PNG 
Views:	11 
Size:	9.3 KB 
ID:	131982
    Last edited by zbook; 25 Apr 2017 at 17:55.
      My ComputerSystem Spec


 

Related Threads
So im having a problem installing Net framework 3.5 it shows searching for required files and nothing else, if i try DISM method it just stays stuck on windows version. any help?
Solved .NET Framework 3.5 Not installing in Software and Apps
.NET Framework 3.5 won't install! It just gives me this error message: Windows couldn't find the required files to complete the requested changes. Make sure you're connect to Internet, and try again. Error code: 0x800F081F Any suggestions?...
Hello, I know this has been asked many times but I have been unsuccessful trying all that has been suggested before. When I attempt to install it through turn Windows features on or off it begins to download but then I get an error code...
We have written several programs in VB.2010. They all have a setup and deploy project to create the MSI file. There is a launch condition for a specific file. This same technique is used in many other programs we have. All work in Windows 7, 8,...
I'm trying to install visual studio community 2015, however it has an error '.net framework required for setup'. Tried installing .net framework 4.5 but it is stated that 'Microsoft .NET Framework 4.5 is already a part of this operating system. ...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 16:24.
Find Us