cclean taking long time for analyze to show up

Page 1 of 2 12 LastLast

  1. Posts : 278
    21H1 (OS Build 19043.1081)
       #1

    cclean taking long time for analyze to show up


    for the past three months cclean has taken a long time for analyze to show up bright blue when first installed it took only seconds have been using it and updating it for two years.

    all info greatly appreciated

    DME
      My Computer


  2. Posts : 35,545
    Win 10 Pro (21H2) (2nd PC is 21H2)
       #2

    Hi, I find the same - and have noticed this happen previously- I've not looked into it, so will just add this to keep track of responses. It's obviously doing something in that period as its CPU use is significant.

    It first spends a lot of time working with registry entries of the form
    HKLM\SOFTWARE\Policies\Microsoft\Windows\safer\codeidentifiers\0\.........

    It then spends time scanning data related to applications, especially browsers and email clients.

    Most of the time is then spent processing instructions as to where to look (presumably) in Ccleaner\winapp2.ini - and nothing else, (maybe it's just collecting the data about where to look, getting ready to scan)

    Finally the Analyze button becomes available.
    Last edited by dalchina; 27 Mar 2017 at 08:57.
      My Computers


  3. Posts : 278
    21H1 (OS Build 19043.1081)
    Thread Starter
       #3

    so i'm not alone in noticing this that's good/bad but still not alone

    Many Thanks
      My Computer


  4. Posts : 35,545
    Win 10 Pro (21H2) (2nd PC is 21H2)
       #4

    Ok, here's (probably) the answer:
    Ccleaner v5.18 Analye butto grey - CCleaner Bug Reporting - Piriform Community Forums
    Sounds like it's taking a scan of the applications you have installed for the applications tab. This scan is usually instantaneous, however can be greatly slowed down if the user uses a winapp2.ini file, especially if it's a large ini, such as using the entire community template without editing out the applications you don't have installed.
    So the solution is to delete that file.

    Do you use CCenhancer? I'm wondering if that creates it..

    And in winapp2.ini I found this:
    ; is CCleaner taking too long to load with Winapp2.ini? Try this:
    http://www.winapp2.com/trim.bat
    (place it in your ccleaner folder and run)
      My Computers


  5. Posts : 278
    21H1 (OS Build 19043.1081)
    Thread Starter
       #5

    i had installed enhancer at some point and have looked to delete the program completely but it doesn't show it in installed programs list seeing as how it is an add on per say so i uninstalled ccleaner and re-installed.

    now i think i will uninstall CC and do windows file clean up re start and reinstall.

    it does look like enhancer is the problem so if CC is gone, i should be able to re-apply basic CC

    many thanks

    not done yet but shortly

    DME
      My Computer


  6. Posts : 35,545
    Win 10 Pro (21H2) (2nd PC is 21H2)
       #6

    This is a relatively trivial issue which reinstalling Ccleaner won't solve.

    I've already discovered exactly what's needed.

    1. You can download and run trim.bat which cleverly cleans up the winapp2.ini file.
    I did that and the time for Analyze to show was reduced to 2-3seconds.
    2. You can simply delete winapp2.ini in Ccleaner's folder if (1) is too much trouble.

    You can easily find ccenhancer if you use a free search tool such as
    locate32
    ultrasearch
    everything by voidtools
    - these are often recommended here and make things so much easier.

    And ccenhancer should be in your ccleaner folder if present.
    Last edited by dalchina; 18 Apr 2017 at 00:34.
      My Computers


  7. Posts : 278
    21H1 (OS Build 19043.1081)
    Thread Starter
       #7

    Many Many Thanks dalchina

    i chose option 2 delete the ini file and the Analyze button didn't take one second to show up

    many thanks again:)
      My Computer


  8. Posts : 1,097
    Windows 10 Home x64 Version 1809 (OS Build 17763.437)
       #8

    Downloaded and ran trim.bat. Two failures, and then it ran but no debug. A search for winapp2.ini comes up empty. What's up with this? how bad am I in trouble?
      My Computer


  9. Posts : 35,545
    Win 10 Pro (21H2) (2nd PC is 21H2)
       #9

    winapp2.ini if present should be in the folder where Ccleaner is installed.
      My Computers


  10. Posts : 1,097
    Windows 10 Home x64 Version 1809 (OS Build 17763.437)
       #10

    Not one there. Doing some more "research" I found it may NOT be part of my system. Everything still works and runs fine. No errors in logs. Guess I made myself panic over nothing.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 00:03.
Find Us




Windows 10 Forums