Windows 10: Remote Desktop App Not Updating Solved

  1.    26 Mar 2017 #1

    Remote Desktop App Not Updating


    I have a couple of computers on which the Remote Desktop App refuses to update.
    Most of them seem to be stuck on version 10.1.893.0
    Current version is 10.1.970.0
    Uninstalling or resetting the app installs version 6.3.9600
    Just updated one machine with the Creators Update and still stuck on version 6.3.9600
    Anybody seen this before?
      My ComputerSystem Spec

  2.    26 Mar 2017 #2

    Do you mean that a cycle/manual check for updates in the store reveals an update is available for the remote app but when you choose to update it then it fails - or it just doesn't find an update at all? If it's the latter then I have seen this before with other apps. Facebook for example I have seen an app update available following a manual check on one of my machines but the other machine doesn't get it til days later. I don't know why it sometimes occurs and it's very irritating but I'd say be patient as the update will eventually come to you.
      My ComputerSystem Spec

  3.    26 Mar 2017 #3

    I have no problems installing the app.
    It just never appears as an update on some computers.
    It's like they cannot see that a new version of the app is available.
    And if I uninstall & reinstall it reverts to the version that came with the anniversary update.
      My ComputerSystem Spec

  4.    27 Mar 2017 #4

    My machine with Windows version 15063 just updated itself to the current version of the app.
    Just decided to take its time.
      My ComputerSystem Spec

  5.    28 Mar 2017 #5

    Yep seems to be a Microsoft thing. I just got the same this morning with camera app. One machine found and installed the update, the other is not seeing any update at all. Sure is annoying and baffled why it happens on the odd occasion but it'll come through eventually!
      My ComputerSystem Spec

  6.    28 Mar 2017 #6

    Took something like 3 months with this app.
      My ComputerSystem Spec


 

Related Threads
Remote Desktop in Network and Sharing
I am having problems setting up remote desktop. I can not find the program in windows firewall to enable it. was just wondering if this would be due to my copy of windows 10 is not activated?
Remote Desktop in Network and Sharing
recently I upgraded my work computer to windows 10 pro just found if I want to connect to a remote computer on a port other than 3389, it doesn't let le me put : just like I can do in previous version "server name/IP address: port number" comes...
Hi. I just viewed Kari Finn's clearly explained Remote Desktop Connection on Win10 and how to connect to remote computer, thank you for that. Good job! In my case though, I use Win XP Home edition. Do I have to have Win XP Pro edition to connect on...
Remote Desktop in Network and Sharing
I have recently upgraded from 7 Ultimate to 10 Pro. When I RDP to another Windows 7 Ultimate machine the application randomly closes, no error messages or anything. Anyone seen this before?
Solved remote desktop connection in Network and Sharing
(1)The initial box you get when trying to connect ,has below,is it the computer name the pc your on or the pc s name your trying to connect to? computer .............? user name-none specified (2) the enter your credential box after above Whats...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 22:50.
Find Us