Page 1 of 2 12 LastLast
  1.    14 Feb 2017 #1
    Join Date : Feb 2017
    The Other La Mancha
    Posts : 6
    Win 10 Home

    Belkin 600VA UPS Management Software and Win 10 - Error: 1067


    Hi,
    I have recently purchased a new Win 10 based Desktop and my Belkin 600VA Automatic Power Management Software (Version 2.6.0.2) no longer seems to be working.
    The usual TrayIcon (small green plug) is missing as with out that I cannot enter the Management Software.
    I also get a Error: 1067 Message if I go to Services and try to start the UPSmonitor Service.
    Tried asking Belkin but after a week and several messages I have not heard back.
    Any help to fix this would be appreciated.
      My ComputerSystem Spec
  2.    14 Feb 2017 #2
    Join Date : Oct 2016
    Caledon, Ontario, Canada
    Posts : 4,035
    Windows 10 Pro Build 1703

    Welcome to the TenForums @laopa

    Could you post the exact model number for your unit. I can't find that one on their site. That program's support under Windows 10 maybe an issue.

    Have you tried installing the software in compatibility mode?

    I assume you are using a USB port to attach. If at all possible use a USB 2.0 port.

    Does the device show up in Device Manager?

    If Belkin doesn't support they you could look at Open Source to see if it would be compatible.

    Please post model number. Thanks


    Ken
      My ComputerSystem Spec
  3.    14 Feb 2017 #3
    Join Date : Feb 2017
    The Other La Mancha
    Posts : 6
    Win 10 Home
    Thread Starter

    Hi,

    Model is a Belkin Line Interactive 600VA UPS, F6U600 .

    I have not tried installing in "compatibility mode" - also not quite sure how to do that?

    OK I looked that up and tried but no joy so far. Set to Win 7 and to run as an Administrator - maybe I need a reboot?

    I have however installed, un-installed and re-installed the software in Administrator Mode.

    In terms of Device Manager I do not see it shown as a separately and easily found unit/item.

    "If Belkin doesn't support they you could look at Open Source to see if it would be compatible."


    Not sure how to do that either.

    Last edited by laopa; 14 Feb 2017 at 22:55.
      My ComputerSystem Spec
  4.    14 Feb 2017 #4
    Join Date : Oct 2016
    Caledon, Ontario, Canada
    Posts : 4,035
    Windows 10 Pro Build 1703

    Thanks.

    Found it. The software says it is supported in Windows 8, 32 and 64 bit so it should work. (For compatibility mode, right click on file, click properties, Compatibility Tab.)

    You will excuse question. What happens when you install software? Does it load, does it fail or error message?

    Have you checked the systray icon notification settings to see if it may just not be showing.

    Right click in clear area of task bar
    Click "Setting" at bottom of list
    Scroll down to "Select which icons appear on taskbar" on right side of screen.
    Click
    Review list and see if it is in there, if so turn On.

    In Device manager it should show at top of list under Batteries. It should make that sound that a USB device makes when you connect. Are you hearing. If not disconnect both ends and try reconnecting.
      My ComputerSystem Spec
  5.    14 Feb 2017 #5
    Join Date : Feb 2017
    The Other La Mancha
    Posts : 6
    Win 10 Home
    Thread Starter

    I don't seem to have a Batteries Heading in Device Manager.

    Parts of the software show under Processes if I check with System Explorer or Autorun64.

    In Services two elements show but if I try to Start UPSmonitor I get the Error: 1067 Message.

    I checked for the TrayIcon in Settings >Select which icons appear in the Task Bar but the "normal" Belkin UPS icon is not there.

    What happens when you install software? Does it load, does it fail or error message?
    It installs fully and is listed in the Programs Area when I left click on the Win 10 Start Symbol. I can even place a short cut on the desk top but nothing appears to happen and no TrayIcon appears.

    I have rebooted after the Win 7 Compatibility change and the Software seems to be operating in Services.

    There is however another aspect of the Management Software that I would like your advice.

    The Belkin UPS Management Software uses Java, at least for some aspects and specifically Java™ SE Development Kit 6, Update 33 (JDK 6u33).

    The TrayIcon seems to be based upon Java and is the entry to the User Interface (GUI) for the Management Software.

    Currently my system has Java Version 1.8.0.121 Installed on it.

    The Belkin UPS Management Software when it installs in stalls the older version.

    Is this relevant?
    Last edited by laopa; 15 Feb 2017 at 02:17.
      My ComputerSystem Spec
  6.    15 Feb 2017 #6
    Join Date : Oct 2016
    Caledon, Ontario, Canada
    Posts : 4,035
    Windows 10 Pro Build 1703

    Can't be sure what is relevant as I don't understand all the underlying code. I'm thinking as the device is not recognized the services can't be started.

    I had asked does you machine make the USB connection sound. I would think that as soon as you connect you would hear. Futher the device should show in the Device manager. I plugged in my APC, heard the sound and saw it in the Device Manager.

    I had suggested disconnecting the cable both ends and reinstalling? Did you try?

    Do you have another cable you can test with, looks like it is a standard cable.

    Have you tried power down your UPS, using the button, and unplugging from wall. Waiting a minute and powering on. Basically resetting unit.
      My ComputerSystem Spec
  7.    15 Feb 2017 #7
    Join Date : Feb 2017
    The Other La Mancha
    Posts : 6
    Win 10 Home
    Thread Starter

    Just for reference.

    http://www.belkin.com/au/support-pro...0000002xVBlAAM

    The Belkin Line Interactive UPS - 600VA (Part # F6U600au) is not a battery pack that you plug in and out regularly. It sits on the floor under my desk and the desktop is permanently plugged into it to protect the system against Power Surges and Power Loss.

    There isn't any USB Sound as the thing is already plugged in when the system starts. The system runs through the UPS. I think that is why it does not show up in the Device Manager.

    I have shut down the system and turned off the UPS and unplugged it from the wall and disconnected it from the USB connector on the rear of my system and then reversed the whole process. Still no joy?

    Maybe I plugged it into an incorrect USB connector on the back of the system? Whatever an incorrect USB connector would be.

    As it is a new system I think all the USB Connectors are USB 3.

      My ComputerSystem Spec
  8.    16 Feb 2017 #8
    Join Date : Oct 2016
    Caledon, Ontario, Canada
    Posts : 4,035
    Windows 10 Pro Build 1703

    Thanks. Yours is just like mine, only mine is APC.

    With my Windows system on, if I pull the USB connection out it makes the USB disconnect sound. When I plug in I hear the connection sound. If you are not hearing a sound I am proposing that the connection is faulty and you should try a new cable. Or removing and replacing USB cable at both ends.

    USB3 ports have a blue tongue inside, if black then USB 2.0. Usually 3.0's are backwardly compatible. That said every once and a while you see a posting about different devices preferring USB2.0 ports.
      My ComputerSystem Spec
  9.    16 Feb 2017 #9
    Join Date : Feb 2017
    The Other La Mancha
    Posts : 6
    Win 10 Home
    Thread Starter

    Sorry I have been away fighting other "fires".

    Took your advice and pulled all the USB Connected Devices from the back of my new system and checked the USB Ports. It seems I have two "legacy" USB 2 Ports and 4 new USB 3 Ports in the rear. Two more new USB 3.0 Ports in the Front.

    I rearranged the devices and made sure that the Belkin was plugged into a "Legacy" USB 2 Port.

    After rebooting my system and if I go to Control Panel > Hardware and Sound > Devices and Printers I now have a USB to Serial Device showing.

    In Device Manager it shows up in Human Interface Devices?

    It also looks like the UPS is running in Services > UPSmonitor and UPSRMI. This is where I get the Error: 1067 if I try to Start the Service if it is not running. Like now!

    In Processes I have monitor.exe *32 with a subprocess javaw.exe *32 plus wpRMI.exe *32 with the same sub process javaw.exe *32.

    I also got some other input about the UPS requiring Firewall Access related to TCP and Port 2099.

    I think I have managed to address the Port 2099 matter.

    I set up a new rule in the Firewall setting of EIS for TCP on Port 2099 as outlined. My only question would be if it should be set for All Networks or just Private Network

    I also set up new Rules in the general Protection Settings > Application Rules to allow the key exe files in the Belkin Management Software (monitor, manager, UPSMS, wpRMI) In and Out clearance through the Firewall.

    Despite all of the above I still I have no GUI or TrayIcon through which to Open or Enter the Management Software.

    Me thinks that is a javaw.exe issue?

    The good news is that my system may now "see" the UPS, the bad news it that I still cannot manager it.

    Onwards, forever onwards.
    Last edited by laopa; 16 Feb 2017 at 17:29.
      My ComputerSystem Spec
  10.    16 Feb 2017 #10
    Join Date : Oct 2016
    Caledon, Ontario, Canada
    Posts : 4,035
    Windows 10 Pro Build 1703

    You want Private Network, you won't be connecting to a public network (In Windows terms). Very interesting on Firewall.

    So as a test kill your firewall and restart Windows. When you shut down windows hold the shift key down and click shutdown. (not restart)

    When it comes back up check to ensure firewall is off. See if things "Start". This is just a test to make sure some other firewall block or rule or protocol isn't blocked.

    My UPS shows as a Human Interface but it is also listed as battery. I think we need to get to that point on your device.

    Be interested to see what happens with no firewall.


    Ken
      My ComputerSystem Spec

 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
Sysprep 1067 has Dead shortcuts (windows apps)
Has anyone else seen that when sysprepping build 1067, the user you ran sysprep from has broken windows app shortcuts. Some do not have pictures and when you click on the shortcut, the system does nothing. I also niticed that after leaving the...
Customization
Sysprep win10 build 1067
please delete
Customization
Belkin Adapter issues
Hi, my name's Wallace. I'm using a Toshiba Satellite C55Dt=A5306 running Windows 10 Home Edition. A few weeks ago, the internet adapter within my laptop decided a hilarious April Fool's Day joke would be to die. Well, I'm not laughing. So I...
Network and Sharing
Random BSOD with error message BAD POOL CALLER/MEMORY MANAGEMENT
Hi, I am facing random BSOD with different error messages as noted in the thread title.Attached is the zip file.
BSOD Crashes and Debugging
Comcast gateway with Belkin N300
Hello I tried to bridge the Comcast gateway and plug my router into one of the four ports; one has the printer ethernet cable, one goes to the pc and 2 are open(I plugged the router into one of the open ones). I was able to open the Belkin but...
Network and Sharing
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 14:32.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums