1.    06 Feb 2017 #1
    Join Date : Feb 2017
    Posts : 4
    windows 10 home

    Unable to install software due to error code 1609


    Error 1609 on Install.
    I am trying to load a program, I get the following error, 'Error 1609. An error occurred while applying security settings. Power users is not a valid user or group. This could be a problem with the package, or a problem connecting to a domain controller on the network. Check your network connection and click retry.
    I have previously installed this on a windows 10 computer, this is a new computer running win 10 home. The computer is hard wired to a router so network connection is good.
    Any help gratefully received
      My ComputerSystem Spec
  2.    06 Feb 2017 #2
    Join Date : Jun 2014
    Posts : 544
    Microsoft Windows 10 Pro 64-bit

    It might help if you provide more info, Like the name of the program
      My ComputerSystem Spec
  3.    06 Feb 2017 #3
    Join Date : Feb 2017
    Posts : 4
    windows 10 home
    Thread Starter

    It's called Time Trax EZ. It runs a time clock for logging worker arrival and leaving time. It's an old program but worked fine on my last win 10 computer.
      My ComputerSystem Spec
  4.    06 Feb 2017 #4
    Join Date : Jun 2014
    Posts : 544
    Microsoft Windows 10 Pro 64-bit

    Have you tried uninstalling then reinstall the software. Windows 10 seems to break a lot of programs after a major update. If I was running a business I would stay away from Win 10. If something works with Win 7 I would save your time and money and stay with that, or run it in a virtual machine.

    Have you tried the driver fix
    TTEZ USB DRIVER FIX -

    You should always check the manufactures web site first especially for stuff like this, 99.999999% of TenForum user's have never used or needed software for this device.

    Also you should check out Spiceworks Community they are more business orientated
      My ComputerSystem Spec
  5.    06 Feb 2017 #5
    Join Date : Feb 2017
    Posts : 4
    windows 10 home
    Thread Starter

    I haven't even got to the install to be able to uninstall. Win 10 has been fine so far, just changed to a new win 10 computer. Having looked around the internet, it looks like a generic problem rather than a time trax problem, that's why I've posted here. I had seen the link you posted, but that is only of use if the software is installed and it's communication between the program and clock.
      My ComputerSystem Spec
  6.    06 Feb 2017 #6
    Join Date : Jun 2014
    Posts : 544
    Microsoft Windows 10 Pro 64-bit

    Not quite sure how you expect to use the device without the software or drivers installed.

    From my understanding this is a device that uses a swipe card reader that connects to a computer to log employees coming and going, You need to install software and drivers to make it work.
      My ComputerSystem Spec
  7.    07 Feb 2017 #7
    Join Date : Feb 2017
    Posts : 4
    windows 10 home
    Thread Starter

    Just to let you know I've solved it. There was a driver for the RS232 converter that was stopping the download. I removed it and hey presto the rest followed. Thanks for your help.
      My ComputerSystem Spec
  8.    07 Feb 2017 #8
    Join Date : Jun 2014
    Posts : 544
    Microsoft Windows 10 Pro 64-bit

    Glad to hear you figured it out
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Solved install .net 3.5 gives error code 0x800F081F
Hi Guys apologies if this is the wrong forum... I have just upgraded a new dell laptop i7 / 16gb ram from windows 8.1 pro to windows 10 pro and all went fine. I need to install sql server management studio 2014 on it, but it requires .net...
Software and Apps
Unable to Install Software From NAS drive
Hi all I wonder if you guys can help me with something that's started happening fairly recently. I'm running Windows 10 x64 Home edition. If it helps, I have 16Gb of RAM and a 1TB HDD. I don't think that information will make any difference...
Software and Apps
Anniversary update won't install - no error code
I've downloaded the update for my laptop through windows update 3 times now. Each time it completes download, then restarts, configures updates, then gives me the notification: "We couldn't finish installing updates" Following that, a check of my...
Windows Updates and Activation
Unable to add to domain - error code 64, or error; network name...
Hello all - Having issues with windows 10 upgrade. A few weeks ago, I upgraded my work laptop to Windows 10. Yesterday in troubleshooting an issue with RSAT (remote server admin tools - issue: inability to connect to domain controller through...
Network and Sharing
Solved Error Code 8007003 in preparing to install
When I try to upgrade Windows 8.1 with Bing tablet to Windows 10 in Windows update i get Error Code 8007003 in preparing to install phase. When choosing try again it re downloads everything and same error appears. I tried cleaning Windows Update...
Installation and Upgrade
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 00:48.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums