Page 2 of 2 FirstFirst 12
  1.    29 Jan 2017 #11
    Join Date : Jul 2016
    Posts : 91
    Win 10 Pro x64
    Thread Starter

    I'm not sure where Java was before all this started, but I think the Program Files folder. But with JavaRa, it put 8.111 in another drive entirely, the one where I kept some old files from Win 8.1. I emptied that drive, as well as my Win 10 files backup drive, onto a USB stick and haven't hooked them up yet. Before I do so, I wonder how I could get the install pointed in the right direction. A clean install isn't going to happen just for Java, at least not at the moment. Many thanks for looking!
      My ComputerSystem Spec
  2.    29 Jan 2017 #12
    Join Date : Oct 2016
    Caledon, Ontario, Canada
    Posts : 4,053
    Windows 10 Pro Build 1703

    Okay so then we are back to your comment, the registry. Have you search it for references. The installer must be getting info from it.

    Its obvious you know what you are doing so I won't go into all the warnings.

    If I were to experiment I would ensure I have a system Image that I can restore. I would have a full copy of the registry and specific instruction on backing up pieces I might change. (Don't want to go nuclear because of a finger slip.)
      My ComputerSystem Spec
  3.    29 Jan 2017 #13
    Join Date : Oct 2016
    Caledon, Ontario, Canada
    Posts : 4,053
    Windows 10 Pro Build 1703

    So for all the posts.
    from the log

    TRACE: Installed Java detected: version=1.8.0_111; arch=64; productCode={26A24AE4-039D-4CA4-87B4-2F64180111F0}; type=0

    Maybe you want to search the product code to see it it is somewhere with Windows or program / programdata folders.
      My ComputerSystem Spec
  4.    29 Jan 2017 #14
    Join Date : Jul 2016
    Posts : 91
    Win 10 Pro x64
    Thread Starter

    Didn't find anything with the product code.

    Update: I went hunting for registry entries and deleted the first couple of groups of JRE entires that looked like possible suspects. The good news is doing that restored the installer; the bad news it it still leads to the 1603 error (run as Admin). The problem now is that the instructions for getting around the 1603 error assume an install, which I no longer have.* There must be other likely registry entries to look for. I ended up with four log files from the install attempt, and have submitted a bug report with the contents of one of the files. Thanks for your patient help.

    *https://java.com/en/download/help/error_1603.xml

    Update 2: Now that the installer is working, I used the defunct JavaRa program to install 8.111 on the system drive. 8.121 still brings the 1603 error.

    Last edited by highstream; 30 Jan 2017 at 00:22.
      My ComputerSystem Spec
  5.    30 Jan 2017 #15
    Join Date : Oct 2016
    Caledon, Ontario, Canada
    Posts : 4,053
    Windows 10 Pro Build 1703

    Well given they know they have a problem you may have to wait it out with 8.111.

    Sorry I couldn't be of more help. Sometimes we just have to wait for the coders.

    Did you try their two alternate methods?
      My ComputerSystem Spec
  6.    30 Jan 2017 #16
    Join Date : Jul 2016
    Posts : 91
    Win 10 Pro x64
    Thread Starter

    The alternate methods are either/or and neither has worked. Just submitted some logs to Oracle on the bug report showing uninstall method doesn't work.
      My ComputerSystem Spec
  7.    30 Jan 2017 #17
    Join Date : Jul 2015
    Poole Dorset UK
    Posts : 2,559
    Windows 10 x64 Home Version(1709) Build16299.64

    Have you tried this
    File Explorer
    Then C Drive
    Then Programs
    Also Programs x86
    You may find traces of the folder in there
    If there is Right Click it and delete it that should get rid of it
    I have had to do that with my Antivirus I wanted removed
    Also another program I needed removed
    You may have to do it 2-3 times
      My ComputerSystem Spec
  8.    30 Jan 2017 #18
    Join Date : Jul 2016
    Posts : 91
    Win 10 Pro x64
    Thread Starter

    From the OP: "I removed Java from my computer via...and did a bit of additional removal via file manager searching." So the answer is of course I checked the program folders and other places - many times. Oracle support asked me to look too, as well as for other mentions, and the upshot of that is my last post. Please understand that the 1603 error is recognized on the Java site as a known bug and that the alternate methods have not worked for some (many?) people. My hunch is that the culprit is something in the registry, but don't really know. it's in their hands.
      My ComputerSystem Spec
  9.    01 Feb 2017 #19
    Join Date : Jan 2017
    USA
    Posts : 18
    Windows 10

    What if you logged on as local admin and installed? If an older version of Java is detected then most likely you have a reg key hanging around. Ccleaner should be able to tell you if it is in the "uninstall" key as there are 3 of the "uninstall" keys in the registry.
      My ComputerSystem Spec
  10.    01 Feb 2017 #20
    Join Date : Jul 2016
    Posts : 91
    Win 10 Pro x64
    Thread Starter

    In Win 10, isn't the normal account local/admin? In Win 8.1 and earlier they were split. The initial problem in the OP was definitely a registry issue and I found it, or got close enough. Not sure from where I am now that the uninstall entries would solve the 1603 problem, since I did try the current version from scratch. And I'm not sure how you are suggesting to use CCleaner, since I didn't notice a Java entry in its settings when I checked the other day.
      My ComputerSystem Spec

 
Page 2 of 2 FirstFirst 12


Similar Threads
Thread Forum
Solved BIOS won't recognize x64 installer, but regconized x86 installer
My netbook is DENVER NBW-10004N. It was running Windows 10 64-bit but the boot file was corrupted so i had to format and install clean Windows 10 32-bit. Now i got another problems. Audio driver is not working, battery icon not showing and...
Installation and Upgrade
Java Installer Won't Run
Anytime I try to install Java on my friend's computer, the installer doesn't even work. I get the loading wheel for a split second, then nothing happens. Her computer seems to be corrupt or something, but when I run the sfc, it doesn't find any...
Software and Apps
Windows 10 and Java ... "Java not available to the System User"
Tried installing a program and received an error message advising that JRE needs to be uninstalled and reinstalled from the off-line installer. I did this and then tried to install the program again, but received the same result ... 74879 I...
Software and Apps
Mediamonkey installer doesn't run
I downloaded Mediamonkey and when I run its setup file, nothing happens and antimalware service starts to steadily use 50% CPU , I waited for 10 minutes and still the same. Does anyone know what's up here? Thank you.
Software and Apps
Solved Installer doesn't have permission to write to the startmenu located..
Installer doesn't have permission to write to the startmenu located in C:\ProgramData\Start Menu Avg & some other software wouldn't install at all, tell I used the take ownership registry file. I also notice, Windows updates keep not...
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 09:59.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums