1.    26 Jan 2017 #1
    Join Date : Dec 2015
    Posts : 36
    Windows 10 Home

    Java-based Programs Crashing [fixed]


    i regularly play Minecraft and use tinyMediaManager, both use Java.

    i played Minecraft earlier today. A little while ago i started up tinyMediaManager and it wouldn't load, instead i got the Java(TM) Platform SE Binary has stopped working error. Started up Minecraft and got the same thing. Somehow, within the 8 hours since i last played Minecraft, or even used the computer, Java broke.

    i have uninstalled and reinstalled Java to no changes.
    here is the Minecraft crash log, it might help even though it seems to be network related but i don't have any other info to give:
    Code:
    java.net.ConnectException: Connection refused: connect    at java.net.TwoStacksPlainSocketImpl.socketConnect(Native Method) ~[?:1.8.0_25]    at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:345) ~[?:1.8.0_25]    at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206) ~[?:1.8.0_25]    at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188) ~[?:1.8.0_25]    at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:172) ~[?:1.8.0_25]    at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392) ~[?:1.8.0_25]    at java.net.Socket.connect(Socket.java:589) ~[?:1.8.0_25]    at sun.net.NetworkClient.doConnect(NetworkClient.java:175) ~[?:1.8.0_25]    at sun.net.www.http.HttpClient.openServer(HttpClient.java:432) ~[?:1.8.0_25]    at sun.net.www.http.HttpClient.openServer(HttpClient.java:527) ~[?:1.8.0_25]    at sun.net.www.http.HttpClient.<init>(HttpClient.java:211) ~[?:1.8.0_25]    at sun.net.www.http.HttpClient.New(HttpClient.java:308) ~[?:1.8.0_25]    at sun.net.www.http.HttpClient.New(HttpClient.java:326) ~[?:1.8.0_25]    at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(HttpURLConnection.java:1167) ~[?:1.8.0_25]    at sun.net.www.protocol.http.HttpURLConnection.plainConnect0(HttpURLConnection.java:1103) ~[?:1.8.0_25]    at sun.net.www.protocol.http.HttpURLConnection$6.run(HttpURLConnection.java:987) ~[?:1.8.0_25]    at sun.net.www.protocol.http.HttpURLConnection$6.run(HttpURLConnection.java:985) ~[?:1.8.0_25]    at java.security.AccessController.doPrivileged(Native Method) ~[?:1.8.0_25]    at java.security.AccessController.doPrivileged(AccessController.java:713) ~[?:1.8.0_25]    at sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:984) ~[?:1.8.0_25]    at sun.net.www.protocol.http.HttpURLConnection.connect(HttpURLConnection.java:931) ~[?:1.8.0_25]    at sun.net.www.protocol.http.HttpURLConnection.getOutputStream0(HttpURLConnection.java:1281) ~[?:1.8.0_25]    at sun.net.www.protocol.http.HttpURLConnection.access$100(HttpURLConnection.java:90) ~[?:1.8.0_25]    at sun.net.www.protocol.http.HttpURLConnection$8.run(HttpURLConnection.java:1248) ~[?:1.8.0_25]    at sun.net.www.protocol.http.HttpURLConnection$8.run(HttpURLConnection.java:1246) ~[?:1.8.0_25]    at java.security.AccessController.doPrivileged(Native Method) ~[?:1.8.0_25]    at java.security.AccessController.doPrivileged(AccessController.java:713) ~[?:1.8.0_25]    at sun.net.www.protocol.http.HttpURLConnection.getOutputStream(HttpURLConnection.java:1245) ~[?:1.8.0_25]    at modinfo.mp.v1.Message.call(Message.java:67) [Message.class:1.10.2-5.4.4]    at modinfo.mp.v1.Client$1.run(Client.java:96) [Client$1.class:1.10.2-5.4.4]    at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_25]    at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_25]    at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_25]    at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_25]    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [?:1.8.0_25]    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [?:1.8.0_25]    at java.lang.Thread.run(Thread.java:745) [?:1.8.0_25]
    EDIT: I just remembered, i did update my NVIDIA driver earlier. That is the only thing i can think of though

    Windows 10 Home

    EDIT 2: It was the new NVIDIA driver. i rolled back and it fixed it.
      My ComputerSystem Spec
  2.    08 Feb 2017 #2
    Join Date : Feb 2017
    Posts : 1
    Windows 10 Home

    I am so glad I stumbled upon this thread. I was having the same issue and the nVidia rollback fixed it for me as well. Any idea what is causing this? Very odd I think.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Solved Java update?
Just got a popup saying java has an update, version 8 update 91. Is there an update or is it fake? And this is the main site right?: java.com: Java + You
Software and Apps
Windows 10 and Java ... "Java not available to the System User"
Tried installing a program and received an error message advising that JRE needs to be uninstalled and reinstalled from the off-line installer. I did this and then tried to install the program again, but received the same result ... 74879 I...
Software and Apps
Java issue?
I'm trying to remote into my work PC, which I've done numerous times in the past. I can get in from my Windows 10 desktop, but on my Win 10 laptop I'm all of a sudden unable to get in. The error I'm getting on my laptop says "Secuity exception"...
Software and Apps
Solved Java
I am trying to uninstall Java 6 update. I have uninstalled it in programs and features, and in CCleaner, and although both say uninstall complete, it is still showing in program list. Any advice on how to remove it would be appreciated. Thanks
Software and Apps
Java
Should I disable Java since Edge does not support in Windows 10. I only use this browser
Browsers and Email
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 19:22.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums