I have a new Surface Pro 3 with MS Office 10 on it. This is a new machine (2 weeks old.) All Office programs launch properly except Word. When Word is launched (either from a desktop shortcut to the program or by clicking a Word doc) the program opens and immediately displays an error message, "Windows is searching for Launcher.exe" followed by another error message, "The drive or network connection that the shortcut 'Logitech QuickCam.lnk' refers to is unavailable. Make sure that the disk is properly inserted or the network resource is available, then try again." When clicking OK the same error message repeats. When clicking OK a 3rd time the same error message repeats. Click OK again and the program opens normally, either to a blank document or to the document selected at launch. After a 2-hour session with Microsoft Office support included a complete "repair" over the internet, the same behavior occurs after the repair. The MS Office tech then took control of the machine and worked on it for a half-hour with no results, then told me that MS could not fix the problem. (!) NO Logitech software has been loaded on the machine.

Has anyone ever heard of such a problem, and is there a fix?