I haven't seen this situation mentioned so posting in case anyone can help. Fairly frequently, when I launch a UWP app (I've actually only tried the Settings app or Solitaire), I get the splash screen and it almost immediately disappears. If I click again, the app then launches and works correctly. After some time ( a day or two?), the same behavior happens again.

Reliability Monitor shows MoAppCrash and always (mostly?) mentions that Cortana stopped working in addition to whatever app just crashed.

I am on the latest stable build running Win 10 Pro - 64.
SFC shows no problems.
This is a native install as purchased from the laptop manufacturer, not an upgrade.

I'm not having problems with any other apps (and those are all non-UWP).

I've tried WSReset. First it found some problem it could not fix. Then I ran it again and it said it was fixed (cache problem). UWP seemed to work for a day or three and then the problems returned. I haven't tried WSReset again since the problems returned.

I have an Nvidia 970m GPU and do wonder if that could be causing a problem, although I don't have a specific reason for suspecting that.

I keep all drivers up to date. Of note, I was updating the Intel wireless chip, and that was causing major, major problems. I downgraded to the driver listed on the manufacturer site (MSI), and all problems went away. I may try that with Nvidia, since the Manufacturer is still only showing a year old driver.

I have seen threads about creating a new admin user and migrating over, but I am reluctant to do that as there are probably file paths and user name issues that may crop up. And, it bothers me...if that fixes it, then why can't I make a change to my current account and get this thing working.

Any thoughts, advice is appreciated.