Windows 10: Unable to Install Software From NAS drive

Page 1 of 2 12 LastLast

  1. Posts : 12
    Windows 10 Home 64-bit
       13 Oct 2016 #1

    Unable to Install Software From NAS drive

    Hi all

    I wonder if you guys can help me with something that's started happening fairly recently. I'm running Windows 10 x64 Home edition. If it helps, I have 16Gb of RAM and a 1TB HDD. I don't think that information will make any difference but there you have it.

    I also have a 1TB Western Digital MyBookWorld which I use as a remote storage tool for all of my documents. I'm not running a business or anything, I'm just paranoid about losing all of my stuff, especially the genealogy research information that I've spent years collating. Among other things, I like to store software on there - nothing illegal, just electronic copies of software that I own, so that if I want to remove and reinstall it I can so without having to grab the physical versions from the loft.

    About 10 days ago I sat down with the intention of installing some software on my PC. To let you understand, I've had the machine about 4 months but it's only now I've felt the inclination to install this piece of software. So, I accessed the folder on my NAS drive (which has a static IP address and to which I can connect using a mapped drive with NO issues. However, when I try to install the software I get this error:

    "Cannot start setup - the setup file may be corrupt, or you may have the wrong password. If you downloaded this file, please download a fresh copy. If the file is password protected, check your password and try again."

    I get this error regardless of whether or not I opt to run the installer as the Administrator. However, I then retrieved the master disc from my loft and ran it without incident. The folder on my NAS drive contains exactly the same subfolder structure and file contents as the master CD, so I don't think it can be that. I've tried copying the folder from the NAS drive to a location on my PC's HDD but get the same error. Finally, I've also tried to install the software onto my laptop (a 7-year old Dell with much less memory/HDD and an upgrade version of Windows 10 rather than a fresh version) and get the same result.

    My PC is fully up to date with all Microsoft patches (I've literally just checked this), and I'm wondering if one of the cumulative updates released by Microsoft may have had a negative effect.

    Has anyone seen this before? And if so, is there an easy fix?
      My ComputerSystem Spec

  2. Posts : 3,708
    Mac OS Sierra
       13 Oct 2016 #2

    Did you try copying the software from the other drive to your machine? Third Party security software can cause issues, along with a slow upload speed on the remote side and remote software being the issue.

    If you can use WinSCP to connect to it, try that.
      My ComputerSystem Spec

  3. Posts : 12
    Windows 10 Home 64-bit
    Thread Starter
       13 Oct 2016 #3

    bro67 said: View Post
    Did you try copying the software from the other drive to your machine? Third Party security software can cause issues, along with a slow upload speed on the remote side and remote software being the issue.

    If you can use WinSCP to connect to it, try that.
    Sorry, I should perhaps have been more clear. The NAS box is on the same internal network as my PC. I did try and copy the software from the NAS box to my local PC but it didn't make any difference. I'm using McAfee Anti-Virus and have tried stopping this software from running while I tried to install the software I'm trying to install.

    What I don't understand is this: if the AV is the problem, why does it let me install the software from the CD but not from a network-attached storage device? I also tried copying it to a USB memory stick, but that made no difference either.
      My ComputerSystem Spec

  4. Posts : 3,708
    Mac OS Sierra
       13 Oct 2016 #4

    You are clear, you just put way too much more information than you needed. Again, did you try copying the file that you were wanting to install from the NAS to your computer? Are you connecting with Ethernet to the NAS and network with the computer or using Wireless? What is the hardware mfg and model for the gateway and if you are using wired, are you connecting the computer directly to the gateway or off in some other room using a Ethernet run or adapters plugged into the electrical outlets.

    Western Digital storage drives are not the greatest, all due in part that their software is garbage and the hardware side for the CPU and RAM is way below what they should have used.

    I use a Synology NAS and connect with just a standard connection SMB connection to it with all devices. It is a huge step up from the Lenovo NAS that I used to use. It all comes down to that if you are going to do network storage, you need to invest in the proper storage gear and also network gear. Otherwise you are just killing yourself and spending twice as much in the long run when you replace cheap gear with cheap gear.
      My ComputerSystem Spec

  5. Posts : 3,708
    Mac OS Sierra
       13 Oct 2016 #5

    Since you have McAfee on the computer, it is best to just remove it completely. That in itself is 99% of the reason why people have issues when trying to connect to network shares or connect outside of the LAN.
      My ComputerSystem Spec

  6. Posts : 12
    Windows 10 Home 64-bit
    Thread Starter
       14 Oct 2016 #6

    Yeah, I'd been a bit concerned that perhaps I'd given too much information but better that than too little, right?

    What I've got is a NetGear hub which is plugged directly into the broadband router. The PC and NAS are also plugged into the hub. The reason I bought the NAS was so that I could store things like my iTunes repository on it and have it accessible by both PC and laptop alike. I take your point about the NAS being slow - probably why it was being sold for a knockdown price in the first place.

    I'm using McAfee solely because when I bought the PC four months ago I got a special deal on the subscription cost. Everything was running ok until about two weeks ago so in my view the issue is either coming from Windows 10 having been updated or McAfee having been patched. I find it odd that both PC and laptop are doing the same thing.
      My ComputerSystem Spec

  7. Posts : 3,708
    Mac OS Sierra
       15 Oct 2016 #7

    You may have felt that I was tearing you apart in the previous post, but that was not intended when I posted. This is more of a learning experience and when I wrote it up, it was about the WD box not why you chose it over something else. I got the 1TB hard drives for my Synology DIS216+2 for around $55 on Newegg. They are Constellation drives. The Fantom eSATA/USB 3.0 is a 3TB that I use for Plex storage and backup of the 2TB on the NAS.

    First NAS I got was no better than the My Book World that you have. I sent that back and got a Lenovo NAS that at the time was considered consumer top of the line. The Synology is ore of a middle to top Small Business type, since it gives you a lot of really good applications and I have yet to choke the sucker when streaming movies and doing a system backup at the time. Of course Plex complains that it cannot stream when I do that. It is just the nature of that software.

    Not too much that you are not on topic. Just too much as in that the basis of what you are dealing with is buried in it and I had to read through a couple of times.

    Your biggest issue is that you are using a storage system that is using tech that is over 16 years old. The CPU and small meager amount of RAM to handle file transfer and that it can be easily hacked to make it do stuff that WD never intended, is why it is more of a Hobbyist/Hacker gear. The unit runs on Busy Box, so it is also going to be limited in what kind of file transfers.

    McAfee has always been a known big headache since XP came out. It causes more problems in how McAfee thinks that your system should be protected, instead of letting the user decide. Windows Defender got even better when the Anniversary Update for Windows 10 rolled out. Back that behind a good gateway with the use of IPTables being used properly, you do not even need to run a software firewall on a computer.

    There is a lot of malware out there that is created to attack specific widely used branded security software, just like Windows is always targeted for malware. If you use safe computing standards and do not go off to somewhere or download some unknown file by protecting your browser with the proper extensions, especially with Firefox and Chrome, you do not need to use McAfee.

    Now getting back to the issue at hand. You may want to try with a direct USB connection to your computer without McAfee running and not installed to see if it is just McAfee that caused the problem. If you use WinSCP with SFTP or even Filezilla which is also good. You can connect through FTP to the WD unit and then just drag and drop files.

    Trying to do a install from a NAS does require some horsepower on the NAS and enough RAM to handle. I looked up the technical spec's on the WD My Book World. It reads like a B horror flick to me when I started to see that they basically took a USB drive and added an ethernet chip.
      My ComputerSystem Spec

  8. Posts : 3,708
    Mac OS Sierra
       15 Oct 2016 #8

    If you want to do iTunes streaming, look into Plex. The Synology units do allow you to run a iTunes server or use Plex as the server. You can still use the My Book as a USB storage for same imaging if it can keep up to not fall behind and take forever when you backup a computer.

    My setup in my System Spec's goes U-Verse Gateway with Cisco RV-320 in DMZ as Edge Router. The Netgear GS-108 switch is connected to the Cisco, my two Engenius Access Points are connected to the Cisco with Ethernet over Power Adapters, the Synology is also connected to the Cisco. From there I have my Silicon Dust Connect tuner that is a 10/100/1000 Ethernet connection to the GS-105, along with a NVidia Shield TV. Everything else in my house is Wireless that the majority are on the Engenius EAP1750H. I use the ECB350 for a Radio Thermostat Wifi-b Radio module and also for our Brother Laser. On the GS-105 switch downstairs there is Lantronix iOS Airprint server and two Ethernet jumpers.

    It took me a lot of trial and error to get my network to where it is now. It was built up from reading what others were running into on their setups and what equipment they found out what worked best. I some extra gear on hand like a couple of switches and Ethernet over Power Injectors in case I lose something.

    From what I started with 12 Ethernet jacks, I have taken it down to only 4 active jacks at this time, with two left in reserve in our two bedrooms in case I have to use them for something that I want hard wired.

    Just troubleshoot from the top down by eliminating software, then hardware as what is causing this issue. Then do as I did and build up the network infrastructure to something that you will know that you built with your own two hands and it will take care of you in return. Just remember to not let the significant other or housemates that the upgrades are for the good of the house hold and not because they believe that it is overkill.
      My ComputerSystem Spec

  9.    15 Oct 2016 #9

    Hi there

    Try the following - note even a "Stand alone NAS drive" has a built in OS so it can connect to the network.

    1) Switch ALL devices that can use the Internet OFF - power down completely - don't leave on standby. Switch off as well ALL mobile phones (if you are under the age of about 27 you probably don't realize that mobile phones actually DO have an Off switch on them !!!).

    2) wait 5 mins -- have a beer, scotch, coffee etc.
    3) switch on ROUTER first. let it power up and connect to ISP / internet.
    4) Switch on your NAS HDD.
    5) Now switch on ONE computer and connect to wifi.
    6) now see if you can connect to NAS.

    Sometimes you can have devices like chromecast dongles / smart TV's or whatever which can screw up the IP addresses - in general it's better to let your router serve these out via DHCP rather than use fixed IP addresses on your LAN - sometimes of course you need to have a fixed IP address - but if you can avoid it it's better.

    Phones are particularly prone to hosing up IP addresses - especially if you have a "Smart switch" on them that switches between 5 GHZ and 2.4GHZ dynamically depending on best signal.

    Note also some older devices won't connect via 5GHZ Wifi so if you are using wifi for connections ensure device can connect at the relevant frequency. If your 5GHZ is weak you can usually get a stronger signal (but will be slower) over the 2.4 GHZ band.

      My ComputerSystem Spec

  10. Posts : 12
    Windows 10 Home 64-bit
    Thread Starter
       17 Oct 2016 #10

    bro67 said: View Post
    You may have felt that I was tearing you apart in the previous post, but that was not intended when I posted. This is more of a learning experience and when I wrote it up, it was about the WD box not why you chose it over something else. I got the 1TB hard drives for my Synology DIS216+2 for around $55 on Newegg. They are Constellation drives. The Fantom eSATA/USB 3.0 is a 3TB that I use for Plex storage and backup of the 2TB on the NAS.
    Hi bro67. Rest assured, I absolutely did not think you were tearing me apart.

    I agree that the WD unit is probably substandard. The main reason for purchasing it was that my wife was climbing the walls about my PC being on 24/7, so purchasing a NAS solution that could be hooked directly into the router seemed like an easy win. Also, the WD unit was going cheap, probably because it was end-of-line so it solved the problem at the time.

    As an update, I decided the other day to remove McAfee from both the PC and the laptop and just let Windows Defender handle anti-virus scanning. The only reason I went with McAfee in the first place was because I got a good price, and because I could cover both PC and laptop with the same licence. To be honest, I'm more than a little bit wary of using a Microsoft product to protect my documents because I'm not convinced that the developers at Microsoft are 100% committed to security - a few years ago someone had suggested to me that Microsoft would turn a blind eye to certain companies being able to infiltrate their products in return for financial reward.

    If removing the antivirus hasn't solved the issue I was having, I might try an experiment whereby I wipe the laptop clean and install Windows 10 from the restore image I've got on USB. I still have a sneaking suspicion that there's something in the anniversary update that's causing the problem.
      My ComputerSystem Spec

Page 1 of 2 12 LastLast

Related Threads
Hi all, first post, so hoping I'm in the right place :/ ... I'm literally pulling what hair I have left out with this, normally this is a routine task for me, but I'm well and truly stumped, so thought I'd ask a Windows 10 community ... I have...
Hello guys, I need help for my new build. from a fresh install of windows 10 i try to install the drver for my IGPU Intel HD 530. each time i do that i get a BSOD with this message: VIDEO_TDR_FAILURE igdkmd64.sys Or sometimes it's...
Windows 10 Install unable to detect Drive. in Installation and Upgrade
afternoon. So I'm stuck with a windows 10 install were the installer dose not detect my drives, requesting drivers. But when you hit the browse button, you can see the drive I want to install too. This is not the first time this has...
Drive Imaging software for Win 10? in Performance & Maintenance
I've used Acronis True image for years on both XP and Win 7 without any problems. I don't keep TI installed on the systems, I install, Make the BOOT media and run all backups, Images, from booting from the rescue media. Usually loaded into a...
Hello, I have 2 drives in my Windows 10 machine. Windows sits on an SSD, and I've got a much larger rotational drive. Generally speaking, Windows recognizes the rotational drive just fine, and I've moved some default folders over to it. It...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 13:32.
Find Us