Windows 10: Net Framework 3.5 searching for required files problem

Page 2 of 2 FirstFirst 12

  1. Posts : 70
    windows 10 Insider Preview 16179
       20 Dec 2017 #11

    Wurstbrot24 said: View Post
    When I do this I get a progress bar that just gets stuck, same as the GUI version does.

    If you are running into the same problem, here is another solution. It requires you to have a Windows 10 installation USB stick (DVD might work as well). Plug it it and run the command posted by TairikuOkami, but replace the last line with:
    Code:
    ​Dism /Online /Enable-Feature /FeatureName:NetFx3 /All /Source:D:\sources\sxs /LimitAccess
    where D: is the drive letter of the Windows 10 installation USB stick/DVD.

    This command will install NetFx3 from the local file on the USB stick/DVD (microsoft-windows-netfx3-ondemand-package.cab) instead of attempting to download it and getting stuck.

    hth
    This is what happened when I followed #7:

    C:\WINDOWS\system32>taskkill /im TiWorker.exe /f
    ERROR: The process "TiWorker.exe" not found.

    C:\WINDOWS\system32>net stop wuauserv /y
    The Windows Update service is stopping.
    The Windows Update service was stopped successfully.


    C:\WINDOWS\system32>rmdir "%systemroot%\SoftwareDistribution\Download" /s /q

    C:\WINDOWS\system32>del "%ALLUSERSPROFILE%\Application Data\Microsoft\Network\Downloader\qmgr*.dat" /s /f /q
    Could Not Find C:\ProgramData\Application Data\Microsoft\Network\Downloader\qmgr*.dat

    C:\WINDOWS\system32>cleanmgr /sageset:65535 & cleanmgr /sagerun:65535

    C:\WINDOWS\system32>​Dism /Online /Enable-Feature /FeatureName:NetFx3 /All /Source:E:\sources\sxs /LimitAccess
    '​Dism' is not recognized as an internal or external command,
    operable program or batch file.

    C:\WINDOWS\system32>



    I pasted the command with the last line replaced as instructed with the Drive letter changed to E where my usb stick is and as soon as I pasted I was very quickly looking at a CleanManager window which I checked all but one line to delete and hit Enter. I got the above message back immediately with no netfx3 installation being completed.

    Now what?
      My ComputerSystem Spec

  2.    19 Jun 2018 #12

    unable to install >NET Framework 3.5 on Windows 10 Home


    Agh! not working for me either.
    ​Dism /Online /Enable-Feature /FeatureName:NetFx3 /All /Source:E:\sources\sxs /LimitAccess (where E is my dvd drive)
    found this batch file (below), which seemed to work. got to 100% but then an 'Error 2'

    @echo offTitle .NET Framework 3.5 Offline Installerfor %%I in (D E F G H I J K L M N O P Q R S T U V W X Y Z) do if exist "%%I:\\sources\install.wim" set setupdrv=%%Iif defined setupdrv (echo Found drive %setupdrv%echo Installing .NET Framework 3.5...Dism /online /enable-feature /featurename:NetFX3 /All /Source:%setupdrv%:\sources\sxs /LimitAccessecho.echo .NET Framework 3.5 should be installedecho.) else (echo No installation media found!echo Insert DVD or USB flash drive and run this file once again. echo.)pause

    tried "Turn Windows features on or off". that failed too.

    i have a stand alone copy of v3.5 - dotnetfx35setup.exe. It opens a dl and install window. it seems a file is being downloaded - according the the green progress bar, but then it says the feature couldnt be installed. Error Code: 0x80070002.

    any ideas please?

    Thanks.

      My ComputerSystem Spec

  3.    3 Weeks Ago #13

    Fixed


    TairikuOkami said: View Post
    Run CMD as admin and copy/paste:
    Thanks TairikuOkami!!!!!
      My ComputerSystem Spec


 
Page 2 of 2 FirstFirst 12

Related Threads
Hi, this has always been a problem I had with searching for files on windows for as long as I can remember. The problem is the search function barely works, 90% of the time it will not find what I search for even though I know for sure the files...
I seem to remember that in Windows 8 and 8.1, if I searched for a file but didn't remember the exact name of the file, I could type part of the name and the file would be found. But in Windows 10, if I don't type the whole name, and spell it...
I cannot seem to delete files when I'm doing a regular search in windows. I can go to any folder and delete files, but I when I see the same files in a search result, pressing del does nothing and when I right click, I have no option to delete them...
I love Windows 10 except for one thing: I cannot search files like I did before; it does not work in the same way and I cannot find the files I need like I did before! Formally, I used to type for example "contract in the search cell and all the...
I'm trying to install visual studio community 2015, however it has an error '.net framework required for setup'. Tried installing .net framework 4.5 but it is stated that 'Microsoft .NET Framework 4.5 is already a part of this operating system. ...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 04:01.
Find Us