I'm running the latest version of Windows 10 in developer mode, with the latest version of Visual Studio 2015 Community.
I need to install the Windows Universal App Development Tools in order to develop UWP C# apps.

1) Firstly, I've tried to download & install the packages from VS setup. I chosed Modify, and checked all the packages of Windows Universal App Development Tolls, then Next & UPDATE. The installation ends up with this message:
Click image for larger version. 

Name:	VSERROR.png 
Views:	4 
Size:	17.7 KB 
ID:	100407

2) I didn't thought it should prevent me from UWP development, so Iv'e launch VS, and then tried to create new UWP blank appliction project. This ends up with this message:
Click image for larger version. 

Name:	vserror2.png 
Views:	4 
Size:	8.1 KB 
ID:	100408

3) Iv'e tried to download some UWP & IOT templates from VS extensions, didn't solve the issue.

4) So I kinda understood this connects to the Windows 10 SDK. I tried to download the SDK from the standalone setup:
Threre are 2 options to download the SDK:
Click image for larger version. 

Name:	windowssdkerror.png 
Views:	1 
Size:	18.5 KB 
ID:	100409
Both options installation ends up with this error:
Click image for larger version. 

Name:	sdkerror.png 
Views:	1 
Size:	12.9 KB 
ID:	100410

5) Iv'e tried to either Repair and Uninstall VS. Didn't solve the issue.
6) Iv'e tried to delete the Temp folder in AppData>Local, didn't solve the issue.
7) Iv'e tried to download the standalone SDK files to 2 another PC's. It's also ends up with the error in section 4.

I don't have any idea what to do in order to install the SDK and create UWP apps... Someone can help me please?