8GadgetPack freezing suddenly after months of trouble-free performance


  1. Posts : 89
    Windows 10 Home 64bit
       #1

    8GadgetPack freezing


    I have 2 PCs, one an HP laptop, the other an ASUS desktop, that are both pretty well configured almost identically, same programs installed, same settings and tweaks.

    I’m running the latest version of 8GadgetPack on both and had no problems at all for months. (I only use the MS clock, calendar, and weather gadgets.) Then a couple weeks ago they started freezing on my laptop. I noticed the clock was almost 45 minutes behind one day. I tried to double-click it and then right-click on it and then tried the other 2 gadgets. All 3 were frozen. I closed all 3 down with the task manager and re-opened them. They ran fine for about 5 minutes then froze again. (The clock stopping is the give-away.)

    I did a system clean with CCleaner and then rebooted. The gadgets loaded and worked for about 5 mins again and then froze up again. After a few days of trying to solve this I decided “screw it” and went to uninstall it. I saw a “Repair/Reset” option on the uninstall screen and decided to try that first. It worked, and the gadgets started running normally again and continued to do so for a few weeks. I thought the problem was fixed. Today, out of nowhere, the freezing started again (I noticed the clock had stopped)! I tried the reset again, which didn’t work this time. I tried uninstalling and reinstalling. Still freezing. Now I’m at a loss.


    This whole time on my other PC, these same gadgets having been running flawlessly. As I said, both systems are running the same version of 8GadgetPack and Win10, fully updated, and both systems are configured almost identically.

    What the heck—?

    Last edited by pjfarr; 26 Aug 2016 at 16:09.
      My Computer


  2. Posts : 89
    Windows 10 Home 64bit
    Thread Starter
       #2

    After viewing the FAQs on the 8GP website, it mentioned some issues can be fixed by going into the "Tools" menu and selecting a different display size for the gadgets. There's only 2 sizes available, small and regular. I tried "small" and that seems to have somehow fixed the freezing issue (for now). It's been several hours and none of the gadgets have frozen.

    They're quite a bit smaller now, but they are legible. I'd prefer to have them the regular size, but this is okay I guess. I'd like to be able to figure out why the display size affects the performance.
      My Computer


  3. Posts : 89
    Windows 10 Home 64bit
    Thread Starter
       #3

    I think I figured it out.

    Since the gadgets worked without any problems at the smaller size only, I figured it might have something to do with screen resolution. I didn't care for the smaller size so I was determined to sleuth out the connection to dpi. Pouring over the 8GP website's documentation I found that custom dpi settings can be set for the gadgets via the registry. I tried a couple sizes and settled for "80" (see below) . Restarted the gadgets and, although they now appear slightly larger than their normal size, they're working. It's been about a day and they haven't froze yet, so I believe the issue is solved.

    Registry settings:

    [HKEY_CURRENT_USER\SOFTWARE\8GadgetPack]
    "ForceDPI"=dword:00000080
    "OverrideDPI"=dword:00000080
      My Computer


  4. Posts : 85
    Win10 Pro, Version 21H2 (Build 19044.1348) (02.12.2021)
       #4

    Thank you very much pjfarr! The two settings
    a) "Make Gadgets smaller" in 8GadgetPack Tools-Settings
    and
    b) your registry setting 80 (instead of default 60)
    gave me back stable and readable gadgets.

    Finally, I can see the entire width of diagrams and bars inside the single gadgets in my Win10 Anniversary Update.
    Last edited by WTenNewbie; 23 Sep 2016 at 09:19.
      My Computers


  5. Posts : 89
    Windows 10 Home 64bit
    Thread Starter
       #5

    WTenNewbie said:
    Thank you very much pjfarr!
    Happy it worked for you too! There have been no problems at all for me since changing the registry settings...it started for me after the Anniversary Update as well.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 01:34.
Find Us




Windows 10 Forums