Trouble with Canon CR2 RAW files

  1.    23 Aug 2016 #1

    Trouble with Canon CR2 RAW files

    Hi: I upgraded from 8.1 to 10 about 6 weeks ago.
    Hopefully this is the right forum for the problem.
    Latest issue is that when I connect my (older) Canon camera via USB to the computer, Windows 10 can see the drive/CR2 files on it OK, but cannot display them (just lists them with a generic thumbnail icon).
    None of my various photo editing software programs can even see the USB connection post Windows upgrade.
    If I move a CR2 file from the camera to the hard drive, none of the photo viewers (that could all previously display CR2 images in 8.1) can display them now - I have updated to the latest Win10 versions of those viewers, still no luck.
    To make it even stranger, Windows and the other photo viewers can display the existing CR2 files (i.e. that were present on the hard drive when I did the Windows update, and came from the same camera) with no problem, it's only new ones from the camera (which has NOT had a firmware update or any changes like that) that it can't seem to handle.
    Any ideas? I really don't want to have to roll back to 8.1 ...
      My ComputerSystem Spec

  2. Berton's Avatar
    Posts : 5,877
    Win10 Home and Pro, Win10 Insider Preview, WinXP Home Premium, Linux Mint
       23 Aug 2016 #2

    I'd try the free GIMP program to convert the files to .jpg.
    GIMP - Frequently AskedĀ*Questions
    A client was saving both RAW and JPG on his Canon EOS 50D [mine is a 60D] and filling up the card, simple to make the change to only JPG in the camera setup. The JPG files were about a fourth the size of the 20MB RAW files, didn't seem to have lost much detail.
      My ComputerSystem Spec

  3.    24 Aug 2016 #3

    I haven't experienced any problem with any .cr2 files in Windows 10, even from my old cameras. As a test I just downloaded a sample 20D raw file from THIS website (which was taken June 2005) to see if a file from someone else's camera would trigger the issue, but that too correctly shows the thumbnail in Windows File Explorer and opens correctly in the Windows Photo app.

    cr2 files are already part of the Microsoft camera codec pack that is automatically updated through Windows Update, so no user action is required to display them. Therefore, I suspect that maybe there's some sort of conflict with the other software you have installed (maybe they installed their own codecs for example)? You could try setting the Windows Photo app as the default program to open .cr2 files and see if they display OK then (See Option 4 in this tutorial). Failing that, try to figure out if any of your third-party programs could be modifying Windows File Explorer and thus could be causing problems. Worst case scenario is not to go back to Windows 8.1, but to backup all your data and reset Windows 10 back to scratch, because Windows 10 does display .cr2 images and thumbnails correctly when everything is working properly.

    Berton said: View Post
    A client was saving both RAW and JPG on his Canon EOS 50D [mine is a 60D] and filling up the card, simple to make the change to only JPG in the camera setup. The JPG files were about a fourth the size of the 20MB RAW files, didn't seem to have lost much detail.
    Shooting jpeg only is fine for the majority of people, however doing so you loose the ability to change picture style profiles, white balance, utilise Canon digital lens optimiser profiles, etc. before the demosaicing process takes place. You also lose the extra headroom to recover highlight detail and the ability to output straight to 16-bit TIFF for post work, as JPEG is 8-bit with lossy compression. So depends on what people want from their images as to what format they choose to shoot in.
      My ComputerSystem Spec

  4.    24 Aug 2016 #4

    I had the problem but a camera firmware update sorted it
      My ComputerSystem Spec

  5. jimbo45's Avatar
    Posts : 6,363
    Windows / Linux : Centos, Ubuntu, OpenSuse
       24 Aug 2016 #5

    Samuria said: View Post
    I had the problem but a camera firmware update sorted it
    Hi there

    just curious but why would a camera firmware update making ANY DIFFERENCE AT ALL to existing .cr2 files being handled (or not handled as the case may be) by Windows. I can't even understand why it would make any difference to NEW .CR2 files either - but you can have the benefit of the doubt on that - it certainly shouldn't make ANY difference to EXISTING .CR2's.

    .CR2 files all work fine for my cameras on W10 - although I use Photoshop for processing. Things like Photoshop elements will handle .CR2 files as well if you don't want full blown photoshop.

    For those who use GIMP on Windows - here's how to add RAW support. (GIMP is great and FREE for people who want to do a lot of processing and don't want Photoshop which isn't cheap !!!).

    RAW Photos With GIMP | How to GIMP

    I don't like converting to png / jpg .

    RAW (.CR2) files are like your original negatives and can be re-processed over and over again as they are lossless. If you need to edit jpg's etc a number of times then you are already editing a lossy format and will lose more and more data from the picture.

    With RAW you can mess around with layers - alter white balance etc and do so many more things to really enhance a good photo.

      My ComputerSystem Spec

  6.    24 Aug 2016 #6

    Thanks for the replies. I just had a quick chat with Canon. They're stumped too. Makes no sense why Windows 10 can handle all the existing CR2 files from this camera with no problem at all, but can't display any new ones that I try to download to my computer. I shot a test pic in JPG a few minutes ago, and that one is fine in Windows. Somewhere along the line Windows is eating the CR2, because the other photo editing software (including Canon's DPP) can't work with the new ones either.
    Here's the display in File Explorer - existing CR2 files and new ones:

    Click image for larger version. 

Name:	Capture.JPG 
Views:	27 
Size:	23.9 KB 
ID:	97947
    The Windows photo editor says it can't open the file.
    Maybe I have to shoot JPG with this camera from now on, which is a pain because RAW allows you to salvage pics that might otherwise be unusable.
      My ComputerSystem Spec

  7. jimbo45's Avatar
    Posts : 6,363
    Windows / Linux : Centos, Ubuntu, OpenSuse
       24 Aug 2016 #7

    Hi there

    How do you handle the .CR2 files from the camera -- do you transfer directly into computer or do you process with camera still attached to the computer. My preference would be to copy / transfer files into computer.

    I only leave camera attached to computer on those occasions where I am shooting some Pro stuff in "Tethered Mode" which is a different issue entirely.

    You can I think download a TRIAL of photoshop -- see if that handles .CR2. I try and avoid canon's software -- I like their cameras etc but they sure make LOUSY software --I never liked DPP in the first place. You might also need the latest updates ( I think Canon are still on Windows 7 !!!! never mind about 6 / 8.1 and 10) - and see if they have any RWA camera updates. They also have issues with x-86 and x-64 bit windows so chose the correct version.

      My ComputerSystem Spec

  8.    24 Aug 2016 #8

    I usually use a freeware program called Faststone (latest version), which I love for basic manipulation, batch resizing, file conversions etc. It can't handle the 'post upgrade' CR2 files either and it has always struck me as a very robust bit of software.
    I always transfer to the computer to manipulate - that way I can delete from the memory card sooner. The camera is an old Rebel XT which they are not really supporting any more (no parts available etc). Other than that the firmware and version of DPP (supports Win10) are upgraded to the latest possible for that camera. I don't really want to bother (pay for) with Photoshop - if it works then I have to buy a subscription and I already have another piece of software (ArtRage) that does most of what Photoshop does. Ho hum.
    I'll see if anyone else comes up with suggestions for a while, and if not then I'll close the thread. Just wish MS would get their act together - you should see the song and dance routine over power settings I've been going through too!
      My ComputerSystem Spec

  9.    05 Jul 2017 #9

    Is there a RAW codec or similar software from Canon you need to download?
      My ComputersSystem Spec

  10. Fisher Mann's Avatar
    Posts : 321
    Win 10 Pro x64 18277 Fast
       05 Jul 2017 #10

    I have not been on the Canon site for downloads for quite some time but they use to have photo editing software there that would download from your camera or sd/cf cards. You could also install your possibly needed cr2 drivers and any firmware for your camera. I have been a fan of Lightroom since version 1 but also have PS and Bridge (unfortunately from the cloud now). Lightroom should download your pics with no issues at all.
      My ComputersSystem Spec


Related Threads
Solved Canon Toolbox Software in Drivers and Hardware
Hi Have installed Canon MF4690PL vista drivers and run update for win10 which showed drivers as correctly loaded in device manager. Have installed Canon Toolbox for scanning from this device. There isn't much wrong and I'm sure that I just...
Solved Trouble running .bat files in General Support
Hi, I'm trying to run .bat files on Windows 10, but it tells me that "This app can't run on your PC". It doesn't matter what I use it for, .bat files just won't run anyway. Are .bat files no longer supported? (ran fine on Windows 7) Any...
double Canon printer trouble in Drivers and Hardware
One of my pc's runs W7ult64, W10pro64 upgrade and W10pro64 build10532. It is connected to a Canon MG5550 all in one printer. W7 is running printer drivers loaded from the cd and up till now, I havn't bothered to try printing from either W10. Neither...
Since upgrading from Windows 7 I have been having some difficulty opening files and even starting programs by clicking on them. Often I have to right click the icon or file and then choose open. I thought it may have been I just didn't have the...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 17:06.
Find Us