Visual Studio 2015 Crash on Windows 10 Anniversary Update


  1. Posts : 28
    WIndows 10
       #1

    Visual Studio 2015 Crash on Windows 10 Anniversary Update


    Recently I updated my Windows 10 with the Anniversary update. Since then Visual Studio crashes like crazy and some of the programs are not working.
    Here are the crash errors:

    Code:
    - <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
            - <System>
              <Provider Name=".NET Runtime" /> 
              <EventID Qualifiers="0">1026</EventID> 
              <Level>2</Level> 
              <Task>0</Task> 
              <Keywords>0x80000000000000</Keywords> 
              <TimeCreated SystemTime="2016-08-18T18:16:39.081375400Z" /> 
              <EventRecordID>2999</EventRecordID> 
              <Channel>Application</Channel> 
              <Computer>PC</Computer> 
              <Security /> 
              </System>
            - <EventData>
              <Data>Application: devenv.exe Framework Version: v4.0.30319 Description: The process was terminated due to an unhandled exception. Exception Info: System.TypeLoadException at
         Microsoft.VisualStudio.VIL.DebuggerHost.VirtualAppDomain.get_DebuggerTypeUniverse() at 
        Microsoft.VisualStudio.VIL.DebuggerHost.GlobalContext.Dispose(Boolean) at
         Microsoft.VisualStudio.VIL.VisualStudioHost.VSGlobalContext.Dispose(Boolean) at 
        Microsoft.VisualStudio.VIL.VisualStudioHost.Interpreter.Destroy() at
         VSDebugEngine.ClrInspector.VilHelper.Dispose() at
         VSDebugEngine.ClrInspector.VilHelper.OnClose() at 
        Microsoft.VisualStudio.Debugger.DkmDataItem.InvokeOnClose(XapiComponentInfo*, Microsoft.VisualStudio.Debugger.DkmDataItem) at
         Microsoft.VisualStudio.Debugger.DkmDataContainer.OnCloseNativeObject(XapiComponentInfo**) at
         Microsoft.VisualStudio.Debugger.DkmDataContainer.Callback_OnCloseNativeObject(IntPtr, XapiComponentInfo**)</Data> 
              </EventData>
              </Event>
    ----------------------------------------------------------------------------
    And

    Code:
         - <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
        - <System>
          <Provider Name="Application Error" /> 
          <EventID Qualifiers="0">1000</EventID> 
          <Level>2</Level> 
          <Task>100</Task> 
          <Keywords>0x80000000000000</Keywords> 
          <TimeCreated SystemTime="2016-08-18T18:16:39.250653400Z" /> 
          <EventRecordID>3000</EventRecordID> 
          <Channel>Application</Channel> 
          <Computer>PC</Computer> 
          <Security /> 
          </System>
        - <EventData>
          <Data>devenv.exe</Data> 
          <Data>14.0.25420.1</Data> 
          <Data>57685d85</Data> 
          <Data>KERNELBASE.dll</Data> 
          <Data>10.0.14393.0</Data> 
          <Data>57898e34</Data> 
          <Data>e0434352</Data> 
          <Data>000d96c2</Data> 
          <Data>1e38</Data> 
          <Data>01d1f97c98f42dde</Data> 
          <Data>C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\devenv.exe</Data> 
          <Data>C:\WINDOWS\System32\KERNELBASE.dll</Data> 
          <Data>f9cb238c-e79f-46c2-bd5e-1ddcaa9fb9c7</Data> 
          <Data /> 
          <Data /> 
          </EventData>
          </Event>
    ---------------------------------------------------------------------------

    Code:
    - <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
        - <System>
          <Provider Name="Application Error" /> 
          <EventID Qualifiers="0">1000</EventID> 
          <Level>2</Level> 
          <Task>100</Task> 
          <Keywords>0x80000000000000</Keywords> 
          <TimeCreated SystemTime="2016-08-18T19:10:34.635049600Z" /> 
          <EventRecordID>3122</EventRecordID> 
          <Channel>Application</Channel> 
          <Computer>PC</Computer> 
          <Security /> 
          </System>
        - <EventData>
          <Data>Microsoft.Alm.Shared.Remoting.RemoteContainer.dll</Data> 
          <Data>14.0.23107.0</Data> 
          <Data>559b78f2</Data> 
          <Data>KERNELBASE.dll</Data> 
          <Data>10.0.14393.0</Data> 
          <Data>57898e34</Data> 
          <Data>e0434352</Data> 
          <Data>000d96c2</Data> 
          <Data>19cc</Data> 
          <Data>01d1f9843068d6aa</Data> 
          <Data>C:\WINDOWS\Microsoft.Net\assembly\GAC_32\Microsoft.Alm.Shared.Remoting.RemoteContainer\v4.0_14.0.0.0__b03f5f7f11d50a3a\Microsoft.Alm.Shared.Remoting.RemoteContainer.dll</Data> 
          <Data>C:\WINDOWS\System32\KERNELBASE.dll</Data> 
          <Data>7d4ce7e2-ade2-4814-bb3e-84dfebb60b4e</Data> 
          <Data /> 
          <Data /> 
          </EventData>
          </Event>
    ----------------------------------------------------------------------------

    Code:
    - <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
            - <System>
              <Provider Name=".NET Runtime" /> 
              <EventID Qualifiers="0">1026</EventID> 
              <Level>2</Level> 
              <Task>0</Task> 
              <Keywords>0x80000000000000</Keywords> 
              <TimeCreated SystemTime="2016-08-18T19:10:34.561501300Z" /> 
              <EventRecordID>3121</EventRecordID> 
              <Channel>Application</Channel> 
              <Computer>PC</Computer> 
              <Security /> 
              </System>
            - <EventData>
              <Data>Application: Microsoft.Alm.Shared.Remoting.RemoteContainer.dll Framework Version: v4.0.30319 Description: The process was terminated due to an unhandled exception. Exception Info: System.InvalidOperationException at
         System.Diagnostics.Process.GetProcessHandle(Int32 access, Boolean throwIfExited) at 
        System.Diagnostics.Process.OpenProcessHandle(Int32 access) at
         System.Diagnostics.Process.set_EnableRaisingEvents(Boolean value) at 
        Microsoft.Alm.Remoting.RemoteContainer.ServerHost.Execute(String clientObjectUri, Process parentProcess) at 
        Microsoft.Alm.Remoting.RemoteContainer.EntryPoint.ExecuteInOtherAppDomain(String clientObjectUri, Int32 parentProcessId) at 
        Microsoft.Alm.Remoting.RemoteContainer+EntryPoint.ExecuteInOtherAppDomain(System.String, Int32) at 
        Microsoft.Alm.Remoting.RemoteContainer+EntryPoint.Main(System.String[])</Data> 
              </EventData>
              </Event>
    I have a simple Windows Forms App. It was working alright before the update. Now it's not working. It starts as process but nothing more. No UI shows up. When I open the solution and choose some cs or designer files a loading message box shows saying "Opening the file..." and loads endlessly.

    I have another simple launcher for the Mail App.

    Code:
    public static void Main()
        {
              Process.Start("explorer", @"shell:Appsfolder\microsoft.windowscommunicationsapps_8wekyb3d8bbwe!microsoft.windowslive.mail");
        }
    It's not working any more. O_o If I type the shell explorer shell:Appsfolder\microsoft.windowscommunicationsapps_8wekyb3d8bbwe!microsoft.windowslive.mail through Run it is working fine though. What have they done to the new Windows?
      My Computers

  2. Mystere's Avatar
    Posts : 3,257
    Windows 10 Pro
       #2

    Applications don't always migrate correctly to a new build. So sometimes, you are forced to re-install them.

    This is not a problem with "the new windows", it's a problem with the app migration during the upgrade. Re-installing makes things correct again.
      My Computer


  3. Posts : 28
    WIndows 10
    Thread Starter
       #3

    So your advice is to reinstall VS2015? That's not a problem.
    But the other two problems are too odd.
    My windows forms application builds successfully but doesn't work on this Windows version. Very strange.
    And the simple process with the shell work from Run but when built in exe it doesn't.
      My Computers


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 04:16.
Find Us




Windows 10 Forums