1.    14 May 2015 #1
    Join Date : Feb 2015
    Posts : 224
    Windows 10 Enterprise LTSB

    how to i really Add AVI support to sony vegas?


    For years ive used sony vegas editing video/audio tool but the lack of extension support is keeping if from being the only tool i use. but long story short i need to add AVI support to sony vegas, I deal with a lot of avi files and vegas cant ust those files. I would normally have to convert to mp4 and then add to vegas to edit but that degrades quality of the video. i have been trying all kinds of codex off the internet and none work. Does anyone here have AVI support?
      My ComputerSystem Spec
  2.    15 May 2015 #2
    Join Date : Sep 2014
    Nashville, TN
    Posts : 3,143
    Windows 10 Pro

    According to this article, Vegas will use whatever codecs you have installed:

    http://www.techisky.com/how-to/sony-vegas-avi.html

    If the AVI file is using a codec you don't have installed (and lets face it, it could be encoded with any of hundreds of codecs) then you will have issues. There's no single codec that does everything.

    What you will have to do is determine which codec you need, you can do this by using a tool like gspot http://www.headbands.com/gspot/ or avicodec http://avicodec.duby.info/

    This will identify the codec you need, then you need to find it and install it. There are a number of links on the avicodec page to codec packs.

    If you've installed codecs and its still not working, then you probably don't have the right codec or the right version. Also, which version of Vegas are you using? You may need 64 bit codecs as well as 32 bit ones.
      My ComputerSystem Spec
  3.    15 May 2015 #3
    Join Date : Feb 2015
    Posts : 224
    Windows 10 Enterprise LTSB
    Thread Starter

    Well it seems to work now under certain conditions

    wants wav sound

    its a start but is dosent seem to like avi's from one of my cameras (a rather old one)

    i installed

    Lagarith
    and Xvid

    still would love 100% support
      My ComputerSystem Spec
  4.    15 May 2015 #4
    Join Date : Dec 2013
    England
    Posts : 944
    Windows IP 17017

    Quote Originally Posted by xdarkmario View Post
    Well it seems to work now under certain conditions

    wants wav sound

    its a start but is dosent seem to like avi's from one of my cameras (a rather old one)

    i installed

    Lagarith
    and Xvid

    still would love 100% support
    You could try Shark007 codecs.
      My ComputersSystem Spec
  5.    15 May 2015 #5
    Join Date : Sep 2014
    Nashville, TN
    Posts : 3,143
    Windows 10 Pro

    Quote Originally Posted by xdarkmario View Post
    its a start but is dosent seem to like avi's from one of my cameras (a rather old one)
    What's the camera model? Have you checked the specs to find out which codecs it uses?
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Facing BSOD Wdf01000.sys whenever i try to do something on Sony Vegas
this problem started from yesterday and still i couldn't fix it. Everything is just fine but if i try to do something on sony vegas i get blue screen this never happened with me before. I have tried to uninstall and reinstall vegas, uninstall and...
BSOD Crashes and Debugging
Solved Sony Vegas Pro 12 Crashing on Launch
On my PC (running build 10049), when I try to open Sony Vegas Pro 12 it closes when it gets to "Creating Windows". It was working fine a few days ago and I haven't installed any updates. It also works fine on my SP3 running the same build.
Software and Apps
Solved Sony OptiArc AD7240 not seen
During the install of 10041 I found that it was taking over 10 hours. Forced a reboot and the OS came up. When I tried to run a program install from a CD (non-bootable) the drive did not run. Only a bootable installer (W10) on a clean startup is...
Installation and Upgrade
Solved Sony Veags Crashes 13 when trying to render a video.
so i noticed that sony vegas 13 is crashing whenever i try to render a video. anyone else have sony vegas?
Software and Apps
Shades of Sony!
Lenovo slapped with lawsuit over dangerous Superfish adware | PCWorld Lenovo slapped with lawsuit over dangerous Superfish adware Talk about yer crapware!
Chillout Room
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 16:42.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums