1. Joined : Aug 2016
    Posts : 8
    Windows 10
       09 Aug 2016 #1

    Task Scheduler will not run Vista WinCal.exe Reminders


    I prefer to use the old Vista WinCal.exe as a local calendar on my PC because it runs in the background and provides timely reminders of appointments and events without having to sign in to an e-mail account. I was able to set it up and have Task Scheduler run reminders on Win7 Pro but, since upgrading to Win10 Pro, the reminders will not run. The WinCal task creates Scheduled Task for reminders (i.e. Snooze for 5 mins) as it should but the task fails with a "requires elevation" type message. I have tried to check "run at highest" option in the original task but that option does not transfer to the reminder task. If I edit the reminder task admin option, it will run just fine but subsequent tasks never have the option set. With UAC disabled, the calendar and reminders work fine, however, I lose all Metro Apps. If I enable "User Access Control: Admin Approval Mode For built in…..”, metro apps work again however, the reminders fail.

    WinCal.exe runs from the desktop and taskbar shortcuts. It runs at startup and will display any reminders at startup but, doesn't display any further reminders until next reboot.

    I tried to create a separate User Account with Admin privileges but it acts the same way.

    Any suggestions to allow me to take advantage of the UAC security and still be able to run Metro apps with WinCal.exe fully functional would be appreciated. Please, do not suggest installing other applications. This one worked in Win7 and I'd like to continue using it in Win10 since it has over 3 years worth of appointments and tasks history.
      My System SpecsSystem Spec

  2.    09 Aug 2016 #2

    If you start it by right clicking and choose run as administrator does it all work then if so we can set it to start as admin
      My System SpecsSystem Spec


  3. Joined : Aug 2016
    Posts : 8
    Windows 10
       09 Aug 2016 #3

    Tried that, still doesn't work. Also have set the .exe to run as admin for all users. Made sure users had read/write access to files and folders. Even tried to create a batch file with admin privileges with no luck. WinCal is located in C:\Program Files\Windows Calendar\ folder. I didn't run Win8/8.1 but I suspect that it's broken there as well... As I said above, I have set the original Task to run as admin but that setting isn't transferring to the task created by WinCal. Since it worked fine with the original settings in Win7, it Definitely appears to me to be a UAC / Admin token issue. Seems that Task Scheduler and the Wincal app are running in different accounts privileges....
      My System SpecsSystem Spec

  4.    09 Aug 2016 #4

    If your logged in as one user and the task then runs as admin it wont be seen by the user it all needs to be same account are you running it in compatibility mode for vista
      My System SpecsSystem Spec


  5. Joined : Aug 2016
    Posts : 8
    Windows 10
       09 Aug 2016 #5

    Only running one account. It is the Built-in Admin account (as set up by Windows 10 Upgrade from my Windows 7 configuration.
    Yes, have it set to run in Vista Comp mode....
      My System SpecsSystem Spec


  6. Joined : Aug 2016
    Posts : 8
    Windows 10
       11 Aug 2016 #6

    OBTW, in Vista and Win7, this task ran at lowest privilege level. Didn't require elevation or run as admin....
      My System SpecsSystem Spec


 


Similar Threads
Thread Forum
Solved Task Scheduler
Will this work without username password logging on? In windows7 you had to have password to make it work.
Installation and Setup
How to show Command Prompt Window when running task in Task Scheduler?
Is there a way to make the "Command Prompt" window show when I have a task running in Windows task Scheduler? I would like to be able to view the progress of the task. For example, I have a program called "Zap2xml" that collects TV EPG data. It...
General Support
Task Scheduler
I have set up a scheduled task called its time and every time I try to run it here is what comes up. I am using Win 10 and have plenty of ram 12GB. Here is message in attachment. Please help. It has worked in past with Win7. But no go in Win10??...
General Support
Task Scheduler
At one time I was showed how to set an alarm using Task scheduler. It worked great when I was using Windows 7. Since I have upgraded to Windows 10, it doesn't work anymore. I put in the scheduler the same words but when it is time to go, a pop up...
General Support
Solved Time Zone change causes error in Task Scheduler for every task
My issue is kind of strange. I am an insider currently on Windows 10 build 10240. All the build I have tried so far has this same error in task scheduler when I change my time zone to my current location which is kathmandu (UTC+5:45). When i change...
Performance & Maintenance
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 05:59.
Find Us
Twitter Facebook Google+



Windows 10 Forums