Windows Store error 0x80070005 when using a different location to C: Solved

Page 1 of 4 123 ... LastLast

  1. Posts : 75
    Windows 10 Pro v1703 Build 15063
       19 Jul 2016 #1

    Windows Store error 0x80070005 when installing/moving to non-C: drive

    I've been experiencing a particularly frustrating problem since upgrading from Windows 10 Pro v1511 Build 10586.494 to v1607 Build 14388 a few days ago (update: I am now on Build 14390 with the same issue; Build 14393 is downloading now but I suspect it will have the same issue as well). In fact, this is the second time I've installed a preview build since I had the same issue going from Build 10586 to 14385 and decided to restore my backup.

    The issue is odd because Windows is otherwise working fine. I have no crashes or stability issues, games, programs and apps all run as expected and the Windows Store is finding updates for apps and games and installing them. The issue relates ONLY to the Windows Store and its apps and games, specifically with the installation of new ones. Windows Update is apparently working fine (although at the moment it is only finding and updating Windows Defender anti-virus definition updates). The problem is if I attempt to install any new Windows Store app or game, where the storage location is anywhere but C: (I have the default apps location under Settings > System > Storage set to H) then they fail after a small sub-1 MB download with error 0x80070005.

    What I have determined is the following:

    1. If I change the Storage location for apps back to C: (which is my Windows boot drive on an SSD by the way) then new apps and games will download fine, even those which previously repeatedly failed with error 0x800700005 when the location was set to H:.

    2. With the H:\WindowsApps folder open while trying to install a new game or app from the Store, I can see folders being created and some files appearing in them. If the download fails with error 0x80070005 then the Store will try to download it again, at which point another folder appears. This repeats until I cancel the failed download and all the folders then disappear.

    3. The Windows Store seems to be able to update apps and games which were already installed before the Windows upgrade regardless of whether they are on C: or H: (note: this may not actually be correct - see my second post below. However, apps and games installed on the C: drive DO appear to update and install fine).

    4. I am unable to move any apps or games from C: drive to the H: drive or vice versa (correction: actually I can move games from H: to C:, just not C: to H: even if I have just moved them from H:). Again, they fail with error 0x80070005 (which I believe is a permission issue meaning access denied).

    5. There are three Accounts_Unknown entries showing under Properties > Security on the H:\WindowsApps folder. These accounts do not show on the hidden C:\Program Files\WindowsApps folder. These unknown accounts are (truncated as I am not sure the long string of numbers are relevant):


    Things I've tried to fix the error are:

    a. Taking ownership of the H:\WindowsApps folder (I use a standard admin account with the Microsoft account).

    b. Setting all the accounts (Users, Administrators, etc) to Full Control and hitting Apply if they didn't have that access to start with.

    c. Deleting the unknown accounts and hitting Apply.

    d. Using Windows Repair All-in-One to reset the registry permissions and file permissions for both C: and H:.

    None of those make any difference.

    I suspect the issue is somehow linked to those unknown accounts but I am at a loss as to how to fix them. I have no problems with installing smaller Windows Store apps to my C: drive but larger games such as Quantum Break have to be installed to a different drive due to their size and the lack of space on my Windows SSD.

    Can anyone point me in the right direction on how to fix this annoying issue please?

    Last edited by Daz1967; 25 Jul 2016 at 13:00.
      My ComputerSystem Spec

  2. Posts : 75
    Windows 10 Pro v1703 Build 15063
    Thread Starter
       19 Jul 2016 #2

    Regarding the Account_Unknown entries in my opening post, I've seen these accounts in the security permissions of folders on my C drive but they just show as S entries (i.e. with the Account_Unknown() part).

    I checked for updates on the Store this morning and it found 6 updates; 5 for apps on my C drive and 1 for Forza Motorsport 6: APEX, which is located on my H drive. Needless to say, all 5 apps on the C drive downloaded and updated fine but Forza again threw up the 0x80070005 error.

    This issue is absolutely infuriating me at the moment. I know I could delete Forza and with the Storage location for apps set to C redownload. However, while it would update from my C drive I would be unable to move it to my H drive.

    If I try to take ownership of the H:\WindowsApps folder then I get a failed message which, I believe, is due to the actual Microsoft.Apex folder because if I try to manually apply Administrators permissions to that folder then I get an error for every file in the folder.

    Can anyone help me with this please?

    (P.S. This issue still remains if I restore my v1511 backup for a week or so ago so it may not just be an issue specific to the Insider Preview builds after all.)
      My ComputerSystem Spec

  3. Posts : 75
    Windows 10 Pro v1703 Build 15063
    Thread Starter
       19 Jul 2016 #3

    Something else I tried...

    Angry Birds Star Wars is located in H:\WindowsApps so I opened Settings > Apps & Features and moved the game to my C drive, which it did without any issue. However, I am unable to move the game from the C drive to ANY other drive, whether it be H, D, E, L, K or whatever. It fails with error 0x80070005. The only thing that happens is that Windows creates a folder called WindowsApps on the drive I try to move the game to but there is nothing inside it.

    Why is it that I can move games and apps from H to C but not back from C to H? All apps and games installed on C seem to update and install OK, even new ones, so the permissions for C appear to be correct. What is triggered the Access Denied error when Windows moves a game from C to another drive? It seems to act as if it doesn't have write permissions but that can't be correct since I can move stuff from H to C and then requires the source files to be deleted after they've been copied to the target location.

    This issue is utterly baffling me as it makes no sense. I have my Download folder on my H drive as well as a Steam and Games folder and they can all be written to with no issue.
      My ComputerSystem Spec

  4. Posts : 75
    Windows 10 Pro v1703 Build 15063
    Thread Starter
       20 Jul 2016 #4

    I had to move Forza Motorsport 6 Apex from the H:\WindowsApps folder to C in order to update it last night because of this stupid 0x80070005 error. This then allowed the game to update but I am unable to move it back to the H drive or any other drive for that matter. Why?

    Does anyone on here understand Windows 10 security permissions and how to fix them please?
      My ComputerSystem Spec

  5. Posts : 75
    Windows 10 Pro v1703 Build 15063
    Thread Starter
       22 Jul 2016 #5

    Right here is what I definitely know:

    1. Windows Store apps and games can ALL be downloaded and installed without issue (i.e. error 0x80070005) when the default Storage location is left at C: (which is my boot SSD where Windows 10 Pro is installed). This includes both new ones and existing ones.

    2. Windows Store apps and games CANNOT be updated if they are located on my H: drive (in the H:\WindowsApps folder), which I'd previously moved there some months ago to free space on my boot SSD. Until the last couple of weeks they have always updated fine but recently stopped working, possibly as a result of upgrading to v1607 of Windows via the Insider Preview.

    In the last couple of days the Windows Store found updates for both Killer Instinct and Forza Motorsport 6: Apex (Beta) but both failed consistently with error 0x80070005.

    3. However, I've found that I am ABLE to move apps and games from the H: drive to the C: drive and then update them from there as long as I have space. I did this for Forza Motorsport 6: Apex (Beta), which updated without error a few days ago, but while I have been able to move Killer Instinct back to my C: drive, I am unable to update it because I do not have enough space.

    4. I am unable to move games or apps from the C: to the H: drive or any other drive either, which includes D:, E: (my games drives), I:, J: and K: (my external backup drives). I get error 0x80070005. This includes both Forza Motorsport 6: Apex (Beta) and Killer Instinct, the former of which updated fine.

    5. I am unable to move games or apps from the H: drive to other non-C: drives such as D: or E:; they fail with error 0x80070005.

    6. When I attempt to move games to another location such as a new drive which does not already have any Store apps or games on it, I can see a WindowsApps folder being created with a sub-folder for the game but there are never any files created inside it. Cancelling the move then deletes the sub-folder for the game and the WindowsApps folder remains as an empty folder.

    What can the issue be?

    I have Steam games installed on D:, E: and H: as well as Origin and Uplay titles and they all update and install to those drives without error despite the root drives being owned by SYSTEM. It's just the blasted Windows Store that seems to have issues with installing or moving anything to anywhere else but C:!
      My ComputerSystem Spec

  6. Posts : 75
    Windows 10 Pro v1703 Build 15063
    Thread Starter
       24 Jul 2016 #6

    Some more info I also posted in a thread I started...

    After using's Windows Repair All in One v3.9.5 tool in a last ditch effort to fix the error and completely messing up the Windows install (missing taskbar icons for Store, Xbox, Photos, etc, and Edge plus the Store opening and instantly closing), I decided to restore my backup of Windows 10 Pro v1511 Build 10586.494 from 14th July 2016. I then tried to move apps and games from C: to H: but got the same error so clearly the issue, whatever it is, was there before upgrading to Insider Preview Build 14393.

    That said, I was able to set the Storage location for apps to H: and download both Forza Motorsport 6 Apex (Beta) and Killer Instinct to the H: drive once I'd uninstalled them. Thinking that I had a solution to the issue, I went ahead and upgraded straight to Build 14393 again. But, and it's a big but, I am unable to download those same games to H: under this v1607 build of Windows with Storage set to H: despite it working under v1511! I have been able to download Forza to my C: drive though, once I set the Storage location to C: but, again, I am unable to move it back to H:!


    I did some reading and found that you can move Windows Store packages via Powershell so here's what I tried:

    1. Opened an elevated Powershell window;
    2. Typed Get-Appxpackages and pressed Enter which then lists all the installed apps and games.
    3. I found the full package name for Forza and typed Move-Appxpackage "Microsoft.APEXPG_1.3.12.0_x64__8wekyb3d8bbwe\AppxManifest.xml" -Volume H: (cut and paste from the listing to avoid mistyping it) and got this error:

    move-appxpackage : Deployment failed with HRESULT: 0x80070005, Access is denied.
    error 0x80070005: Creating file \\?\H:\WindowsApps\Microsoft.ApexPG_1.3.12.0_x64__8wekyb3d8bbwe\AppxManifest.xml
    NOTE: For additional information, look for [ActivityId] aaf12b4c-e58c-0001-938e-f1aa8ce5d101 in the Event Log or use
    the command line Get-AppxLog -ActivityID aaf12b4c-e58c-0001-938e-f1aa8ce5d101
    At line:1 char:1
    + move-appxpackage -package "Microsoft.ApexPG_1.3.12.0_x64__8wekyb3d8bb ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo : SecurityError: (Microsoft.ApexP...__8wekyb3d8bbwe:String) [Move-AppxPackage], PSSecuri
    + FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageManager.Commands.MoveAppxPackageCommand

    The error also contains a command for more info, Get-AppxLog -ActivityID aaf12b4c-e58c-0001-938e-f1aa8ce5d101 so I typed it and got this:

    Time ID Message
    ---- -- -------
    24 Jul 2016 12:08:00 pm 301 The calling process is powershell.exe
    24 Jul 2016 12:08:00 pm 603 Started deployment MovePackageOperation operation on a package with main
    parameter: Microsoft.ApexPG_1.3.12.0_x64__8wekyb3d8bbwe and Options:
    ForceApplicationShutdownOption. See for help diagnosing app
    deployment issues.
    24 Jul 2016 12:08:00 pm 10002 Creating Resiliency File C:\ProgramData\Microsoft\Windows\AppRepository\306e3e3f
    c for MovePackageOperation Operation on Package
    24 Jul 2016 12:08:00 pm 607 Deployment MovePackageOperation operation on package
    Microsoft.ApexPG_1.3.12.0_x64__8wekyb3d8bbwe has been de-queued and is running
    for user DARREN\Darren.
    24 Jul 2016 12:08:03 pm 10000 About to service package Microsoft.ApexPG_1.3.12.0_x64__8wekyb3d8bbwe. Setting
    the package state to disabled returned with 0x0.
    24 Jul 2016 12:08:03 pm 462 error 0x80070005: Creating file \\?\H:\WindowsApps\Microsoft.ApexPG_1.3.12.0_x64
    __8wekyb3d8bbwe\AppxManifest.xml failed.
    24 Jul 2016 12:08:03 pm 470 error 0x80070005: Package update failed for
    Microsoft.ApexPG_1.3.12.0_x64__8wekyb3d8bbwe. Re-stage package
    24 Jul 2016 12:08:03 pm 605 The last successful state reached was PreStagePackagesInUseClosed. Failure
    occurred before reaching the next state Staged. hr: 0x80070005
    24 Jul 2016 12:08:03 pm 10001 Finished servicing package Microsoft.ApexPG_1.3.12.0_x64__8wekyb3d8bbwe.
    Setting the package state to enabled returned with 0x0.
    24 Jul 2016 12:08:03 pm 401 Deployment MovePackageOperation operation with target volume H: on Package
    Microsoft.ApexPG_1.3.12.0_x64__8wekyb3d8bbwe from: (AppxManifest.xml) failed
    with error 0x80070005. See for
    help diagnosing app deployment issues.
    24 Jul 2016 12:08:03 pm 404 AppX Deployment operation failed for package
    Microsoft.ApexPG_1.3.12.0_x64__8wekyb3d8bbwe with error 0x80070005. The
    specific error text for this failure is: error 0x80070005: Creating file \\?\H:\

    Does that help identify what the issue is to anyone who understands it please? I would be so grateful for any help as this is driving me mad. My only recourse at the moment, since a clean install of Windows or even a repair install is not possible at the moment, is to buy a larger 1 GB SSD!

    Thanks in advance.
      My ComputerSystem Spec

  7. Posts : 75
    Windows 10 Pro v1703 Build 15063
    Thread Starter
       24 Jul 2016 #7

    OK, so apparently I *CAN* move games from the C: drive to a FAT32 formatted USB memory stick N:, albeit the one I am testing, Oxenfree, is very slow even though it is only 3.4 GB in size. When I try to access the N:\WindowsApps folder though I get an access denied error and I am unable to even view the security permissions. Maybe that is due to FAT32 not having security permissions? All my other drives are formatted as NTFS.
      My ComputerSystem Spec

  8. Posts : 75
    Windows 10 Pro v1703 Build 15063
    Thread Starter
       25 Jul 2016 #8

    Hundreds of reads but not one reply?

    I did some reading over the weekend and discovered that even though I've kept the same account with each Windows upgrade that a different Security ID (SID) is assigned post-upgrade. Could this be why I am having this issue?

    I was able to uninstall and redownload games (Forza and Killer Instinct) to H: with v1511 of Windows but with v1607 the same two games fail with error 0x80070005.
      My ComputerSystem Spec

  9.    25 Jul 2016 #9

    I have no pearls of wisdom, this is well above my head. But I thought I read once, somewhere, that Windows apps being stored anywhere other than C: drive was not supported but would be coming in later versions (anniversary update perhaps). So that's probably why your running into roadblocks or unpredictable results.

    I guess the reason no-one has chirped up is because everyone is stumped and there is no advice to offer. From a personal viewpoint I have little or no time for the Windows Store and it's app offshoots due to it's buggyness and penchant for breaking (whether that be the store itself or it's native apps). I guess the majority could be of same mindset. I'd never install a game through this method but rather stick with reliable sources such as Steam, Origin which can handle drive letters other than C. I sympathise with your issues as trying to work with a small SSD as your boot drive makes juggling everything very difficult.
      My ComputerSystem Spec

  10. Posts : 75
    Windows 10 Pro v1703 Build 15063
    Thread Starter
       25 Jul 2016 #10

    The option to move Windows Store apps and games was added last November I believe in v1511 Build 10586 (Settings > System > Apps and Feature - just select any Store downloaded game or app... the default storage location for apps is also set under Settings > System > Storage). The only reason I tried the PowerShell was because (a) I thought it might give me more control over the moving of files, even allowing me to actually move them; and (b) it gave me more insight into what the actual error was over the rather vague Something went wrong, error 0x80070005 errors you typically get from Windows.

    Thank you though for being the first person to actually post in this thread. I was hoping that someone like Brink might reply since he clearly knows the ins and outs of Windows.
      My ComputerSystem Spec

Page 1 of 4 123 ... LastLast

Related Threads
As suggested from the title I've been battling with this error for a while now. I am not sure when it started but this Windows 10 installation was a clean one directly from an .iso file from Microsoft meaning no tampering was done with it. It is a...
Solved Error 0x80070005 in General Support
Hello i just updated to build Windows 10 pro 1511 and i get the error 0x80070005 when i try to install facebook\readiy from the store, i have rebooted and followed this link but i am still unsuccessful, trying to avoid a system restore
when update windows 10 this morning: Security Update for Lync 2010 X64 (KB3075593). and Cumulative Update for Windows 10 for x64-based Systems (KB3081436). after both update downloaded and installed, i was asked to re-boot my laptop. but i...
Solved Windows Store 0x80070005 in Windows Updates and Activation
I can't update any apps or install new ones as well. I tried my fixes posted online and no fix. I tried the wsreset.exe and rebooted, nothing. Changed permissions for packages in my local app data folder, nothing. I can't even install Windows...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 14:14.
Find Us