Page 2 of 4 FirstFirst 1234 LastLast
  1.    25 Jul 2016 #11
    Join Date : Jul 2015
    Posts : 1,544
    Windows 10 Pro (64 bit)

    Yes someone like Brink will be well placed to advise. Your prob right on that feature, I just thought I'd read otherwise. Maybe someone else can confirm this.

    i know how you feel on the posts - I've done a few where you just end up posting to yourself and getting nowhere! The guys on here are very helpful and I just think no responses generally means nobody is sure. I don't think a repair install is the way to go as I think maybe you'll hit this roadblock again as it seems a deep rooted bug/oversight on the part of Windows itself

    one thing I have learned though is to try and stay away from those power shell fixes. They seem to create more carnage than good - at least in my experience. I'm very anti the store and the native apps and the way store updates them, they are the most buggy and troublesome aspect of Windows 10, again in my experience
      My ComputerSystem Spec
  2.    25 Jul 2016 #12
    Join Date : Sep 2015
    Posts : 51
    Windows 10 Pro v1703 Build 15063
    Thread Starter

    What I suspect may have happened, and I might be completely wrong but it kind of makes sense to me as far as I understand it, is that when I upgraded Windows 10 Pro from v1511 to v1607 that Windows updated all the security permissions for the apps and games installed on C:, including reassigning a new Security ID (SID) to my account, but "forgot" to update them for the stuff I'd previously moved to my H: drive. It seems that Windows *can* read from this folder hence why I am still able to play games like Quantum Break which is installed there (all 67 GB of it, which is why it is not on my C: drive!) but it seems unable to write to it (although I have seen it create folders in there).

    I'm not quite sure how Windows can move apps and games from H:\WindowsApps to my C: drive though since that requires it to read, copy, write to C: (which I know is OK) but also finally DELETE the original files from H:. Presumably deleting and writing have different permissions on my system because of this, i.e. Windows can delete from H: but it cannot write to it?

    I've just opened up the H:\WindowsApps folder now and tried to create a folder in there... I get a Bad Data 0x80090005 error (that is typed correctly by the way, it is not the same error as 0x8007​0005).

    I took a look at my nephew's laptop yesterday, which is running Windows 10 v1511 and I played around with downloading a small game from the Store to the default C: drive then moving it to D:. I then examined the permissions for the folders and found that the D:\WindowsApps folder was owned by SYSTEM and the D:\WpSystem folder (which is the equivalent of the C:\Users\<Name>\AppData\Local\Packages folder was owned by S-1-5-21-XXXXXXXXXXXXXX-1001 (which I think is the main user account). When Windows creates a WpSystem folder on my system it shows as being owned by Administrators\Darren, not as an SID string. Not sure if this is part of the problem though.
      My ComputerSystem Spec
  3.    25 Jul 2016 #13
    Join Date : Jul 2015
    Posts : 1,544
    Windows 10 Pro (64 bit)

    The lack of a string on your machine does sound like a key difference. You seem to of done a lot of hard work. I totally understand your rationale for wanting to use your H drive. There is no way the majority of users can support large game installs on the C drive if they are using SSD. Not unless you've got pots of cash to buy a 1 or 2 TB SSD drive. Mine is a 500 gb SSD and even this is half full, and I keep 99% of my games on my steam install which is on I drive.

    i will see if can message Brink to alert him. Maybe he will have an idea. Between keeping an eye on the seven forums, eight forums and ten forums I imagine he has a lot on his plate!
      My ComputerSystem Spec
  4.    25 Jul 2016 #14
    Join Date : Jul 2015
    Posts : 1,544
    Windows 10 Pro (64 bit)

    Total long shot but have you tried updating your gpu drivers? It sounds crazy but I have seen on nvidia forums about how some of the sets have been interfering with Store app updates. I don't expect it to be the answer but it's worth a shot. I still use 355 driver set and refuse to update them until there is a compelling need to do so - purely because everything is ticking along fine on these. Bizarre that could be a connection. I'll try and find the forum discussion and link it here if I can find it.
      My ComputerSystem Spec
  5.    25 Jul 2016 #15
    Join Date : Jul 2015
    Posts : 1,544
    Windows 10 Pro (64 bit)

    Found it and then realised the person who had brought this up was you!! So I presume you've already tried this

    Solved Unable to check for updates in Windows Store - Page 2 - Windows 10 Forums
      My ComputerSystem Spec
  6.    25 Jul 2016 #16
    Join Date : Sep 2015
    Posts : 51
    Windows 10 Pro v1703 Build 15063
    Thread Starter

    Yes, that was a bug in the pre-v368.xx drivers that was fixed in v368.81. I am using the latest v368.95 Hot Fix and can confirm that the issues triggered by setting MFAA to On in the Global Profile has been completely fixed for me. That was a string of non-gaming related Windows issues caused by a buggy driver but somehow I do not think I am so lucky as to be able to fix this one with a driver update, no matter how much I'd like to pin the blame on NVIDIA for it.

    Again, appreciate the feedback and assistance. I mean if I have this issue then who's to say that someone else won't several months down the line? Maybe the issue isn't being acknowledged yet because few people (a) have upgraded to Windows v1607; and (b) have moved apps and games to drives other than the default location of C:?
      My ComputerSystem Spec
  7.    25 Jul 2016 #17
    Join Date : Jul 2015
    Posts : 1,544
    Windows 10 Pro (64 bit)

    I suspect it's (b) where not too many have changed the location. I am not really clued up on the gaming scene from the store. I guess as it takes off and becomes more popular more people will try and download large GB game installs through the store and feel the need to store on secondary drives due to space constraints. Then the issue you have will become more prevalent. I am sorry it's giving you the frustrations you have - this seems to be a really complex issue that even some of the gurus resident in this forum will be hard pushed to explain. The anniversary update is almost upon us, just maybe that could bring salvation
      My ComputerSystem Spec
  8.    25 Jul 2016 #18
    Join Date : Sep 2015
    Posts : 51
    Windows 10 Pro v1703 Build 15063
    Thread Starter

    It's the Anniversary build which I have installed though via the Insider Preview: v1607 Build 14393.5. This is strongly rumoured to be close to the final version as it is just being updated with cumulative update now rather than full install builds.
      My ComputerSystem Spec
  9.    27 Jul 2016 #19
    Join Date : Sep 2015
    Posts : 51
    Windows 10 Pro v1703 Build 15063
    Thread Starter

    Just a quick update...

    I have managed to resolve this issue on my PC although, unfortunately, it now appears that the issue DID arise as a result of upgrading from v1511 Build 10586.494 to v1607 Build 143xx after all as I restored my backup of the previous build from 23rd July in the early hours of this morning, after noticing many Store games were opening and instantly closing (even after uninstalling and redownloading/reinstalling them). I tried taking taking ownership of the C: WindowsApps folder but I could not get them to load so I decided to just go back to the last stable build.

    Now I am able to move games and apps (non-system ones) from C: to H: with no error. A few games did seem to have issues starting (they'd open then close) but I believe they were ones that were on H: then moved onto C: while v1607 was installed (since I could move them from H: to C: without the 0x80070005 error as stated above). What I think happened there was that I'd restored my v1511 build again last week, after moving certain games from H: to C: to update them on build v1607, but that backup did not contain the apps on C: (since it was done before they were moved). Therefore Windows still thought they were on H: but in reality they weren't H: or even C: anymore!!!

    Anyway, I have been able to uninstall those few games and redownload them (to H: of course... FINALLY!!!). I am even downloading both Killer Instinct and Forza Motorsport 6: Apex (Beta) to my H: drive something that I have been 100% unable to do on any of the v1607 builds!

    So this thread perhaps serves as a warning for anyone thinking of upgrading to the Anniversary update on 2nd August... I would seriously consider doing a full backup of your current Windows drive first before you do so. On my system, this update seemed to have messed up the security permissions for installing Store apps and games on any drive except the Windows C: drive and I was not able to fix it (believe me, I tried just about everything I could think of).

    I will wait for the final build on the 2nd August, do another backup before I install it and then if I still have this issue then I will revert back to v1511 (for what would be the fourth time) and just defer the update until more people have been able to report feedback. It may be just specific to my setup and a one-off or it may be an issue others may have who upgrade a system that has existing apps and games that had previously been moved or installed to other non-C: drives before the upgrade.
    Last edited by Daz1967; 27 Jul 2016 at 02:46.
      My ComputerSystem Spec
  10.    27 Jul 2016 #20
    Join Date : Jul 2015
    Posts : 1,544
    Windows 10 Pro (64 bit)

    Good to hear you've sorted the issue and an important warning to people ahead of the dreaded anniversary update! Totally agree that taking a system image ahead of this update should be something people undertake. I hope post update your difficulties do not resurface, I would be very keen to hear how things are holding up once you've had a chance to run with it for a while
      My ComputerSystem Spec

 
Page 2 of 4 FirstFirst 1234 LastLast


Similar Threads
Thread Forum
Solved Windows Store 0x80070005 Error, tried multiple fixes which didnt work
As suggested from the title I've been battling with this error for a while now. I am not sure when it started but this Windows 10 installation was a clean one directly from an .iso file from Microsoft meaning no tampering was done with it. It is a...
Software and Apps
Solved Error 0x80070005
Hello i just updated to build Windows 10 pro 1511 and i get the error 0x80070005 when i try to install facebook\readiy from the store, i have rebooted and followed this link but i am still unsuccessful, trying to avoid a system restore
General Support
Windows 10 update err: 0x80070005 how to fix it location Australia
when update windows 10 this morning: Security Update for Lync 2010 X64 (KB3075593). and Cumulative Update for Windows 10 for x64-based Systems (KB3081436). after both update downloaded and installed, i was asked to re-boot my laptop. but i...
Windows Updates and Activation
Solved Windows Store 0x80070005
I can't update any apps or install new ones as well. I tried my fixes posted online and no fix. I tried the wsreset.exe and rebooted, nothing. Changed permissions for packages in my local app data folder, nothing. I can't even install Windows...
Windows Updates and Activation
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 00:27.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums