Windows 10: Windows Store 0x80070005 Error, tried multiple fixes which didnt work Solved

  1. Posts : 3
    Windows 10 Pro x64
       21 Jun 2016 #1

    Windows Store 0x80070005 Error, tried multiple fixes which didnt work

    As suggested from the title I've been battling with this error for a while now.
    I am not sure when it started but this Windows 10 installation was a clean one directly from an .iso file from Microsoft meaning no tampering was done with it.
    It is a legit activation from the start, so no tampering there either.
    My Windows Update works (actual system updates), but any updates/installations regarding Windows Store just refuses to work.
    I've tried multiple fixes I've found online:
    Relogged in the Store - achieved nothing
    Tried wsreset - achieved nothing
    Took ownership and tried switching it around multiple times - achieved nothing
    Removed registry keys as suggested on another thread - achieved nothing
    Tried sfc /scannow - achieved nothing (it did find a dll file it tried to fix regarding gpu drivers but thats another problem in itself)
    Tried running apps.diagcab (not the latest diagnostic app but it provided info which the latest one did not)
    Interestingly enough it showed a problem:
    "Service registration is missing or corrupt"
    It ofcourse failed to fix it and now I'm stuck with no idea how to proceed further, I feel like I've tried pretty much everything.

    Worthy note: Since the clean install back then I didn't immediately use my email account with the System knowing that it would create a user folder with the name of my email account, so I made a local account and then later just signed in with my email and associated the system with that. This might be a possible problem seeing as how retarded Microsoft's account and permissions system has been going lately (since Win8).

    I would really appreciate if someone guides me through a fix, post your ideas about a fix and I'll try them and report back.
    Also no viruses on this PC either, running nod32 v9 activated and have done recent scans with Malwarebytes and nod32 which found nothing.

    Click image for larger version. 

Name:	4d445dcf5c5d4a94bca5578b8aa6f07a.jpeg 
Views:	29 
Size:	76.9 KB 
ID:	86093

      My ComputerSystem Spec

  2. Posts : 3
    Windows 10 Pro x64
    Thread Starter
       22 Jun 2016 #2


    Nevermind then as I have fixed the problem myself after numerous failed attempts.
    This is what fixed it:
    1.Downloaded a program called Windows Repair (v3.9.3 Free Version)

    2.After installation run the program as administrator

    3.Head over to the Backup tab and backup your Registry and create a System Restore point.

    4.Head over to the Repairs tab and click Open Repairs

    5.Select options: 1,2(Select Win Drive in my case C:),14,28(Completely Reset App Store) and 29.
    I didn't select the side options but if you want to you can.

    6. Click Start Repairs and wait
    I wouldn't recommend interrupting it but I had some problems with the repair getting stuck at running some powershell commands (specifically command number 4). In that case I just closed the CMD window and it would continue with other repairs.

    7.After its all done close the program and restart your computer.

    8.Run the store and try updating/installing apps and it should work.

    This is what fixed the Windows Store for me, every other step I tried achieved absolutely nothing.
    I believe it was a permissions problem as the error code means that access was denied.

    I hope this post helps someone else.
    Last edited by latestduo; 22 Jun 2016 at 17:10.
      My ComputerSystem Spec


Related Threads
So I try to restore any point and get an error: 35772 I have turned off Malwarebytes and SuperAntiSpyware. I also did a sfc /scannow with no integrity violations. Running Windows 10 Pro 64bit... Any suggestions?
Solved Error 0x80070005 in General Support
Hello i just updated to build Windows 10 pro 1511 and i get the error 0x80070005 when i try to install facebook\readiy from the store, i have rebooted and followed this link but i am still unsuccessful, trying to avoid a system restore
error code 0x80070005 in General Support
Hi All. I'm new to the group. I've got 8 apps in the windows store in queue for the last three days. Every time I open store and click on check updates I get this error message as shown below..... Can anyone please help. Thankyou. Try that...
Read more: Microsoft fixes Windows 10 Store glitch | ZDNet
Solved Windows Store 0x80070005 in Windows Updates and Activation
I can't update any apps or install new ones as well. I tried my fixes posted online and no fix. I tried the wsreset.exe and rebooted, nothing. Changed permissions for packages in my local app data folder, nothing. I can't even install Windows...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 07:53.
Find Us