Windows 10: MagicDisc can't run?

Page 1 of 2 12 LastLast
  1.    16 Jun 2016 #1

    MagicDisc can't run?


    Howdy guys, windows has hurt my feelings and I'm in need of assistance! So I've got 2 windows 10 computers, my desktop and my laptop. about 8 months ago, I auto upgraded my laptop from 8.1 to 10, just to see how the new OS ran. At the time I had MagicDisc disc image mounting software installed on it, and it was still there after the upgrade, it still works just fine on my laptop to this day. I really liked a lot of the changes they made to the OS, so I was sold and decided after several months to go ahead and switch my desktop over as well.

    My desktop however, is a totally different story. I took the long road with this computer, opting instead for a freshly formatted SSD and HDD. Problem is that windows tells me every time I try to run the installer that, "This app can't run on this PC". I've tried running in compatibility mode for every different OS listed, tried running as admin, disabled smartscreen, disabled UAC, ran through command prompt, safe mode, you name it. Literally everything I can think of and two suggestions I found online all to no avail. It works flawlessly on my windows 10 x64 laptop, and I'm betting that it'll run just fine on my desktop too if only I could figure out a way to install it... I would like to install MagicDisc specifically, because I've used it for years and years now and love it, and I'm now on a mission to make sure this little problem doesn't beat me...

    If anybody has some suggestions as to how I can force this issue, I would LOVE to hear it. The OS is only a few days old, so if there's some crazy aggressive option that might force me to reformat it, I'm totally down for trying it! I don't mind re-installing Windows, but I CERTAINLY do mind microsoft thinking they have more rights to my computer than I do.

    Thanks very much in advance!
      My ComputerSystem Spec


  2. Posts : 11,861
    Windows 10 Pro
       16 Jun 2016 #2

    Not knowing MagicDisk I am unable to assist you. However, I just wanted to check if you know it that in Windows 10 you really do not need any third party virtual CD / DVD drive app; you simply double click any disk image file to mount it as a virtual drive.

    Kari
      My ComputerSystem Spec

  3.    16 Jun 2016 #3

    MagicDisk is an open source project, and the problem with a lot of open source projects is that they don't have the funds or ability to get their drivers signed by Microsoft.

    First, i'm guessing your laptop is running a 32 bit version of windows, which doesn't require driver signing, while your desktop is probably 64 bit, which does. What this means is that MagicDisk probably won't work for you on a 64 bit windows.
      My ComputerSystem Spec


  4. Posts : 3,506
    Win_8.1-Pro, Win_10.1607-Pro, Mint_17.3
       16 Jun 2016 #4

    I agree with Kari - you don't need it. Windows 10 mounts (double click: appears in File Explorer as a CD/DVD drive) or burns (right click: Burn) ISOs without 3rd party pgms.
    For Thumb drives, all you need to do is mount the ISO and copy the contents to the drive, then set the Thumb drive as Active.
    Rufus is another way you can put ISOs to a Thumb drive.

    Mystere makes a good point re: device signing (x86 v x64) - you don't tell much about the tow machines

    Win10 does a fair job trying to migrate older pgms when youupgrade. It's not perfect though and you often have to reinstall fresh.
    MagicDisc Download
    Pick Download for Windows 8 x86/x64 Edition

    But... you don't really need MagicISO - sure the issue is a headbanger, but why dent your forehead for something that is not needed?

    I know ... because!

    There are other reasons not to use some 3rd party ISO mount pgms. Some do cause BSODs and the solution is to uninstall the 3rd party pgm.
      My ComputerSystem Spec

  5.    16 Jun 2016 #5

    To Kari and Slartybart:
    I'm aware that windows now has included image mounting software, but it has some pretty big limitations. For one, it can't do anything about the DRM software from some discs. Any disk that has SecuROM or similar DRM software won't mount properly with the windows integrated mounter. I know that I could just go find a different software, but even for no other reason than the learning experience, I'm only looking for a way to bypass the windows child-locks and force this program to at least TRY to install.

    To Mystere:
    Nope, both my lappy and desktop are both x64 systems with x64 versions of windows installed.


    Thanks for the insights so far guys, keep 'em coming!
      My ComputerSystem Spec


  6. Posts : 3,506
    Win_8.1-Pro, Win_10.1607-Pro, Mint_17.3
       16 Jun 2016 #6

    Fair enough...

    Can you extract the contents of the installer pkg (Google extract installer) - try launching the installer in Command Prompt with the help option /?

    Put the contents in a regular folder and try running Magic ISO from the extracted files.
    You want to first unblock the exe (first page of Properties)
      My ComputerSystem Spec

  7.    16 Jun 2016 #7

    Mkay, I extracted the installer contents, and now have what I would assume is the installer, "mcdInst64.exe". When I run it, a cmd window flashes briefly, and then nothing... If I run it through cmd prompt, with or without the /? tag, it does nothing, just returns to the next line and awaits input.

    Going into the properties for each file, I know the "Unblock" button should be right below the "Advanced" button, but it's not there. If i try to run the program now, with or without administrator privilege, I get the following window:

    "ERROR

    MagicDisc can't open driver(mcdbus), Please make sure that MagicDisc is run as
    administrator.
    You need to right-click MagicDisc.exe on Windows Explorer, and click "Run As
    Administrator" to run"

    Not sure what comes next now, but thank you for the help so far!
      My ComputerSystem Spec

  8.    16 Jun 2016 #8

    Why not use daemon-tools instead? That's a signed driver and works fine on Windows 10. It has the secure-rom emulation and what not.
      My ComputerSystem Spec

  9.    16 Jun 2016 #9

    To Mystere:

    I really want to use MagicDisc, because A; I know it CAN work, I just don't know how to make windows let me install it, and B; it's the software that I've used for over 10 years now and I really like it.

    It's 1 part learning experience, 1 part anti-windows-child-lock rage, and 1 part software preference. If getting MagicDisc working takes too long, I may end up using another program like Alcohol or DT in the mean-time while I keep working on getting this program to install. I see a lot of value in just knowing how to bypass the windows child-locks. You remember in Vista, all the hell that "TrustedInstaller" file ownership caused? same concept...

    Any ideas or questions? I'm going cross-eyed reading through old forum posts on the matter, thanks again for the help here.
      My ComputerSystem Spec


  10. Posts : 3,506
    Win_8.1-Pro, Win_10.1607-Pro, Mint_17.3
       16 Jun 2016 #10

    hugazebra December 8, 2013 9:58:18 PM
    I just ran into the same problem with a clean build of Win7SP1 as well. It turns out the conflict was with Intel RST. Since I don't have SSD cache or RAID, I uninstalled Intel RST after which MagicDisc installed properly.

    ggrk September 2, 2014 5:46:35 AM
    Thank you, same problem here with an ASUS z87-pro board with win7 64 bit. I followed your advice and Magicdisc installed perfectly!


    In the folder with the files you previously extracted, right click > install the mcd????.inf file

    The only other thing I can suggest is to compare the two machines, especially anywhere drives are concerned (IRST, IME, Secure boot ...)

    I'm going to bow out - not being too much help.

    Best of luck
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 05:58.
Find Us