Windows 10: Groove Shows Unknown Artist & Unknown Album Solved

Page 2 of 2 FirstFirst 12

  1. Posts : 1,657
    Windows 10 Home x64 (Laptop), Windows 10 Pro x64 (Desktop)
    Thread Starter
       12 Jun 2016 #11

    I solved it by doing the following! I'm not sure which step cracked the problem.


    1. Set indexing to index the content of my music files by right clicking on the top level folder, setting the option and applying to all files and sub-folders
    2. Rebuilt the index via the Control Panel Indexing options
    3. Deleted the folders watched in Groove
    4. Deleted the Groove database at C:\Users\<username>\AppData\Local\Packages\Microsoft.ZuneMusic_<random>\LocalState\Database
    5. Started Groove
    6. Reassigned the folders to watch


    All songs now appear with the right artist & album but some album art was missing in Groove and Media Player despite being displayed correctly in iTunes. I manually updated the missing album art in Media Player and Groove then synchronised to match the Media Player album art.
    Last edited by Steve C; 12 Jun 2016 at 10:37.
      My ComputerSystem Spec

  2.    21 Jun 2016 #12

    A new groove app update just came through on store - my album art now shows! Might be worth updating to see if it improves for you guys
      My ComputerSystem Spec


  3. Posts : 19
    Windows 10 x64 Professional
       14 Aug 2016 #13

    Steve C said: View Post
    I solved it by doing the following! I'm not sure which step cracked the problem.


    1. Set indexing to index the content of my music files by right clicking on the top level folder, setting the option and applying to all files and sub-folders
    2. Rebuilt the index via the Control Panel Indexing options
    3. Deleted the folders watched in Groove
    4. Deleted the Groove database at C:\Users\<username>\AppData\Local\Packages\Microsoft.ZuneMusic_<random>\LocalState\Database
    5. Started Groove
    6. Reassigned the folders to watch


    All songs now appear with the right artist & album but some album art was missing in Groove and Media Player despite being displayed correctly in iTunes. I manually updated the missing album art in Media Player and Groove then synchronised to match the Media Player album art.
    This worked! I was playing with disabling indexing since it was interfering with my backup procedures, but it caused this. (What broke it was right clicking the drives and turning off indexing for the whole drive). I'll try some other ways of limiting the indexing. Thanks kindly.
      My ComputerSystem Spec

  4.    26 Sep 2016 #14

    I found this thread because I had the same annoying thing happening - but I solved it simply by using MP3tag to make sure that the "Album Artist" part of the tags was correctly filled in. (You don't have to use that program, but it's quicker than doing each track's "properties... details" individually.) Now everything displays correctly.
      My ComputerSystem Spec

  5.    26 Sep 2016 #15

    Since a few updates back the majority of mine started showing the art but there are a handful that don't for some reason. I am hesitant to start fiddling with tags etc. My music software of choice is iTunes which feeds our phones and iPads via iCloud music library and iTunes Match. Seeing as everything displays perfect on iTunes I'd be concerned that changing metadata could adversely affect iTunes. As much as I'd like groove to do it's job and display correctly I wonder if it's worth the risk!
      My ComputerSystem Spec


  6. Posts : 3,122
    10 Home x64 (1703) (10 Pro on 2nd pc)
       26 Sep 2016 #16

    RGrahamSmith said: View Post
    I found this thread because I had the same annoying thing happening.
    I've never found this thread because, while annoying that Groove doesn't seem to be able to handle this, Windows Media Player can. In WMP I just right-click on the 'unknown album' and choose 'Find album info'. I then get all track listings along with album artwork, which both WMP and Groove now display.
      My ComputersSystem Spec


 
Page 2 of 2 FirstFirst 12

Related Threads
BSOD cause (mostly) unknown in BSOD Crashes and Debugging
My computer has been having regular BSODs that I have tracked to ntoskrnl.exe. I have run the sfc /scannow command multiple times and it always comes back clean. I dont remember if I have tried DISM /online /cleanup-image /restorehealth or not,...
Unknown .exe? in Software and Apps
I was browsing my Task Manager for suspicous processes and I stumbled along one called 'WinStore.Mobile.exe'. Is this usual? I will post a Word Doc which includes screenshots.
I was in the process of updating several sata controllers and chipset drivers. I also installed a new USB 3.0 hub and was in the process of moving around several devices between ports. I had a problem with my keyboard which uses USB 2.0 as a...
Groove and Album details.. in Software and Apps
- anybody know how I can force Groove to accept a particular picture for an album cover? - there is actually a picture included in the music folder, but Groove hasn't picked it up, and a search from within the Groove app itself for the album...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 17:49.
Find Us