Windows 10: Unable to Uninstall Apps Multi-Profile Wide

  1.    20 May 2016 #1

    Unable to Uninstall Apps Multi-Profile Wide


    Hello, I am working for a company where we're trying to rollout some new Tablets with Windows 10; as these tablets are to be used with specific tasks in mind and potentially across multiple profiles, it would be ideal if majority of the Apps were removed PC wide. We already have it set in the group policy to disable the App Store and Cortana, and I have found many options online for running PowerShell scripts to remove the apps (Eg. Gett-AppxPackage *zune* | Remove-AppxPackage ) but when I attempt to add the -allusers portion to the code, it continues to only make the changes to the immediate profile. I have tried running this from the admin profile, and a secondary profile (running PowerShell as admin of course) but it continues to only make the change on the current profile, and the changes do not carry over to newly created profiles.

    Any suggestions at all would be appreciated, as I am running out of options to try online. If you require any more information to help troubleshoot this, just let me know.
      My ComputerSystem Spec

  2. essenbe's Avatar
    Posts : 11,342
    Windows 10 Pro and Windows 10 Pro Insider
       20 May 2016 #2

    Hello Imarch and welcome to the forums. have you tried setting the execution policy to unrestricted?
    Code:
    Set-Executionpolicy Unrestricted 
    When finished you can set it back to restricted which I am sure you would. I don't know if that would help your situation. See if there is anything here that will help. The author of this tutorial may be able to help if you post in that thread. PowerShell PackageManagement (OneGet) - Install Apps from Command Line - Windows 10 Forums
      My ComputersSystem Spec

  3. essenbe's Avatar
    Posts : 11,342
    Windows 10 Pro and Windows 10 Pro Insider
       20 May 2016 #3
      My ComputersSystem Spec


 

Related Threads
This is probably the most painful issue I have with Windows 10 right now (and likely previous versions as well, but I didn't have a multi-monitor setup back then). The monitors I have are as follows: 3840x2160 (4K UHD) monitor with preferred...
Unable to Uninstall Remote Mouse in Software and Apps
I had installed remote mouse on my computer but then decided it wasn't something I wanted so I uninstalled it in the control panel, when I restarted my computer the program wasn't in the uninstall list in the control panel but kept starting on the...
Unable to uninstall windows update in Windows Updates and Activation
Hello Experts, I am trying to uninstall Windows Update which was done recently in order to fix an issue but when I uninstall it and reboot my system it always gets installed back again. I also disabled the automatic update and deferred it also, I...
Since upgrading to Windows10 Home, I have had problems installing/uninstalling programs. The installer crashes with the message Cannot find 'C:\Users\Nik\AppData\Local\Temp\mia1\installaware.png'" 32786 I have looked in the Local\Temp...
Unable to open Edge after profile migration in User Accounts and Family Safety
Hi All, Looking for a little help with the MS Edge following a profile migration... The browser flashes the blue screen with the Egde logo and the terminates (no processes for Edge in task manager). I obviously installed Windows 10 and then...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 22:56.
Find Us