Net 3.5 unable to install even after fresh install Windows 10

  1.    22 Apr 2016 #1

    Net 3.5 unable to install even after fresh install Windows 10


    Using the DISM, restorehealth, etc.. all do not seems to work. Advise. Spend 3 days doing it... even reformatting and reinstall OS.
      My ComputerSystem Spec

  2.    23 Apr 2016 #2

    Hi.
    You've tried installing it using "Turn Windows features on or off" in Control Panel>Programs and Features?

    You could download it from MS and try installing that way.
    Download Microsoft .NET Framework 3.5 Service pack 1 (Full Package) from Official Microsoft Download Center

    Or, you could try using Powershell OneGet. The Chocolatey repository command is

    C:\> choco install dotnet3.5
    Other than these options, I'm not sure how else you could do it.

    Hope that helps.
      My ComputerSystem Spec

  3. Cliff S's Avatar
    Posts : 22,012
    Win10 Pro, Win10 Pro N, Win10 Home, Win10 Pro Insider Fast Ring, Windows 8.1 Pro, Ubuntu
       23 Apr 2016 #3

    DISM /Online /Enable-Feature /FeatureName:NetFx3 /All /LimitAccess /Source:I:\sources\sxs


    Where the /Source:I:\ is the mounted USB drive, with the Windows 10 ISO I made using Media Creation tool.
      My ComputersSystem Spec

  4.    23 Apr 2016 #4

    That also did not work.
      My ComputerSystem Spec

  5.    23 Apr 2016 #5

    Error 14003

    The referenced assembly is not installed in your system
      My ComputerSystem Spec

  6. Cliff S's Avatar
    Posts : 22,012
    Win10 Pro, Win10 Pro N, Win10 Home, Win10 Pro Insider Fast Ring, Windows 8.1 Pro, Ubuntu
       24 Apr 2016 #6

    There is no, single, correct way to install .NET 3.5, because the reasons it doesn't install are many. What worked for on person, might not work for another.

    When I need it for my Vodafone USB mobile broadband software to install. the above command worked for me.

    You need to make sure you use an Admin Command Prompt,
    and also make sure you change the source drive letter to the one the ISO is on.
    Asletter case & spacing is very important, copy & paste the command into Notepad and change the drive letter, only,then copy & paste into an admin command prompt.
    It also works if you mount an ISO in file Explorer.

    Have you tried our forums search? Windows 10 Forums - Search Results
    There are a few threads marked as solve on this subject.
      My ComputersSystem Spec


 

Related Threads
Hello guys, I need help for my new build. from a fresh install of windows 10 i try to install the drver for my IGPU Intel HD 530. each time i do that i get a BSOD with this message: VIDEO_TDR_FAILURE igdkmd64.sys Or sometimes it's...
I just installed Windows 7 Service Pack 1 Home Premium, using my Upgrade Disc, on a broken Vista machine. Windows Update says I have 289 important updates. Do I need to install these or can I go straight to Windows 10? In a possibly related...
Solved unable to fresh install-help! in Installation and Upgrade
I have a Dell Inspiron 17R 5720 laptop. It had 8.1 on it. It was upgraded to Win10, used one day, then crashed, and unable to boot. When handed to me for inspection, I found the partitions were all kinds of messed up. After several attempts to...
Hi, I'm running an MSI 280 Gaming 3G in my desktop. I never had trouble installing drivers until I upgraded to 10 from 8.1. I am now unable to install Catalyst Control Center. It gets stuck, as shown in the attached picture, during the...
This is on an old eMachines M6805 laptop that originally came with XP 32-bit. I put a fresh install of Windows 7 32-bit on it which ran fine. I then upgraded that to Windows 10 32-bit. The first time it booted up I was able to log in but got a...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 08:16.
Find Us