Windows 10: Mail app will not open on 10041. Solved


  1. Posts : 804
    10 Pro Preview x64
       19 Mar 2015 #1

    Mail app will not open on 10041.


    After upgrading to 10041 the mail app was missing. Installation through the store failed with Event ID 214, AppReadiness

    Code:
    'microsoft.windowscommunicationsapps_8wekyb3d8bbwe' install failed for xxxxxxxxxxx@xxxxx.com. Error: 'To install this application you need either a Windows developer license or a sideloading-enabled system.' (0.8124167 seconds)
    Following this guide I set Allow all trusted apps to install to enabled in Group policy and it installed OK but will not open. Event ID 5973 is seen in event viewer
    Code:
    Activation of app microsoft.windowscommunicationsapps_8wekyb3d8bbwe!Microsoft.WindowsLive.Mail failed with error: The application cannot be started. Try reinstalling the application to fix the problem. See the Microsoft-Windows-TWinUI/Operational log for additional information.
    and in TWinUI/Operational log is the error blocked with error 0x80073CFC because its package is in state: 64.
    Code:
    Activation of the app microsoft.windowscommunicationsapps_8wekyb3d8bbwe!Microsoft.WindowsLive.Mail for the Windows.Launch contract was blocked with error 0x80073CFC because its package is in state: 64.
    Any ideas what to try?
    Last edited by adamf; 19 Mar 2015 at 05:07.
      My ComputerSystem Spec


  2. Posts : 20,755
    64-bit Windows 10 Pro build 16199
       19 Mar 2015 #2

    Hello Adam,

    This is the suggested solution below if you haven't already tried it.

    In this Windows 10 build 10041, the Mail, Calendar, and People apps may be broken due to a licensing issue with the Store Beta. To get these apps working again, you need to follow these steps:

    • Open powershell as administrator
    • Run the command Get-appxprovisionedpackage –online | where-object {$_.packagename –like “*windowscommunicationsapps*”} | remove-appxprovisionedpackage –online
    • Re-install Mail, People and Calendar from the Store (green tile)
      My ComputersSystem Spec


  3. Posts : 8,304
    Windows 10 Professional
       19 Mar 2015 #3

    Brink said: View Post
    Hello Adam,

    This is the suggested solution below if you haven't already tried it.

    In this Windows 10 build 10041, the Mail, Calendar, and People apps may be broken due to a licensing issue with the Store Beta. To get these apps working again, you need to follow these steps:

    • Open powershell as administrator
    • Run the command Get-appxprovisionedpackage –online | where-object {$_.packagename –like “*windowscommunicationsapps*”} | remove-appxprovisionedpackage –online
    • Re-install Mail, People and Calendar from the Store (green tile)
    Hey Shawn,
    I did that to no avail, then I ran WSReset.exe; now I'm good on all 3, Mail, Calendar and People!
    Go figure!

    Store Cache - Clear in Windows 8
      My ComputersSystem Spec


  4. Posts : 11,221
    Windows 10 Pro
       19 Mar 2015 #4

    To get it working you need to first remove Mail, Calendar and People app using an elevated PowerShell, see this post: Windows 10 Technical Preview Build 10041 now available - Page 7 - Windows 10 Forums.

    When done go to the Windows Store (the "real" one with a green tile in Start Menu > All apps > S > Store (important: not the Store Beta)) and search for Mail, Calendar and People app and reinstall it.

    Works like a charm .
      My ComputerSystem Spec


  5. Posts : 804
    10 Pro Preview x64
    Thread Starter
       19 Mar 2015 #5

    Thanks all. I did a clean install, then Get-appxprovisionedpackage –online | where-object {$_.packagename –like “*windowscommunicationsapps*”} | remove-appxprovisionedpackage –online and then it re-installed fine.

    Prior to the clean install it didn't work - perhaps the setting Allow all trusted apps to install to enabled in Group policy made it worse. Anyway, mail is working so I'm happy again
      My ComputerSystem Spec


  6. Posts : 20,755
    64-bit Windows 10 Pro build 16199
       19 Mar 2015 #6

    Great news Adam.
      My ComputersSystem Spec


  7. Posts : 11,221
    Windows 10 Pro
       19 Mar 2015 #7

    brink is always faster than a thought . My reply was unnecessary, Brink had already answered.
      My ComputerSystem Spec

  8.    19 Mar 2015 #8

    Great job guys and gals! This worked flawlessly, thanks.
      My ComputerSystem Spec


  9. Posts : 1
    Windows 10 Technical Preview 10049
       06 Apr 2015 #9

    Hello,
    I am new in this forum and found you because I have had the same problem on three of my machines. For one the work around worked, for the other two it has not worked. Maybe because there is a different bug in 10049? Anyway the work around described above does not work for me in 10049 (installed as an upgrade on the fast ring). I get an error code 800 73 cff in the green Store and the message This purchase can not be finsihed (or something similar) and the installation fails. Has a different issue been reported for the 10049 for the same app and a different work around that we ought to be aware of?
      My ComputerSystem Spec


  10. Posts : 804
    10 Pro Preview x64
    Thread Starter
       06 Apr 2015 #10

    I upgraded from 10041 to 10049 and had to repeat the same thing:

    1. Get-appxprovisionedpackage –online | where-object {$_.packagename –like “*windowscommunicationsapps*”} | remove-appxprovisionedpackage –online

    2. + R then type WSreset and press enter to reset and open the Green store.

    3. Reinstall apps from the Green store that opens.

    Perhaps the store reset is your missing step...
      My ComputerSystem Spec


 

Related Threads
Mail and Calendar Apps won't open in Software and Apps
I just installed the Windows 10 Preview on my Surface Pro 3 and immediately updated it to the 10130 build. Anytime that I try to open up the Mail and Calendar apps, both will pop up for 1 second and then immediately crash. I've searched fixes but...
I'm a bit slow jumping on the Insider Preview bandwagon, and as 10 is literally around the corner I thought I'd better get some practice in so I've only just installed Windows 10 for the first time today. I'm on build 10074 and have added my...
Hello All. I have added an Exchange 2010 email account to my secondary laptop running the latest version of Windows 10 TP - 10122. I can successfully add the account and configure it and, as with Windows 8, a pop-up message appears asking me...
No sound in 10041 in Drivers and Hardware
Would appreciate any help. Thanks
PDF re-open in Software and Apps
I have a small annoying problem, after I closed a pdf with the X , it re-open after a wild. Can be a problem if it's a confidential documents
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 01:44.
Find Us