1.    03 Apr 2016 #1
    Join Date : Apr 2016
    Christchurch
    Posts : 5
    Windows 10 Pro - 64 Bit

    Issues with 64bit software


    Ever since i've upgraded to windows 10 (fresh install), I've had issues with running 64 bit versions of software. I'm not sure i can describe the problem accurately, but it's internet/network related. When using git, it will not relsolve hostnames or ip addresses (and i'm pretty sure you don't relsolve ip addresses, but that's the error it gives). Can use the ping command from git fine, just can't clone, push or pull. When using VLC, i can't stream videos from youtube, it comes up with an error saying the input cannot be opened. When running java applications if i use the 64 bit environment, i can't connect to anything that requires authentication (such as online minecraft servers, can connect to servers running in offline mode just fine though). I only run into these problems when using the 64bit versions of the applications, the 32bit versions work just fine. Has anyone encountered something like this before, and can point me in the right direction?

    Just to add a little more info, the 64 bit versions worked just fine on windows 7 and 8.1. - which is what peeves me off the most.

    EDIT: The only things i can think of, is that it there is a problem with using MinGW-w64 to compile binaries to be used on windows 10, or it's a problem with windows 10
    Last edited by Datgoat; 03 Apr 2016 at 07:00. Reason: extra thoughts
      My ComputerSystem Spec
  2.    03 Apr 2016 #2
    Join Date : Jan 2015
    UK, Midlands
    Posts : 11,137
    Win 10 Pro (1703)

    Well, I'd never tried streaming media from a URL through a player like that.. but I agree, none of vlc player, winamp or zoom player succeeds in playing from youtube. And I'm using the 32 bit version of vlc player v2.2.1 on Win 10 Pro x64.
      My ComputerSystem Spec
  3.    03 Apr 2016 #3
    Join Date : Jul 2014
    San Jose, California
    Posts : 2,207
    Ubuntu14.04x64 MintMate17x64 Win10Prox64

    I think your problem is with the network/firewall settings. I use VLC 2.22 X64 and can stream from youtube: TAYLOR vs. TREADMILL - YouTube
    You can try to download the new 64 bit version 2.2.2: VideoLAN - Downloads
    It's an installer but actually you can just unzip it with 7-zip to your desktop and run from there
    Click image for larger version. 

Name:	2016-04-03_5-25-40.jpg 
Views:	4 
Size:	202.5 KB 
ID:	72819
      My ComputerSystem Spec
  4.    03 Apr 2016 #4
    Join Date : Apr 2016
    Christchurch
    Posts : 5
    Windows 10 Pro - 64 Bit
    Thread Starter

    If only the issue was that simple. Just tried using VLC 2.2.2 X64, but i still have the same issues.
    Click image for larger version. 

Name:	VLC error.PNG 
Views:	1 
Size:	38.1 KB 
ID:	72823
    I'm pretty sure it's not a firewall issue.
    I've turned off windows firewalls temporarily in the past to test this.
      My ComputerSystem Spec
  5.    03 Apr 2016 #5
    Join Date : Jul 2014
    San Jose, California
    Posts : 2,207
    Ubuntu14.04x64 MintMate17x64 Win10Prox64

    Open admin command. Copy and paste the line below, run to make sure no corrupted Windows files. (Will take a while to run):
    Dism.exe /online /Cleanup-Image /StartComponentCleanup&dism /online /cleanup-image /restorehealth&sfc /scannow&pause
      My ComputerSystem Spec
  6.    03 Apr 2016 #6
    Join Date : Apr 2016
    Christchurch
    Posts : 5
    Windows 10 Pro - 64 Bit
    Thread Starter

    Click image for larger version. 

Name:	DISM.PNG 
Views:	3 
Size:	28.2 KB 
ID:	72828
      My ComputerSystem Spec
  7.    10 Apr 2016 #7
    Join Date : Apr 2016
    Christchurch
    Posts : 5
    Windows 10 Pro - 64 Bit
    Thread Starter

    For those who come here looking for a solution, I never found a reasonable one. A more detailed diagnostic of the problem was that the 64 bit software i was trying to use could not see outside my local network ( this included VLC, Java (JRE and JDK), Git, and WaterFox). The most likely cause of the problem is an error in registry i would think. I ended up re-installing my OS (with a more recent image), and magically my problems were gone.
    Last edited by Datgoat; 10 Apr 2016 at 19:22. Reason: clarification
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Virtualization suddenly gone? 64bit guest / 64bit host (VirtualBox)
Hopefully somebody here can help me. I've looked around everywhere to find a solution for this issue, but this problem differs from all the threads you can find in many forums around there: it already worked well for me :sleepy: My problem: I...
Virtualization
Typing Issues with Win 10 64bit
Apologies if this has already been asked/answered, couldn't find it after a quick search. When I type in Windows 10 on pretty much anything - chrome, open office, celtx (writing software) - the cursor will frequently jump to a random point, could...
General Support
Anyone had issues with this software when installing Win 10?
Anyone had issues with this software when installing Win 10? Office 2007 This game - Battlefield Bad Company 2 FTP
Software and Apps
Issues with built in Administrator Account Windows 10 Pro 64bit
Hello everyone! I have been using Windows 7 Pro 64 Bit before, always with the built in Admin account. I have tried out Windows 10 awhile back with a clean install just to get used to it, and already noticed the issue that enabling the built in...
User Accounts and Family Safety
Playon software issues
Just installed Playon Media Server on my W10 desktop. The server and the configuration software for it work as advertised, and I can use the server from my TV via the Dish Hopper just fine. But the Playon client and IE plugin cannot find the...
Software and Apps
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 02:19.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums