Windows 10: Windows 10 apps or Store not working for some users

Page 5 of 6 FirstFirst ... 3456 LastLast
  1.    23 Feb 2016 #41

    Hi,

    The changes to the scheduled update task do not help. :-( I Had a broken Mail app on a pc that had the modification.

    Local account versus MS account. I was also looking at that.

    • I had the problem on computers with only local accounts (all admins).
    • Last week I had a local user who updated the apps. The other accounts (one local and one Microsoft) had both broken apps.
    • No idea yet: what if a Microsoft account does the app update. Is there also a risk that it ruins the apps for the other computer users (local/Microsoft account)? Someone experience with that? I guess this is your configuration ScottyBoy99?


    Maybe the "ideal" system is indeed one with only MS accounts. All my computers have ... at least one local account (backup).

    Iíd also prefer MS fixing issues rather than adding new features.

    KoenD
      My ComputerSystem Spec

  2.    23 Feb 2016 #42

    Unfortunately only having MS accounts isn't the ideal system. I only added the local account a few weeks ago and had problems before that with only MS accounts on the machine. It's looking like until MS sort themselves out we will need to live with it. I am creating a system restore point every other day at the moment. I know there are registry tweaks/fixes, keys that can be removed - maybe that can help. But the complexity and time it takes makes those things simply not worth it. Although I take my hat off to those who delve that deep and work something out.

    Personally I don't see why MS have to keep updating the native apps and risking this problem. Since I got the computer in November I have seen the calculator app update at least a couple of times. I mean, what on earth does a calculator need an app update for, how can that possibly be improved/changed? So MS like to change/tinker for the sake of change. As a result we have to play Russian roulette with these updates. Focus on bugs and not change is my mantra
      My ComputerSystem Spec

  3.    04 Mar 2016 #43

    KoenD said: View Post
    Hi,

    Iím responsible for multiple computers for our youth work. All windows 10 computers with multiple local users (administrators). Clean installed at the beginning of January.

    Windows 10 drives me kind of crazy, cause on a very regular base Store apps stop functioning. Iíve had troubles with the calculator app, the photos app and the store itself. One fine day a user starts the pc and calculator/photo or store app does not work any longer. The app appears in the search result, but itís icon is white. And under it the text ďdesktop appĒ. Iím not kidding: the store pretends to be a desktop app.

    I read some other posts on your forum about not working apps. But ďmyĒ apps think they are desktop programs.

    Then not all the users on the pc have the problem. Most of the time itís okay for one user, and for all the other users it is corrupt.

    I found a work around: make a new user. And for the new user all apps are present.

    But I kind of get a fulltime job creating new users and giving the user itís documents and itís settings back.

    Does anybody know a way to PREVENT the loss of functionality of the modern apps?
    Does anybody know a way to REPAIR the broken modern apps? I found some Powershell magic on the internet, but that did not help.

    Iíd be very grateful for any help.
    Koen
    Hi Koen,

    I'm having similar issues with the Windows Store and the camera app, and apps like calendar, mail, onedrive not working for all users.

    The issues started after patch Tuesday in January 2016 as Windows 10 was working fine before then.

    I have a computer with multiple users, and Windows Store doesn't open at all for any user. For the standard users there is a black space on the task bar where the store app is.

    I tried powershell and this messed up the camera app which is now listed under "other" for the admin user. The camera app doesn't start for all users.

    For the admin user one drive is not synchronizing and the icon is grey out in the task bar. The standard users have no issues with onedrive. Same with mail calendar which opens for standard users, but not for admin user.

    I think the best was to resolve these issues is create new user accounts giving the user itís documents and itís settings back.

    I've looked in the tutorials section, user account, but couldn't see anything about how to do this.

    As you've made 100 new users I'm sure you will be able to explain the best way to do this.

    Thanks.

    David
      My ComputerSystem Spec

  4.    05 Mar 2016 #44

    Many Many Thanks & Mahalos to all of you who have found ways to solve this windows store and apps problem and shared your advice and solutions. With your help I've fix my computer and I am happy again ..... Jon
      My ComputerSystem Spec


  5. Posts : 1
    windows 10 pro 64 bit
       05 Apr 2016 #45

    Hi KoenD,

    I am experiencing the same frustrating problems with my PC... But creating new profiles for me is not a piece of cake with all the settings per profile/apps...

    Please keep us posted if you find a solution since; Microsoft seems to be ignoring all those problems...

    Thank you


    KoenD said: View Post
    Hi,

    Iím responsible for multiple computers for our youth work. All windows 10 computers with multiple local users (administrators). Clean installed at the beginning of January.

    Windows 10 drives me kind of crazy, cause on a very regular base Store apps stop functioning. Iíve had troubles with the calculator app, the photos app and the store itself. One fine day a user starts the pc and calculator/photo or store app does not work any longer. The app appears in the search result, but itís icon is white. And under it the text ďdesktop appĒ. Iím not kidding: the store pretends to be a desktop app.

    I read some other posts on your forum about not working apps. But ďmyĒ apps think they are desktop programs.

    Then not all the users on the pc have the problem. Most of the time itís okay for one user, and for all the other users it is corrupt.

    I found a work around: make a new user. And for the new user all apps are present.

    But I kind of get a fulltime job creating new users and giving the user itís documents and itís settings back.

    Does anybody know a way to PREVENT the loss of functionality of the modern apps?
    Does anybody know a way to REPAIR the broken modern apps? I found some Powershell magic on the internet, but that did not help.

    Iíd be very grateful for any help.
    Koen
      My ComputerSystem Spec

  6.    09 Apr 2016 #46

    joeT said: View Post
    Hi KoenD,

    I am experiencing the same frustrating problems with my PC... But creating new profiles for me is not a piece of cake with all the settings per profile/apps...

    Please keep us posted if you find a solution since; Microsoft seems to be ignoring all those problems...

    Thank you
    No real solution yet. Indeed very frustrating constantly creating new users.
      My ComputerSystem Spec


  7. Posts : 4
    Windows 10 Version 1511 (OS Build 10586.318)
       28 May 2016 #47

    KoenD said: View Post
    No real solution yet. Indeed very frustrating constantly creating new users.
    I stumbled upon this thread via google search as I also am experiencing a similar issue. Even though no real solution has been found yet, I do feel better considering that this is an issue affecting many users, and therefore not my fault but that of Windows.

    I bought a new laptop for myself and my mom wants to occasionally use it too, so we need two accounts for my stuff and her stuff.

    When I first set up the PC, I set up a local account (administrator privileges) under just my first name, just like things used to be in Windows 7 and prior.

    Then I wanted to set up an account for my mom, under her first name. The thing is, Windows 10 asks for a Microsoft account, i.e. an e-mail address, so basically I made a mistake and gave her e-mail address and set it up (also admin). I then realized only her e-mail address is displayed instead of her name, which is annoying. At this point I'd like to mention I had made a restore point.

    So when I logged into her account for the first time, it changed to her full name (as registered in her microsoft account), which makes it look better, but I was bugged that I couldnt edit out her last name. However, this is not the main issue.

    The main issue is, after I logged in to her account, and the set up screens showed up ("Hi", "Getting things ready" etc.) I thought all was fine and logged out again. Then I logged back into my own account.

    And guess what? All the microsoft apps (Windows Store apps, I guess) no longer work in mine:

    For example, the Calculator doesn't work, the Mail app doesnt work, the Alarms & Clock doesnt work, the maps app doesnt work, the windows store doesnt open, and when I double click a picture, I get "the remote procedure call failed" error, so the picture viewer doesnt work either.

    What the hell is going on? I restarted but my apps still did not work (interestingly, they did on her account).

    I did a system restore to the point BEFORE I had logged into her account the first time, and lo and behold all my apps were functional again.

    Seriously what the heck?

    Right now this means I can scrap the idea of having an additional account on the laptop, as when someone logs in, it messes up my account's apps.

    In the meanwhile I have tried several permutations, always using my previously done restore point as starting position.

    1) as mentioned, tried it with her microsoft account: logged in for the first time, watched the greeting text, then looked around in her desktop, everything checks out, her apps were working, logged out, logged back into my own account and my apps werent working, not even after restart

    2) Went back to restore, removed her microsoft account, restarted to make sure, set up a local account for her with admin privileges, same procedure as above, same issue.

    3) Basically the same as 2) but also deleted the C: \Users\[Her name]\ folder to make sure everything was gone before creating a new account. Same issue.

    4) Tried changing her microsoft account's admin privileges to a standard account. Same issue. I guess I could try the permutation of setting her up with a local account with standard privileges but I'm slowly getting tired of all this experimentation. Unchecked "update apps automatically" in the Windows store as well.

    At this point I like to mention I use a cleaner tool called Advanced System Care by Iobit that, among other things, cleans my registry. I hope using that didnt somehow mess things up in my registry.

    I did try the sfc /scannow command and everything was normal, no errors detected.

    I googled a bit about apps not working and one popular solution was to copy paste some code into the windows power shell. I tried that once (I can always system restore so no damange is done) and I got a lot of RED text meaning something messed up and obviously it didnt fix the problem.

    Last edited by Sir Arun; 28 May 2016 at 11:23.
      My ComputerSystem Spec

  8.    28 May 2016 #48

    I can only sympathise. MS and native apps are screwed up when trying to use multi user accounts. Everytime there is a native app or store update it is Russian roulette as to whether they still work on other user accounts. Always take a restore point before a native app update (and keep the app updates on manual rather than auto). Basically if a native app updates fails but then works second time round - then those apps will prob be screwed for other users. Windows 10 is borked in that respect. Only way to fix is delete and re create the affected user account (a major pain) or try a system restore point and try the app updates again keeping fingers crossed they 'complete' first time !
      My ComputerSystem Spec


  9. Posts : 4
    Windows 10 Version 1511 (OS Build 10586.318)
       28 May 2016 #49

    Since the Windows Store won't open, I googled a bit on how to make it work again.

    Tried wsreset.exe, didnt work.


    Tried deleting the store cache, didnt work either.

    Of course, a repair install might solve the issue but I might lose my restore point when attempting that, not to mention all installed programs.

    Obviously a clean install will fix everything (it has to!) but then I lose all programs, settings and personal files (the latter are backed on on an external HDD, but the hassle of having to move everything back to my laptop and reinstall all programs is too much headache).

    Right now what I can do is just use my one main account and let my mom use my account as well, with her data being accessible via the Users/[Hername]/ folder tree. That way our personal files are separated but we still share one account.

    I guess I'll be sticking with this option until Windows fix this with an update.

    I am gonna be buying a new desktop pc for gaming soon anyway. And when I do that, I will try getting this whole multiple user accounts business sorted out from day 1 itself. That way it is a lot easier to do factory resets etc. if something messes up since I have no data installed yet.
      My ComputerSystem Spec

  10.    28 May 2016 #50

    An in-place repair install keeps all your programs, most settings, loses changed language, loses restore points ('cos it's a fresh Windows installation, turns system restore off..

    If you buy Laplink PCMover (or Zinstall) you can save all your installed programs and optionally data and some settings, and have all of that (or selectively) automatically reinstalled when you do a clean install.
      My ComputerSystem Spec


 
Page 5 of 6 FirstFirst ... 3456 LastLast

Related Threads
Hi, I am experiencing issues with some core apps alike store, calculator, contacts etc. The live tile is showing these apps with title like @{Microsoft.WindowsStore_2015.... etc. I tried to reinstall the apps via admin powershell but it stops with...
Hello all, So, a few days ago I noticed a problem with my apps and App Store. They will not load. Additionally, when I pull up my program menu, the shortcuts for the apps are greyed out with an exclamation mark on the bottom right hand corner....
I'll try to keep it short... after initial problems with both task bar and start menu I've followed the steps from this forum to get it working properly again. Thanx for that, it worked great! 1 day later the store and edge apps were missing...
Hi In Windows 10, how do I set the manual update of the Store apps for all users? Thanks Bye
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 17:41.
Find Us