Windows 10: Powershell reinstall of Windows 10 apps messed them all up?

  1.    16 Feb 2016 #1

    Powershell reinstall of Windows 10 apps messed them all up?

    Hi there,

    So I was having a problem with my calculator app, it would open but I couldn't click the settings to move to any other mode. If I clicked it, it would open and close immediately, making it impossible for me to actually change anything. I searched online, someone suggested using Powershell to reinstall all Windows 10 apps using the following code (which is everywhere)

    Get-AppxPackage -AllUsers| Foreach {Add-AppxPackage -DisableDevelopmentMode -Register “$($_.InstallLocation)\AppXManifest.xml”}

    I tried it, now none of my apps work, including Store, and they all start with @[Microsoft... etc. I've tried to do the process again, but nothing has helped. I've turned it on and off again.

    I'd prefer not to have to do a system reinstall because I'd like to keep my apps and keep my software, the "reset my PC" option, does that also remove your downloaded software? Like Microsoft Office, Photoshop, etc.?

    Is there any way I can either reinstall those apps or reset my PC without losing any of my files AND installed software?
      My ComputerSystem Spec

  2.    16 Feb 2016 #2

    Try system restore and select last restore point
      My ComputerSystem Spec

  3. hTconeM9user's Avatar
    Posts : 2,678
    Windows 10x64 Home Version 1803 (Build 17134) 345
       16 Feb 2016 #3

    There has been a lot posted on this forum about not using Powershell has it is not doing what it should

    Here is answers I have found about Powershell

    Reddice :Never ever run that powershell command to repair apps. All it does it breaks apps that only a refresh can fix. You have been warned.
    Clayto: Yes, I am afraid you are right. It is suspected that there is a bug in the November update for which the PowerShell command to re-register apps is a trigger. I just hope that Microsoft is about to issue a fix.

    The November update bug

    I had been hoping Microsoft would have issued a fix for the November bug by now, but as January comes towards an end without anything from them it looks unlikely. I am not often prone to criticising them, but this has been a bad business. I fear I am going to have to get my head round a re-install, as some users have recommended. I follow quite a few different forums in which I have not encountered a single example of someone resolving the issue other than by re-installing.

    I think it may be worth explaining how I came to be caught by the PowerShell app re-registration trap, as someone who had never used PowerShell before. It was as a result of using the FixWin 10 Tool produced by The Windows Club. One of its features is the procedure to re-register app(s) with a PowerShell command, which I hoped would repair a corrupt Calendar app. The rest as they say is history. My Calendar app is still in need of repair, to which is added the Store, plus a large number of important Microsoft apps which are in an even worse unusable state, and several third-party apps as well.
    Hope that helps because still not fixed as far as anyone knows
      My ComputerSystem Spec

  4.    16 Feb 2016 #4

    Yep the powershell fix is to be avoided at all costs. I've been stung by it too. But I had a system restore point prior to running this fix and luckily everything was ok after that. So try that first (assuming the restore point is from before you did the powershell command) and hopefully you'll get back to the point where only your calculator is borked.

    As for the calculator app, you could try a third party app. Or go into windows store and see if there is an update pending for calculator. Downloading it may fix it. The native apps have been very problematic when they get updated by MS. I have had the photos, calculator apps stop working on me before because of the updates. In each case I went into store and the apps were stuck updating. Manually cancelling and re downloading the updates worked for me but has messed the photos app up on other user accounts. I was forced to recreate the affected user accounts to get them working.

    In the last cumulative update MS referenced a fix for app store updates so maybe this will not be so much of a problem going forward. I think when there are several updates to apps queued up the likelihood of the process sticking and messing them up is increased. But of course that's just speculative, all I can really say is the native apps have been a big problem for me. Third party apps on the other hand have behaved just fine. The fact there is no way of easily uninstalling a native app and then redownloading (unlike third party apps) compounds the problems.
      My ComputerSystem Spec

  5.    17 Feb 2016 #5

    Hi there is this incredibly complex way of 'fixing' the broken apps
    Windows 10 apps not working - Download apps folder - All things technical - tips tricks

    which I post purely for - well- interest. You don't want to do that.

    The alternative is an in-place upgrade repair install (See the Tutorials section), which basically provides a new copy of build 10586.

    - keeps all your programs
    - keeps most of your associations
    - disables system restore (again)
    - creates Windows.old
    - means you need to redo the latest cumulative Windows update and anything else
    - takes up to (say) 2 hours excluding download time - depends on hardware.

    Note: if you create a daily scheduled task to create a restore point and use 3rd party disk imaging regularly and keep a change log you have an excellent chance of being able to recover from sthg like that much more quickly than an in-place upgrade install (which might not fix some problems anyway).
      My ComputerSystem Spec


Related Threads
How to Reinstall and Re-register All Built-in Windows Apps in Windows 10 This tutorial will show you how to reinstall and re-register all built-in Windows apps for your user account or all user accounts in Windows 10. CONTENTS: Option...
Many of the Universal Apps cannot be uninstalled because the button is inactive (grayed out). This might be 'by design' for the Technical Preview since Microsoft wants users to test the Apps. The preferred method is to use the uninstall button...
Windows 10 Version 1511 (Build 10586.71). None of built in apps are not working. What else can I do? Get-AppXPackage | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"} All of them Errors ...
Looking for a way to use powershell to remove every modern/metro app except those specified in a list. I assume you'd have to use get-appxpackage to list all apps installed, then select ones that aren't in the list. (the list would just include...
Ok so dont ask me how (long story) but i managed to corrupt all my windows modern apps and i cant use or uninstall them, the store showed that there installed and i cant redownload them or launch them. is there some way i can reinstall only all or...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 19:49.
Find Us