Photos app not working

  1.    05 Feb 2016 #1

    Photos app not working

    I noticed the photos app got an update in the last day or so. Whilst it works fine on my user account my wife and son's user account it refuses to launch. Just does nothing. Is there an easy way to fix without that risky powershell cmd making things worse?
      My ComputerSystem Spec

  2.    05 Feb 2016 #2

    Is there another photos app out there that supports the live tiles? It's funny as the live tile on the other user accounts works, you can see the photos changing. It just won't launch! I went into store under their accounts. Even though photos is installed it had the 'free' box, as if it wasn't installed. So I clicked it, it downloaded, acquired license etc but it still didn't work after that.


    I gave up on the photos app. It works in my account. Maybe a future update to windows or to the app itself will get it working again. In meantime I downloaded for the other users 'Gallery HD' which does much the same as the native app except I cannot find an option to allow for printing. In any case I downloaded Picasa desktop app which gives all that functionality. So I guess I'll just forget the native app.

    The MS store is flakey when it comes to updating native apps. It's pretty Russian roulette. I don't know what it does but it obviously tries to update for all user accounts and is prone to breaking. Seems your reasonably safe on your own user account. Although I do notice the native apps sometimes have trouble updating. I found a few of them stuck not downloading and had to cancel the downloads and then try them manually again where upon they worked. Camera, People were another couple of apps done in last day or two. They got stuck too but luckily when they installed their functionality was ok in the other user accounts. So god knows what happened to photos. MS should make it easy to uninstall a native app just like the non native apps so you have the opportunity to try and redownload it again. Pretty frustrating
    Last edited by Scottyboy99; 05 Feb 2016 at 19:33.
      My ComputerSystem Spec

  3.    06 Feb 2016 #3

    So I created an additional user account as a test and the photos app worked fine. So the problem is user account specific. Just thought I'd add that. If anyone has any pearls of wisdom let me know - unfortunately I don't trust the powershell related fixes having read some horror stories relating to these!

    of course I could delete those user accounts and create new ones but I am fed up with doing that and having to get them all back setup. I have had to do it before due to another store related issue. And of course I don't think it's going to be the last time as I can see the issue occurring again. It boils down to the fact that MS needs to provide an easy way to uninstall/reinstall native apps like photos and to be able to do it easily at user account level without disrupting other accounts
    Last edited by Scottyboy99; 06 Feb 2016 at 12:45.
      My ComputerSystem Spec


Related Threads
Photos in Software and Apps
Does W10 photo app have a facility to upload from scanner ?
photos in General Support
Is there a way using windows 10, to take a face from one pic and add to another?
PHOTOS app stopped working in Windows Insider
PHOTOS app no longer able to open a .jpg .bmp etc.... image files when I click on file getting message "windows cannot find xxxxxx.file" when right works seems like PHOTO has some serious issues, does not...
photos app in Software and Apps
the photos app keeps closing every time I try to open it. How can i fix this?
This is driving me crazy. I have PhotoShop which runs fine under win10 bty BUT I really like the little Photos app for quick editing however. It doesn't work all the time. The app itself never fails to launch but with about half of the pictures...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 08:42.
Find Us