Page 1 of 2 12 LastLast
  1.    08 Jan 2016 #1
    Join Date : Jan 2016
    Posts : 19
    Windows 10

    Calculator doesn't initiate.


    After an update my calculator fails to initiate. When I double-click the app it shows on the desktop for about half a second as a shadow but disappears in an instant. I've rolled back the update but it didn't solve the problem. So now I am trying to uninstall it in order to upload the new one (https://www.microsoft.com/en-us/stor...r/9wzdncrfhvn5 ) but I've got this message in my Windows Powershell:
    Click image for larger version. 

Name:	calcERROR.jpg 
Views:	9 
Size:	86.3 KB 
ID:	57612

    What's going on and how can I fix that?
    Thanks in advance.
      My ComputerSystem Spec
  2.    08 Jan 2016 #2
    Join Date : Jul 2015
    Posts : 3,820
    10 Pro

    That message is saying it doesn't exist.

    You could try uninstalling for all users with this from elevated powershell (right click and run as administrator).
    Code:
    Get-appxpackage -allusers | where-object {$_.packagename -like "*windowscalculator*"} | remove-appxpackage
    
    Get-appxprovisionedpackage –online | where-object {$_.packagename –like "*windowscalculator*"} | remove-appxprovisionedpackage –online
    (from option 3 here)

    What does the store say when you try to install it? That it is installed already?
      My ComputerSystem Spec
  3.    08 Jan 2016 #3
    Join Date : Jan 2016
    Posts : 19
    Windows 10
    Thread Starter

    Quote Originally Posted by lx07 View Post
    What does the store say when you try to install it? That it is installed already?
    Yes, hence the problem.

    I've tried your solution and it didn't work either:

    Click image for larger version. 

Name:	calcERROR2.jpg 
Views:	5 
Size:	76.9 KB 
ID:	57618

    Also, I can't uninstall it through "Apps & features":

    Click image for larger version. 

Name:	calcERROR3.jpg 
Views:	2 
Size:	106.8 KB 
ID:	57619
      My ComputerSystem Spec
  4.    08 Jan 2016 #4
    Join Date : Jul 2015
    Posts : 3,820
    10 Pro

    Quote Originally Posted by smerH View Post
    Yes, hence the problem.
    Did you try the other 2 powershell commands?
      My ComputerSystem Spec
  5.    08 Jan 2016 #5
    Join Date : Jan 2016
    Posts : 19
    Windows 10
    Thread Starter

    Quote Originally Posted by lx07 View Post
    Did you try the other 2 powershell commands?
    I've just tried, see above.

    P.S. It looks like "Microsoft Alarms" and "Microsoft People" are screwed up too.
      My ComputerSystem Spec
  6.    08 Jan 2016 #6
    Join Date : Jul 2015
    Posts : 3,820
    10 Pro

    You can't uninstall some apps through Apps and features (and calculator is one of them for some reason) - that is normal.

    It isn't normal to have them starting with @ though or having the icon for candy crush soda for the camera app.

    I would download Windows 10 ISO and do a repair install - you can keep your programs and files but it will replace your store apps with default. It is the only reliable way of fixing apps I think. You can see here Repair Install Windows 10 with an In-place Upgrade - Windows 10 Forums
      My ComputerSystem Spec
  7.    08 Jan 2016 #7
    Join Date : Jan 2016
    Posts : 19
    Windows 10
    Thread Starter

    O.K., thanks. I didn't know it was that bad.
    Should I leave the thread open or have it marked as "Solved"?
    Last edited by smerH; 09 Jan 2016 at 04:16.
      My ComputerSystem Spec
  8.    08 Jan 2016 #8
    Join Date : Jul 2015
    Posts : 3,820
    10 Pro

    The apps to seem to get corrupted like this fairly often (it has happened to me more than once). The repair install seems to be the most reliable fix to me.

    It doesn't take too long after downloading an ISO - you just mount the ISO, double click on setup.exe and wait.

    It takes about 1/2 or 3/4 hour (rebooting a few times) for me. That isn't too long compared to spending hours and hours running different powershell commands that (in my case) never seem to work.

    I'd leave the thread open until it is fixed in case you have more questions.

    Good luck
      My ComputerSystem Spec
  9.    08 Jan 2016 #9
    Join Date : Jul 2015
    Poole Dorset UK
    Posts : 2,567
    Windows 10 x64 Home Version(1709) Build16299.125

    Calculator installed ok from the store tested it and working ok.
    So have you tried running the trouble shooter at all as that might fix your problem
      My ComputerSystem Spec
  10.    08 Jan 2016 #10
    Join Date : Nov 2015
    Posts : 4,892
    windows 10 Home threshold2

    smerH,
    You mentioned you had "roll back the update".
    I assume you meant you uninstalled that update.
    I would like you you to go one step further.........................
    Providing you do create restore points regularly.
    Do a system restore. Pick a date that is a few dates BEFORE you installed that update. Use that date as your restore point.
    System Restore Windows 10
      My ComputerSystem Spec

 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
Need Old Calculator
Howdy, I want to use the old calculator from Windows 8.1 in Windows 10. The new metro app is pretty slow and ugly, I think. I copied calc.exe from System32 and SysWOW64 folder of Windows 8.1 to my Windows 10 but it won't run. I searched the web...
Software and Apps
Calculator app update
Noticed when I tried to launch Calculator tonight it was just flashing open for a milli second then closing. Went into Windows Store and saw calculator stuck on updating. I paused the update and then clicked the circular arrow to re-download. This...
Software and Apps
Calculator seems to be broken.
This is annoying... 16277 Does anyone know of a fix yet?
Software and Apps
Calculator pops up every second
Calculator pops up every second. Can not stop it only by shutting down my pc. How can I resolve this or how do I delete calculator? Thnx! Ron
Software and Apps
Calculator won't run
Sorry if there is already a thread for this, I couldn't find one... I cannot get the calculator to run, nothing happens. I just upgraded yesterday and it went fine, but this won't work. Maybe it's related to the store hanging? Thanks for any...
Software and Apps
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 21:43.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums