Hello everyone,

I have just done the upgrade from windows 7 64 Bit, To Windows 10 andi must say i am enjoying the fresh new look so far but i have a minor yet annoying issue. I have noticed when i double click on teamspeak3 and then try and connect to a server it cause my steelseries rivals mouse cursor to just LOCK and i cannot do anything apart from restart the computer.

i have tried the following and they have not worked.

1. uninstall/reinstall teamspeak 3 deleting all previous files/folders.
2. closing down the steelseries software before opening teamspeak.
3. unplugging and reconnecting USB steelseries mouse it mreley powers down then back on but cursor remains locked in last position.

However when i plug in a different mouse during the "lock" with the steelseries mouse still connected i can use the cursor ONLY with the second mouse not the steelseries as it remains locked, but as soon as i close teamspeak the steelseries mouse starts to work again. the only way i can use teamspeak with the rival is right click and run as admin. I have tried to set it to always run as admin via right click properties and choosing the appropriate box and as far as i beleive this worked but still cause the crash i have to actually maually right click run as admin.

I can normally open team speak via the double click method and when its open the mouse is fine its as soon as I connect to a server the lock up occurs.

after a fresh install of teamspeak the normal double click method worked and there was no crash but as soon as i restart the computer the problem re-occurs.

I understand this is a very minor problem but i didnt have this issue in windows 7 i could just double click and away i go, now if i do this i have to either restart the system OR connect another mouse close teamspeak and then right click run as with the steelseries mouse. i have noticed since upgrading to windows 10 my mouse has sort of frozen on other screens but only for a split second but something isnt right.

My next option would be uninstalling and reinstalling the steelseries software but I do have a few profiles so would rather not go down this route but if its the only option then needs must. perhaps removing the mouse drivers? but as i am not familiar with windows 10 yet if that is an option would someone be kind enough to talk me through.


The right click and run as admin is not working now only when I restart the system does this method work.

Any help would be much appreciated.

Thanks for reading.