1.    25 Dec 2015 #1
    Join Date : Jul 2015
    Finland
    Posts : 88
    Win 10 Pro

    A couple of q's - startup programs automatically and broken start menu


    Hello,

    I'm trying to run programs upon boot in W10 but it doesn't work.
    I have put them in Start folder and if I go to Task manager I can see the programs are there as well in Startup tab and enabled...but they will not start. I have to manually launch them anyway.

    I found out a thread where someone was able to get a fix in the same situation by going to taskbar and menu properties and selecting 'use the Start menu instead of start screen' but alas, my menu has no such tab.

    Any ideas how to try to get them programs to launch upon boot would be appreciated. The machine was just freshly clean installed with W10 and it has but a couple of programs on it - exactly the programs I'd like to auto-start. Done all windows updates as well.

    Another machine of mine developed a weird glitch in that the start menu doesn't suddenly work at all.
    It just raises a red box in the middle of screen saying something like 'oops your start menu doesn't seem to work but don't worry, we'll fix it up for the next boot' and then it promptly reboots, but whatever I try it doesn't get fixed. I have updated the machine several times without issues and it works fine, just can't use the start at all or it reboots...been using it for a month now as it is now, got the big updates and all...but it doesn't get fixed. Start menu would sometimes be rather convenient in a machine, no? Well any ideas about how to try to fix that as well would be welcome.

    The latter machine I might just re-install clean anew. I have 7 windows boxes all now W10 and it appears every one needs to be freshly clean installed to W10 before they really start working well.
      My ComputerSystem Spec
  2.    25 Dec 2015 #2
    Join Date : Jul 2015
    Posts : 9,141
    Windows 10 Pro

    As far as running a program, this is pretty much the same procedure in Windows 10:
    Task - Create to Run a Program at Startup and Log On - Windows 7 Help Forums
      My ComputerSystem Spec
  3.    25 Dec 2015 #3
    Join Date : Jul 2015
    Finland
    Posts : 88
    Win 10 Pro
    Thread Starter

    OK an update right away...on that latter machine apparently NOTHING that looks like W10 works. Besides the start menu, the Store button gives a similar red box error message. And the looking glass icon (search) does nothing.

    I can access the start menu with a righ-button click and I can launch old-skool control panel and all those device managers and such, but the W10 style 'settings' and 'personalization' and all that is just not available at all.

    While the login screens and the taskbar look like W10, the machine however works just like W7, with all those new additions apparently suddenly not working or missing.
      My ComputerSystem Spec
  4.    25 Dec 2015 #4
    Join Date : Jul 2015
    Posts : 9,141
    Windows 10 Pro

    If you don't want to do a clean install and reinstall all your programs and keep your data, you can try this:
    Repair Install Windows 10 with an In-place Upgrade - Windows 10 Forums

    I would back up your data files before, though, just in case.
      My ComputerSystem Spec
  5.    25 Dec 2015 #5
    Join Date : Jul 2015
    Finland
    Posts : 88
    Win 10 Pro
    Thread Starter

    Thanks for the link...yeah - I'm just running installation on it now. I doubt it will help, I will likely have to format C and redo from scratch to get it fixed, but I'll give it a try!

    I just tried auto-launching the program using the TaskScheduler, but I ran into a whole different kind of problem. Now it DOES launch the program...but it launches it somehow in a way I can't use or reach it! I can see it's launched now in Task Manager and eating up 36% of CPU time but there seems to be no way to actually see or use the program. It is in the task list, but not available. Can't switch to it with alt-tab or anything...it just runs hidden somewhere in the background and not usable. Damn.
      My ComputerSystem Spec
  6.    25 Dec 2015 #6
    Join Date : Jul 2015
    Posts : 9,141
    Windows 10 Pro

    What program are you trying to start?
      My ComputerSystem Spec
  7.    25 Dec 2015 #7
    Join Date : Jul 2015
    Finland
    Posts : 88
    Win 10 Pro
    Thread Starter

    I don't really care about user data and such, these both are clean/almost new and they just have some basic stuff installed - if I format C and redo it all, it's only gonna be the 15 hours it takes to install W10 again clean, and then it's a matter of a couple of basic installations like Steam and it's a go. The machines are used for not much, the other to run an audio app (guitar amp program) and the other to run simple steam etc. games. But installing W10 takes a couple of days because they're on WiFi mostly and it takes aeons to load all the necessary stuff.

    FWIW, when I installed these machines I first tried off USB to no avail, then via a DVD I burned from the ISO and that didn't work either so I just installed it over the Internet and THEN they both installed just fine - only that it takes a reeeeaaalllly long time to install.

    On most of my machines it's been rather quick to install W10, and on two of them I have already nuked the original installation and installed on clean drive, because it seems that in the usual WIndows fashion you always need to re-install from scratch sooner or later when you update the system from the previous OS.

    Waiting to do that on my main PC as well, but have to wait until I get some work stuff out the way...can't risk messing them up. It works fine, but on about every 3rd boot it won't...refuses to load anything online, start all services and such...and needs to be rebooted and then it will work fine again. Just needs a clean new install. Been a year since I last installed Windows fresh on it so it's probably about time to do it.
      My ComputerSystem Spec
  8.    25 Dec 2015 #8
    Join Date : Jul 2015
    Finland
    Posts : 88
    Win 10 Pro
    Thread Starter

    Quote Originally Posted by NavyLCDR View Post
    What program are you trying to start?
    I have tried two, but even either of them would help---IK Multimedia's Amplitube 4 guitar amp and same company's StealthPedal MIDI driver to be used with the previous one.

    I had both start automatically on this machine when it was W7 still. Then I installed W10 on it without keeping any settings i.e. clean install and now I have this issue. They both work fine when launched manually, no issues there.
      My ComputerSystem Spec
  9.    25 Dec 2015 #9
    Join Date : Jul 2015
    Finland
    Posts : 88
    Win 10 Pro
    Thread Starter

    FWIW, the other machine - with the broken start menu - just finished the re-install process (keep all files) surprisingly quickly....only took about...2 hours? Whoa. And it works now! The menu is back there! :-)

    Really starting to get annoyed about this other machine though...whatever I try to put to startup just doesn't work, or with TaskScheduler...it runs in some hidden space completely in the background & inaccessible. Very very strange. I don't have any other users for the machine, and I'm the admin and I also turned off all password asking etc. so it automatically logs in (asked for passwords though for scheduler when I tried it) and also I keep it off the network most of the time (laptop for audio use...as few interruptions as possible) which is easy because it has a separate button turn on/off WiFi.

    It's just a Celeron and running Amp4 it barely handles it without stutters so I really need to make sure it isn't doing any background tasks or there will be artefacts in the sound. So no network etc. unless I want to run updates.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Solved Startup programs do not start with windows
hello guys, In task manager I can see all programs which are supposed to start together with windows, however, none is starting… Every time I start windows I have to start these programs manually. Anybody else with the same behavior?
General Support
Virtual Desktops and programs set to start on Win startup
Hi, I'm not sure IF this is the appropriate section to post this thread, I'm going to do it anyway, though. On Windows 10 build 10162 I have tried for the first time ever the Virtual Desktop feature. It is awesome! I wish to have at least one...
Software and Apps
Automatically search files in start menu
In Windows 7 I type xxxx.txt and it searches the file in the indexed files. In Windows 10 I have to type Find in Documents. How do I make it searches in my files without clicking a second time ?
General Support
Windows 10 Start-Menu Icons broken ?
Hello community, I just installed Windows 10 and its nice and all, just that the icons in the start menu and the system settings for programs are broken. You dont know what I mean? This is a screenshot: http://prntscr.com/7ygrd5 Hope you can...
General Support
Broken tile images in start menu. How to fix?
Upgraded the home computer this morning (win10 home). All was looking well until all of a sudden Paint.net starting showing half the image and shortly after, the Photos app as well. It only happens if I set the size of the tiles as small. Any idea...
Customization
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 04:15.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums