Windows 10: Installed Program Dates Have Changed?


  1. Posts : 1,536
    Windows 10 Home x64 (Laptop), Windows 10 Pro x64 (Desktop)
       25 Dec 2015 #1

    Installed Program Dates Have Changed?


    I noticed the installation dates of about 12 programs and drivers have been changed to 24/12/15 in Control Panel / Programs & Features (see screen shot). I haven't made any changes and Reliability Monitor does not show any automatic updates. The programs still work. What would explain this behaviour?
    Click image for larger version. 

Name:	Screenshot.JPG 
Views:	7 
Size:	271.5 KB 
ID:	55264
      My ComputerSystem Spec

  2.    25 Dec 2015 #2

    This also just happened to me again, this happens every week or so it seems. A handful of random programs install date will just jump to current day.
      My ComputerSystem Spec

  3.    14 Feb 2016 #3

    The same just happened to me and I found this thread. Any idea why it is happening?
      My ComputerSystem Spec


  4. Posts : 1,536
    Windows 10 Home x64 (Laptop), Windows 10 Pro x64 (Desktop)
    Thread Starter
       14 Feb 2016 #4

    This has since happened to me again. I can only think this is a product 'feature' of Windows 10 due to poor software QA and inadequate software testing
      My ComputerSystem Spec


 

Related Threads
Newly installed apps. ot appearing in program menu unable to pin apps to start menu. This happened to me previously and I could find no solution....I eventually created a new admin profile, where newly installed apps appeared in the program menu...
have installed Aome hdd manager on my W10 PC and laptop. on the PCs it appears in the start menu and also as an icon in the start menu. but on the laptop it is not showing, have uninstalled and reinstalled and created a shortcut from the...
I just wonder why some of my apps are not listed there?! I also tried "apps and features" from settings and still some of my installed software don't show up there either! Even tried with 3rd party uninstaller program (Revo) and still no trace of...
I messed up big time while installing 10 or shortly after I logged in. Somewhere I unchecked Photos, Mail, Camera and something else. Photos are set to open with TWINUI in properties but has a popout saying 'Element can't be found.' but can be...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 06:14.
Find Us