Page 1 of 2 12 LastLast
  1.    15 Dec 2015 #1
    Join Date : Dec 2015
    Posts : 1
    Win 10 Pro

    Problem with reinstalling default apps


    I am having a problem with reinstalling the default apps of Windows 10.

    When I have uninstalled an app, and then try to reinstall the default package through:

    Get-AppxPackage -AllUsers| Foreach {Add-AppxPackage -DisableDevelopmentMode -Register “$($_.InstallLocation)\AppXManifest.xml”}

    I get a lot of error messages in red text, and all my default apps from that point on have names that start with @{ and a version number. None of them work any more. The error messages relate to versions, if I remember correctly. Something about my versions being newer than the ones in the package. The only way to fix my problems is with system restore so far.

    I did this once before, under the first Win 10 build, and it worked fine. I think this stopped working for me since the 1511 build.

    The reason I am doing all of this, is because I am having regular problems with the default apps not working. Right now, for instance, my Photos app won't open. But I have had a lot more strange behaviour with my Win 10 upgrade. Unresponsive apps, or unresponsive start menu/taskbar items.

    I want to be able to repair things myself, before I have to resort to completely reinstalling Windows 10 again, which I think will ultimately be unavoidable, seeing as how much problems I am having with Win 10.

    Can anyone tell me what is going wrong with my default apps installation?

    Also, what would happen if I took control of the WindowsApps folder, and manually delete stuff there(if that's even possible)?
      My ComputerSystem Spec
  2.    16 Dec 2015 #2
    Join Date : Jan 2015
    UK, Midlands
    Posts : 10,422
    Win 10 Pro (1703)

    Hi, welcom to tenforums. I'll just comment on system restore, as much had been written about the problems of unresponsive taskbars and problems with universal apps- fortunately not a problem I've had, but one you can research until someone can offer you a specific reply on that.

    Build 1511 is implemented after the manner of a new Windows installation, as you'll have noticed. Thus all system restore points prior to it will be lost, inevitably. Further, system restore (for whatever reason) is usually found to be disabled after that update.

    Because the build is so implemented, you can even revert to your previous build via Settings, Update.. within 30 days (I presume).

    It might help if you can post a copy of your error message, and confirm the results of running
    sfc /scannow from an elevated command prompt, just to establish confidence in your current situation.
      My ComputerSystem Spec
  3.    16 Dec 2015 #3
    Join Date : Jul 2014
    UK
    Posts : 18,303
    Windows 10

    Seems to be an issue with the latest build

    Here is some more info on it
    Default Apps won't open or re-install, No Store App since......
      My ComputerSystem Spec
  4.    02 Jan 2016 #4
    Join Date : Dec 2015
    Posts : 6
    windows 10

    I have the same problem
    Click image for larger version. 

Name:	Untitled.jpg 
Views:	3 
Size:	75.7 KB 
ID:	56626
      My ComputerSystem Spec
  5.    02 Jan 2016 #5
    Join Date : Jan 2015
    UK, Midlands
    Posts : 10,422
    Win 10 Pro (1703)

    The link paulsalter quotes above appears to offer a solution. Windows 10 is fragile- changing some settings has untoward effects which can be tricky to resolve.
      My ComputerSystem Spec
  6.    02 Jan 2016 #6
    Join Date : Aug 2015
    San Francisco, California USA
    Posts : 945
    Windows XP/7/8/8.1/10, Linux, Android, FreeBSD Unix

    The other way to fix this is if you have a image of the drive or in my case, my 7200rpm 2.5" 750GB Western Digital HDD that I upgraded to 10586 was still available that I cloned to the new 2TB Samsung 850Pro SSD so all I did was copy the folders from the Western Digital HDD by mounting via USB for Windows Store after doing a system restore to the point right before it was broken with the Powershell commands which was only 30 minutes before.
      My ComputerSystem Spec
  7.    02 Jan 2016 #7
    Join Date : Dec 2015
    Posts : 6
    windows 10

    Thank you very much, I'm not sure if I know exactly how to do that but I will check into it .
      My ComputerSystem Spec
  8.    02 Jan 2016 #8
    Join Date : Aug 2015
    San Francisco, California USA
    Posts : 945
    Windows XP/7/8/8.1/10, Linux, Android, FreeBSD Unix

    Basically, if you had a recent copy of the drive in either image form or a actual drive, you would know since it's like backup... System Restore would be one way to fix it if you know the app worked on a certain day and time.
      My ComputerSystem Spec
  9.    03 Jan 2016 #9
    Join Date : Dec 2015
    Posts : 6
    windows 10

    Thank you so much! I did this and it fixed the problem - there were two of those @{... left but I was able to uninstall them after the process finished. I was worried that I'd lose all my programs and settings but everything was exactly the same, just without the problem apps.
      My ComputerSystem Spec
  10.    03 Jan 2016 #10
    Join Date : Jan 2015
    UK, Midlands
    Posts : 10,422
    Win 10 Pro (1703)

    Quote Originally Posted by Almighty1 View Post
    The other way to fix this is if you have a image of the drive or in my case, my 7200rpm 2.5" 750GB Western Digital HDD that I upgraded to 10586 was still available that I cloned to the new 2TB Samsung 850Pro SSD so all I did was copy the folders from the Western Digital HDD by mounting via USB for Windows Store after doing a system restore to the point right before it was broken with the Powershell commands which was only 30 minutes before.
    Just a question for future reference.. so this demonstrates System Restore does not encompass the universal apps themselves, doesn't it, as you mention both doing system restore and copying the apps folder (presumably)?

    (I encountered this problem myself when running the powershell command to reregister all - I really only needed to deal with a problem with Cortana and Location- dealt with it by restoring my very recent disk image and then finding and using a command specific to Cortana).
      My ComputerSystem Spec

 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
How do U keep Win 10 from reinstalling apps I removed? (& Privacy)
How do you keep Win10 from reinstalling apps I removed? Furthermore.. how to delete 10's metro apps that it wont let me uninstall? ( I wont ever use any metro or new UI apps so I want them All removed from my system.) I KNOW I have uninstalled...
Software and Apps
Prevent removed apps from reinstalling
Hello all, There are a few apps that keep installing themselves even after I removed them. 3D builder, Get Office, etc. Is there a way, or a couple ways to get them to NOT install once I remove them? Or to at the very least block them from...
Software and Apps
Need help reinstalling metro apps
I was installing this new game and it had errors, part of the troubleshooting of said game was to nuke the app data folder. I have deleted things from this folder in the past on previous OSes just fine with no issues. However after killing this...
Software and Apps
Problem with Default apps
Hello again everyone, This is something else I found happening to my PC since the installation of the windows 10 pro (service pack) update. I change all the default apps to apps I prefer to use by selecting them as you would in the defaults app...
Software and Apps
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 09:51.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums