1.    11 Dec 2015 #1
    Join Date : Dec 2015
    Posts : 2
    windows 10

    Google Earth won't install - admin privileges required (I am admin)

    Frustrated with admin rights - Please help me.

    Just purchased new PC - HP Pavilion desktop and upgraded to Windows 10 during installation. I've downloaded Google Chrome as my default search engine with no issues. I've attempted several times to download Google Earth. Download fails: "Google Earth needs administrator privileges to install."

    I am the only user on this PC and User Account type indicates that I'm the "Administrator".

    Why won't Google Earth install?
      My ComputerSystem Spec
  2.    11 Dec 2015 #2
    Join Date : Nov 2015
    Posts : 2,961
    64bit Win 10 Pro ver 1709 Build 16299.125

    Hello and welcome!

    Sometimes you have to run the installation file and deliberately make it "Run as Administrator" by right clicking on the downloaded file and selecting this option. Not sure if this is the case with Google Earth but worth a try.
      My ComputersSystem Spec
  3.    11 Dec 2015 #3
    Join Date : Dec 2015
    Posts : 2
    windows 10
    Thread Starter

    Unable to locate option to deliberately "run as administrator". I'm still at a loss. Any chance that Google Earth is not compatible with Windows 10?
      My ComputerSystem Spec
  4.    11 Jan 2016 #4
    Join Date : Jan 2016
    Posts : 1
    Windows 10

    Quote Originally Posted by Hitchy23 View Post
    Unable to locate option to deliberately "run as administrator". I'm still at a loss. Any chance that Google Earth is not compatible with Windows 10?
    I had EXACTLY the same problem after upgrading to Windows 10.

    1. Find the executable file that downloaded. It is probably in your Download folder, but if not, search for GoogleEarthSetup or download Google Earth again and click on the arrow on the right of the rectangular representation of the download at the bottom of the screen (if using Chrome) to see which folder your download has gone to.

    2. Right click on the GoogleEarthSetup executable (application) file when you find it and choose "Run as Administrator"

    3. After a few seconds, I then got an "Error 1603" message, so I searched for Google Earth using the Windows 10 Search facility and noticed the Google Earth desktop app was actually there. So I right clicked on it and pinned it to the Taskbar, launched it and it worked.

    It is entirely possible the program had installed the first time around, despite the "administrator privileges" error. So maybe do step 3 first and start from step 1 if it is not there.
      My ComputerSystem Spec


Similar Threads
Thread Forum
Google chrome only runs If I ask it to run as admin
Since I updated to win 10... There is an icon that looks like a shield with bluenand yellow squares on chrome icon... Any idea how to fix thi? It's annoying Thanks
Browsers and Email
My Admin Account isn't truly admin
Hi guys, I have a W10 user account attached to my microsoft account. It is listed as a full on admin account. However, with certain tasks it doesn't let me do certain admin tasks. I wanted to make changes to my hosts file, but was unable to...
User Accounts and Family Safety
Windows 10 Admin Privileges causing issue
Hi, I'm having persistent issues with Windows 10 and its user privilege settings. When running a program as administrator, I'm unable to drag and drop files as normal onto its GUI. A look at the screen record below should elaborate on what I...
General Support
Can't access Admin acct., admin files are still there
I just transferred from Windows 7, and everything worked except for the fact that the admin account on the computer (also the superuser account) cannot be accessed. The account shows up in the Users file under the Local Disk, but I can't access it...
User Accounts and Family Safety
Set Admin Privileges
How can I setup Windows 10 so it permanently has Administrative priveleges ? I am the only user here. Thanks, rs
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 02:28.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App

Windows 10 Forums