I upgraded my Samsung Magician from 4.8 to 4.9. After doing this I was presented with a firmware update to my two Samsung Evo850 SSD's. I did the update on both. All appeared to go well.

Immediately after this however, I noticed that the layout of the tiles on my Start Menu was reset, not laid out in the way I group them. No problem, just rearrange. However one tile was missing - for Flight Simulator X - the main reason this PC exists. I then noticed that this program (FSX) no longer appears in the All Apps list either. It used to be under Games or Microsoft Games I think. I am able to navigate to the fsx.exe application file in the FSX directory and it runs perfectly. This is installed on my second (F:\) non OS SSD drive. Other apps installed on F:\ are ok though. Only FSX is affected.

I tried to "Pin to Start" from the FSX folder (fsx.exe) but it does not. I created a desktop icon to the program (fsx.exe) and tried to pin that to start and it also did nothing. The desktop icon does start the program fine though.

I cannot see anything else that is wrong, just that my FSX is no longer registered as an app in the Windows Start Menu and I am guessing this is causing it to refuse to display as a tile on the Start Menu.

Does anybody have any ideas? I'm thinking maybe a simple registry edit is needed to fix this. Problem is that there are perhaps several hundreds of entries in the registry for this program and related add-ons. Reinstalling/Repairing the program is not an option right now [will take days, maybe weeks to get it back to where it is now] so, I need to find a proper fix, or live with the issue until I do find the fix. Running Windows 10 x64 Pro with the recent major Nov update installed.