Page 1 of 4 123 ... LastLast
  1.    15 Nov 2015 #1
    Join Date : Nov 2015
    Posts : 65
    10Prox64

    Data files not saving correctly [File names but zero byte files]


    I have a problem with a program not saving preset data. Possibly due to harlink extenstion with only one piece of software.

    I use symbolic hardlinks on my system but I do not know if the following has any bearing on the issue with the software I am using.

    The software is a plugin that works within a host digital audio workstation software (Steinberg Cubase and plugin Soundtoys V5) and uses presets for different settings.

    All software is legit and registered. I have contacted the developer regarding the issue with no resolve so trying here as the issue may largely be to do with windows.

    The associate plugin has been installed with admin permissions and the host DAW software is run with full administrative rights. I have double checked that there are no hardlink main or subfolders used in the installation path for the plugin software.

    All other 3rd party plugins work fine when saving presets and using symbolic links of which there's about 60+ 3rd party plugins installed using the main host system, however this particular software is not saving correctly.

    It will save the preset name as a zero byte file and reports unable to save at location.

    All other plugins work fine even when using symbolic links when saving preset data.

    The issue may have been to do with a previous install of the soundtoys software as a phantom install directory is being created during the installation

    E:\Users\Public\Documents\Soundtoys\Soundtoys 5

    I did originally install the software using the symbolic hardlink to E:\Users\Public\Documents\Soundtoys\Soundtoys 5.
    After hitting the issue of presets not saving, I uninstalled the software, manually searched both c and e drive (and registry) for any soundtoys redundant files and directories. Rebooted, ccleaned and resintalled the software plugin WIHTOUT any hardlinks,

    _____________________________________________

    On the reinstall the following problem occurs.

    When installing the software the installer creates a user preset folder with factory presets and for saving user presets to:

    C:\Users\Public\Documents\Soundtoys\Soundtoys 5

    However the software when launched automatically shows the preset bank menu as empty but all the data folders and files are present at the location

    C:\Users\Public\Documents\Soundtoys\Soundtoys 5

    This default location has all the folders, subfolders and data files within it where it should be as instructed automatically by the installer, however the save function still throw up the unable to save preset error. Saving the file name as zero bytes and unloadable.

    _____________________________________________

    Within the plugin software there is a dropdown link called organise which takes you to the preset file location (which should be C:\Users\Public\Documents\Soundtoys\Soundtoys 5).

    However the Soundtoys plugin installer has created a new folder on the secondary drive which did have an historical symbolik hardlink which has since been removed.

    E:\Users\Public\Documents\Soundtoys\Soundtoys 5

    This is where the software is trying to save the user presets and is also looking for the factory preset data by default.

    This is not specified or shown as during the install process as it clearly states data fodler at C:\Users\Public\Documents\Soundtoys\Soundtoys 5 location.

    The E:\Users\Public\Documents\Soundtoys\Soundtoys 5 is created by the system post installation,is empty except for the folder and subfolders but no physical data.

    During the installation process all folder locations are deafulted by the installer with no option to manually select an alternative folder/drive.
    _____________________________________________

    To get the software to see the factory presets I have to pick the folder and file structure using the hardlink extension from

    C:\Users\Public\Documents\Soundtoys\Soundtoys 5

    and drop as symbolic link in

    E:\Users\Public\Documents\Soundtoys\Soundtoys 5

    The plugin software now sees the expected folders and data files so works for the factory settings and preset recall.

    However the software is still unable to save to location, yet any other plugins or data can be saved fine at the locations using symbolic links or directly to the e:\users\public\... folder.

    Something maybe corrupt on my system but I do not know what and why only the soundtoys plugin software is being affected by this issue and no other plugins or software pre or post installation.

    I know it's not a permissions issue for the location as all other programs can access the user location and save files there.
    ______________________________________________

    Thoughts

    1) Would Windows have saved and somehow recall the E:\Users\Public\Documents\Soundtoys\Soundtoys 5 when isntalling this software as the phantom folder. I have not been able to locate any references on the C and E drives or registry editor.

    2) If I unintsall the Hardlink extension (Link Shell Extension) will reinstalling, will it relink the existing symbolic links that I use regularly or will the be redundant and need to be dropped into the relevant locations again.

    3) Any ideas on the phantom folder being created by windows as clearly it is not the installer.

    Thanks for your time and whilst it's a detailed post, I appreciate your help.

    Any questions shoot.

    M

    Windows 10 Pro x64
    Steinberg Cubase 8Pro x64
    Soundtoys V5 x64
    Link Shell Extension
      My ComputerSystem Spec
  2.    16 Nov 2015 #2
    Join Date : Sep 2015
    Posts : 2,373
    Windows 10 Pro 64-bit 1706 (CU build 15063.674)

    If you can select the save location, try saving to a different folder or on your desktop. It could be access right issue. I would find the specific folder, right-click on it, select Properties and then click the Security tab. To make sure there is no access restriction, I would add the user Everyone and give him (as well all the others) full access, just in case.
      My ComputerSystem Spec
  3.    16 Nov 2015 #3
    Join Date : Nov 2015
    Posts : 65
    10Prox64
    Thread Starter

    Thanks for the response.
    Unfortunately the save location is set by deafult to the hardlink location E:\Users\Public\Documents\Soundtoys\Soundtoys 5.
    There is no save as option from within the software.

    Quote Originally Posted by spapakons View Post
    If you can select the save location, try saving to a different folder or on your desktop. It could be access right issue. I would find the specific folder, right-click on it, select Properties and then click the Security tab. To make sure there is no access restriction, I would add the user Everyone and give him (as well all the others) full access, just in case.
      My ComputerSystem Spec
  4.    16 Nov 2015 #4
    Join Date : Sep 2015
    Posts : 2,373
    Windows 10 Pro 64-bit 1706 (CU build 15063.674)

    Then give full access to all users, including Everyone to this folder and see if the problem is solved
      My ComputerSystem Spec
  5.    16 Nov 2015 #5
    Join Date : Nov 2015
    Posts : 65
    10Prox64
    Thread Starter

    Click image for larger version. 

Name:	Clipboard01.jpg 
Views:	1 
Size:	153.7 KB 
ID:	48628
    I've uploaded a snap shot of the actual folder with the issue.
    I am trying to fathom out where I am going wrong.
    The one thing that jumps out is the last in the list is Read&Execute on opening this up it's greyed out
    Click image for larger version. 

Name:	Clipboard02.jpg 
Views:	1 
Size:	71.2 KB 
ID:	48629
      My ComputerSystem Spec
  6.    16 Nov 2015 #6
    Join Date : Sep 2015
    Posts : 2,373
    Windows 10 Pro 64-bit 1706 (CU build 15063.674)

    Change the owner to Administrators. Then click OK to return to the previous window. Now you should be able to change permissions by clicking Edit while on the Security tab.
      My ComputerSystem Spec
  7.    16 Nov 2015 #7
    Join Date : Nov 2015
    Posts : 65
    10Prox64
    Thread Starter

    Quote Originally Posted by spapakons View Post
    Change the owner to Administrators. Then click OK to return to the previous window. Now you should be able to change permissions by clicking Edit while on the Security tab.
    Appreciate you taking the time with this.

    Some screen shots.

    In security tab everything appears ok.
    Click image for larger version. 

Name:	c.jpg 
Views:	20 
Size:	78.3 KB 
ID:	48633

    In advance it is still showing as read&execute only
    Click image for larger version. 

Name:	a.jpg 
Views:	1 
Size:	168.6 KB 
ID:	48634
    Double click on the User (MFXSOUND\Users) last in the list and all greyed out despite previously setting everything with full rights.
    Click image for larger version. 

Name:	b.jpg 
Views:	1 
Size:	71.2 KB 
ID:	48635


    This is assuming that the Users Read right is causing the problem?

    Just loaded and tried again. Still no resolve.

    Something just doesnt look right but I cant figure it out.
      My ComputerSystem Spec
  8.    16 Nov 2015 #8
    Join Date : Sep 2015
    Posts : 2,373
    Windows 10 Pro 64-bit 1706 (CU build 15063.674)

    In case the settings are inherited from the parent folder, you are not allowed to change them. Click on the Disable inheritance button to change this.
      My ComputerSystem Spec
  9.    16 Nov 2015 #9
    Join Date : Nov 2015
    Posts : 65
    10Prox64
    Thread Starter

    Think Im starting to go down a rabbit hole of no return.
    Resulted
    Click image for larger version. 

Name:	D.jpg 
Views:	20 
Size:	61.3 KB 
ID:	48648

    Lost the other Groups and users?
    Quote Originally Posted by spapakons View Post
    Change the owner to Administrators. Then click OK to return to the previous window. Now you should be able to change permissions by clicking Edit while on the Security tab.
    Attached Thumbnails Attached Thumbnails 2015_11_16_22_45_061.png  
      My ComputerSystem Spec
  10.    17 Nov 2015 #10
    Join Date : Sep 2015
    Posts : 2,373
    Windows 10 Pro 64-bit 1706 (CU build 15063.674)

    Add user Everyone and give him full access as well.
      My ComputerSystem Spec

 
Page 1 of 4 123 ... LastLast


Similar Threads
Thread Forum
Files automatically renaming themselves, duplicate file names
I have a new laptop, so unless this is some weird feature that's specific to the laptop, then I assume it's a Windows 10 settings issue because I've never encountered anything like this before. I downloaded several JPGs and PDFs from various emails...
General Support
Solved Saving files to default Pic, Vid and Docs Problem
Hi Guys I seem to have a problem trying to save file to my default Docs, vid and Pics folder on my C drive. I have attached a pic of what it says. I have changed the permissions to let me do this or am I looking in the wrong place? If I save the...
General Support
File explorer chinese files names and phantom files.
When I launch file explorer and get the home view, it is showing a bunch of filenames in Chinese characters (see attached screenshot) which it says are in the desktop folder. However there are no such files when I look at the desktop folder. WTF? ...
General Support
Solved Editing and Saving Office Files
Since I upgraded to Windows 10 I am unable to open an existing Office file, edit and save it. I get popup messages saying that I don't have administrator permissions. I am logged in as administrator. Also, I'm told that the files are Read Only,...
General Support
asking question about .edb data files. What are they used for?
I posted or tried to post a question yesterday asking about .edb data files. I have several LARGE .edb data files on my desktop and wonder what they are for. The name associated with most of them starts out as "Catalog...............and long...
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 20:59.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums