1.    03 Nov 2015 #1
    Join Date : Nov 2015
    Posts : 3
    Windows 10 64-bit

    Java will not Install on my Windows 10 Machine


    Hello there! I've been having a very frustrating issue with installing Java on my (fairly) new Windows 10 64-bit machine, and any assistance in this matter would be so very much appreciated. I've searched all over, and posted in several tech forums searching for help, all to no avail. So any help or suggestions at all are welcome, and I am so grateful for them.


    On my previous version of Windows (Windows 7 64-bit), I had Java (32 bit and 64 bit) installed, and it worked perfectly. However, I can not for the life of me get it to install on my current machine, no matter what I do, and I have spent the better part of a week trying to find someone who's having the same issues I am, or fix the problem myself, both to no avail.
    So I turn to the experts on this forum.




    To describe my problem in much greater detail:


    I downloaded the offline installer for Java 32 bit, and 64 bit, from the manual download page: Java Downloads for All Operating Systems
    Upon trying to run the 32 bit installer (which you are supposed to install first), nothing appeared to happen. So I left it for about 20 minutes, and found it still wasn't doing anything when I came back. So I brought up my task manager to check if anything was running in the background, and found "Java Platform SE Binary (32 bit)" running there. As it appeared to be doing nothing, I ended it, and tried running it again, only for the same thing (nothing) to happen.


    I then tried the 64 bit installer, thinking maybe something had changed, and Windows 10 just didn't need the 32 bit version (upon later research finding that this is an incorrect assumption on my part). Same story with the 64 bit installer as well.


    Frustrated, I tried to search my computer, to see if it had added anything. There were no new program entries, and no Java section in my Control Panel, but there was a new folder in my Appdata, LocalLow, called "Oracle," containing a Java folder, with a "jre1.8.0_65.msi" file.
    I tried to run the MSI file, but got the following message:
    "There is a problem with this Windows Installer Package. A program required for this install to complete could not be run. Contact your support personnel or package vendor."


    I tried their official help on this matter: Error 1721: There is a problem with this Windows Installer Package
    But none of the listed steps, even all used in conjunction, did anything.


    I also tried their online installer, rather than the offline one (even though I need to use the offline ones in the end, because I need 64 bit), and it had the same issues.


    I tried searching all over to see if someone was having this same issue, but I could only find similar ones, and even upon trying their solutions, I still couldn't get it to work.


    In short, I run the installer, and nothing happens, no window, no errors, it just runs in the background indefinitely. I have tried installing in safe-mode, verifying/repairing my system files, running the installer in all available compatibility modes and as administrator, turning off my firewall and anti-virus softwares, and nothing has worked thus far. I'm out of ideas.




    Thank you very much for any and all assistance, it is much appreciated.
      My ComputerSystem Spec
  2.    03 Nov 2015 #2
    Join Date : Aug 2015
    Posts : 610
    W10

    First of all:

    The current version of Java, jre8 update 65, should be installing and working fine on Windows 10. If you have Windows 10 64 bit, then it also should be possible to install both, the 32 and the 64 bit version of Java, on the same PC.

    I just tried an installation myself:

    When I run the installer, then it will directly give me a Windows security warning, asking if want that installer to make changes to my system. Is that warning appearing for you? Or is it already failing before that point?

    Anyway, you might want to try this uninstaller:

    Information about the Java uninstaller tool

    This uninstaller however requires you to still have a running version of Java on the PC - I don't consider this implementation to be very clever, but that's how it is.

    Another option would be to manually remove the files and folders of the Java installation and to then install Java again.
      My ComputerSystem Spec
  3.    03 Nov 2015 #3
    Join Date : Nov 2015
    Posts : 3
    Windows 10 64-bit
    Thread Starter

    You're right, it should be installing just fine, but it isn't, which is why I'm trying to find out why.

    It doesn't bring up anything, as I said, nothing appears to happen. No windows, no errors.
    I've tried removing it, but nothing's there to begin with. No installation or adding of files occurs, aside from the .msi file that I mentioned in my post, which doesn't work.
      My ComputerSystem Spec
  4.    03 Nov 2015 #4
    Join Date : Jul 2015
    Posts : 3,652
    10 Pro

    Have you blocked programs from running from %appdata% by any chance? Perhaps by group policy here?

    Click image for larger version. 

Name:	Capture.PNG 
Views:	47 
Size:	72.7 KB 
ID:	46123

    You didn't mention it but did you try downloading again (not that it will make a difference I don't suppose if all methods are failing).

    I installed 64 before 32 by the way - the order doesn't matter.
      My ComputerSystem Spec
  5.    03 Nov 2015 #5
    Join Date : Aug 2015
    Posts : 610
    W10

    Quote Originally Posted by sonicboom282 View Post
    It doesn't bring up anything, as I said, nothing appears to happen. No windows, no errors.
    Have you disabled the Windows Security warnings? You can test that easily by running another "unknown" application from your desktop, e.g. another installer. If these warnings are not deactivated, then you should see such a warning message. If they are in fact activated and you don't see it, then obviously Windows is completely blocking the application...
      My ComputerSystem Spec
  6.    03 Nov 2015 #6
    Join Date : Nov 2015
    Posts : 3
    Windows 10 64-bit
    Thread Starter

    Woohoo! I just got a reply on one of the other forums I previously posted in, with a solution that appears to have worked!


    Sorry to bother, I'm super grateful for your responding so quickly to assist.


    For future reference, if anyone ends up finding this thread and is having the exact same problem, I fixed it by installing the JDK version, then just uninstalling the Dev Kit part of the install, leaving me with just the proper Java Runtime Environments.
      My ComputerSystem Spec
  7.    03 Nov 2015 #7
    Join Date : Jul 2015
    Posts : 3,652
    10 Pro

    Good news, thanks for posting solution...
      My ComputerSystem Spec
  8.    03 Nov 2015 #8
    Join Date : Aug 2015
    Posts : 610
    W10

    Quote Originally Posted by sonicboom282 View Post
    For future reference, if anyone ends up finding this thread and is having the exact same problem, I fixed it by installing the JDK version, then just uninstalling the Dev Kit part of the install, leaving me with just the proper Java Runtime Environments.
    That is interesting. However, if that helped, it's fine. :-)
      My ComputerSystem Spec
  9.    04 Nov 2016 #9
    Join Date : Nov 2016
    Posts : 1
    Windows 7 (64-bit)

    The funny thing is, I had the same issue on Windows 7 (64-bit), but only with the 32-bit Java.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Solved Clean install of W10 not possible in Virtual Machine.
Clean install of W10 not possible in Virtual Machine it won't activate. I just thought I would report one of my testings. I installed windows 7 retail in the virtual machine and it activated. I upgraded to windows 10 and it activated. I...
Virtualization
JAVA install dont start
Hi guys! This is my first post here. I have a problem about the Java install on windows 10 Pro x64 system. The problem is "install dont start even execute the setup exe". I tried below methods: I downloaded "JavaSetup8u60.exe" (571kb) from...
Browsers and Email
Windows 10 TP Latest build install on an empty machine
Right, so I've got a laptop that I'm currently trying to install windows 10 tp onto. It's the exact same model as the one I'm running on (it's my brothers, and I'm trying to fix it for him), but I've hit a snag. The insider program website says...
Installation and Upgrade
Easy way to install on a REAL machine from a VM
Hi there Having got a VM working just the way I want it I wanted to install this on a laptop as a PHYSICAL machine. (VMWARE Easy way : 1) From WITHIN the VM -- uninstall VMWARE tools or VBOX additions etc. 2) Run acronis or other imaging...
Virtualization
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 04:34.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums